aboutsummaryrefslogtreecommitdiff
path: root/editors/fxite
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2014-07-24 12:25:47 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2014-07-24 12:25:47 +0000
commit4f374c4364e36f34e75a54aac7dfacc6f22736a5 (patch)
tree8b3852edaf2f6e1152efce804e5e96fff6127b94 /editors/fxite
parentf9e45d370fb359d2d176e995985033e6e433b286 (diff)
downloadports-4f374c4364e36f34e75a54aac7dfacc6f22736a5.tar.gz
ports-4f374c4364e36f34e75a54aac7dfacc6f22736a5.zip
- Remove compiler flags not understood by GCC
- Fix the source instead
Notes
Notes: svn path=/head/; revision=362790
Diffstat (limited to 'editors/fxite')
-rw-r--r--editors/fxite/Makefile2
-rw-r--r--editors/fxite/files/patch-src_export.cpp11
-rw-r--r--editors/fxite/files/patch-src_luafx.cpp11
3 files changed, 23 insertions, 1 deletions
diff --git a/editors/fxite/Makefile b/editors/fxite/Makefile
index 1c7ee256cff2..5e97bae371f9 100644
--- a/editors/fxite/Makefile
+++ b/editors/fxite/Makefile
@@ -26,7 +26,7 @@ USES= gmake pkgconfig lua:51 desktop-file-utils
USE_AUTOTOOLS= aclocal autoconf automake
ACLOCAL_ARGS= --force -I m4
AUTOMAKE_ARGS= --gnu --add-missing --copy
-CXXFLAGS+= -fPIC -Wno-invalid-source-encoding -Wno-format
+CXXFLAGS+= -fPIC
LDFLAGS+= -L${LOCALBASE}/lib -lintl
CONFIGURE_ARGS+=--with-system-lua \
--with-lua-pkg=lua-${LUA_VER}
diff --git a/editors/fxite/files/patch-src_export.cpp b/editors/fxite/files/patch-src_export.cpp
new file mode 100644
index 000000000000..e15dafaecd60
--- /dev/null
+++ b/editors/fxite/files/patch-src_export.cpp
@@ -0,0 +1,11 @@
+--- src/export.cpp.orig 2014-07-24 14:11:00.000000000 +0200
++++ src/export.cpp 2014-07-24 14:11:00.000000000 +0200
+@@ -464,7 +464,7 @@
+ }
+ // start to write PDF file here (PDF1.4Ref(p63))
+ // ASCII>127 characters to indicate binary-possible stream
+- oT->write("%PDF-1.3\n%Η쏒\n");
++ oT->write("%PDF-1.3\n%\267\276\255\252\n");
+ styleCurrent = STYLE_DEFAULT;
+
+ // build objects for font resources; note that font objects are
diff --git a/editors/fxite/files/patch-src_luafx.cpp b/editors/fxite/files/patch-src_luafx.cpp
new file mode 100644
index 000000000000..432a39a53ab4
--- /dev/null
+++ b/editors/fxite/files/patch-src_luafx.cpp
@@ -0,0 +1,11 @@
+--- src/luafx.cpp.orig 2014-07-24 14:16:55.000000000 +0200
++++ src/luafx.cpp 2014-07-24 14:19:21.000000000 +0200
+@@ -173,7 +173,7 @@
+ switch (toupper(type[0])) {
+ case 'I' : {
+ if (!lua_isnil(L,3)) {
+- txt.format(sizeof(lua_Integer)>4?"%ld":"%d", luaL_checkinteger(L,3));
++ txt.format("%ld", luaL_checkinteger(L,3));
+ }
+ opt=INPUTDIALOG_INTEGER;
+ break;