aboutsummaryrefslogtreecommitdiff
path: root/editors/fxite
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2018-02-16 08:12:16 +0000
committerJason E. Hale <jhale@FreeBSD.org>2018-02-16 08:12:16 +0000
commit60f61d1988e6e9ff69129fc09da760963a3236be (patch)
tree5f962027f6700e5595a5dc83cc812a8bdd7ffe35 /editors/fxite
parente4d5b99f018ab05472ad6282a49e2bc1163d060e (diff)
downloadports-60f61d1988e6e9ff69129fc09da760963a3236be.tar.gz
ports-60f61d1988e6e9ff69129fc09da760963a3236be.zip
Fix build with clang 6 (C++11 requires a space between literal and identifier)
Mark FOX17 option broken (Not related to clang 6 in particular, the FOX-1.7 API is ever changing due to being a development version. This project appears to be dead, so I'm not sure it is worth fixing.) recorder.cpp:104:9: error: no matching member function for call to 'prepend' NewMessage(); ^~~~~~~~~~~~ recorder.cpp:51:6: note: expanded from macro 'NewMessage' list.prepend((FXObject*)mm); ~~~~~^~~~~~~ /usr/local/include/fox-1.7/FXObjectList.h:256:10: note: candidate function not viable: no known conversion from 'FX::FXObject *' to 'MacroMessage *' for 1st argument FXbool prepend(TYPE* object){ return FXObjectList::prepend(object); } ^ /usr/local/include/fox-1.7/FXObjectList.h:265:10: note: candidate function not viable: no known conversion from 'FX::FXObject *' to 'const FXObjectListOf<MacroMessage>' for 1st argument FXbool prepend(const FXObjectListOf<TYPE>& objects){ return FXObjectList::prepend(objects); } ^ /usr/local/include/fox-1.7/FXObjectList.h:259:10: note: candidate function not viable: requires 2 arguments, but 1 was provided FXbool prepend(TYPE* object,FXival n){ return FXObjectList::prepend(object,n); } ^ /usr/local/include/fox-1.7/FXObjectList.h:262:10: note: candidate function not viable: requires 2 arguments, but 1 was provided FXbool prepend(TYPE** objects,FXival n){ return FXObjectList::prepend(objects,n); } ^ Rename/remake patches
Notes
Notes: svn path=/head/; revision=461984
Diffstat (limited to 'editors/fxite')
-rw-r--r--editors/fxite/Makefile1
-rw-r--r--editors/fxite/files/patch-fxscintilla_ScintillaFOX.cxx (renamed from editors/fxite/files/patch-fxscintilla__ScintillaFOX.cxx)4
-rw-r--r--editors/fxite/files/patch-jef_compat.h (renamed from editors/fxite/files/patch-jef__compat.h)4
-rw-r--r--editors/fxite/files/patch-jef_interproc.cpp (renamed from editors/fxite/files/patch-jef__interproc.cpp)9
-rw-r--r--editors/fxite/files/patch-jef_shady__tabs.h (renamed from editors/fxite/files/patch-jef__shady_tabs.h)2
-rw-r--r--editors/fxite/files/patch-src__recorder.cpp10
-rw-r--r--editors/fxite/files/patch-src_appmain.h (renamed from editors/fxite/files/patch-src__appmain.h)2
-rw-r--r--editors/fxite/files/patch-src_appname.cpp16
-rw-r--r--editors/fxite/files/patch-src_appwin.cpp (renamed from editors/fxite/files/patch-src__appwin.cpp)0
-rw-r--r--editors/fxite/files/patch-src_appwin__base.cpp (renamed from editors/fxite/files/patch-src__appwin_base.cpp)4
-rw-r--r--editors/fxite/files/patch-src_appwin__base.h (renamed from editors/fxite/files/patch-src__appwin_base.h)2
-rw-r--r--editors/fxite/files/patch-src_appwin__pub.h (renamed from editors/fxite/files/patch-src__appwin_pub.h)2
-rw-r--r--editors/fxite/files/patch-src_doctabs.cpp (renamed from editors/fxite/files/patch-src__doctabs.cpp)4
-rw-r--r--editors/fxite/files/patch-src_export.cpp9
-rw-r--r--editors/fxite/files/patch-src_fxasq.cpp (renamed from editors/fxite/files/patch-src__fxasq.cpp)10
-rw-r--r--editors/fxite/files/patch-src_fxasq.h (renamed from editors/fxite/files/patch-src__fxasq.h)0
-rw-r--r--editors/fxite/files/patch-src_fxasq__lua.c (renamed from editors/fxite/files/patch-src__fxasq_lua.c)0
-rw-r--r--editors/fxite/files/patch-src_help.cpp (renamed from editors/fxite/files/patch-src__help.cpp)17
-rw-r--r--editors/fxite/files/patch-src_luacmds.cpp (renamed from editors/fxite/files/patch-src__luacmds.cpp)4
-rw-r--r--editors/fxite/files/patch-src_luacmds.h (renamed from editors/fxite/files/patch-src__luacmds.h)0
-rw-r--r--editors/fxite/files/patch-src_luafuncs.cpp (renamed from editors/fxite/files/patch-src__luafuncs.cpp)4
-rw-r--r--editors/fxite/files/patch-src_luafuncs.h (renamed from editors/fxite/files/patch-src__luafuncs.h)0
-rw-r--r--editors/fxite/files/patch-src_luafx.cpp2
-rw-r--r--editors/fxite/files/patch-src_luafx.h (renamed from editors/fxite/files/patch-src__luafx.h)0
-rw-r--r--editors/fxite/files/patch-src_macro.cpp (renamed from editors/fxite/files/patch-src__macro.cpp)12
-rw-r--r--editors/fxite/files/patch-src_macro.h (renamed from editors/fxite/files/patch-src__macro.h)0
-rw-r--r--editors/fxite/files/patch-src_menuspec.cpp (renamed from editors/fxite/files/patch-src__menuspec.cpp)2
-rw-r--r--editors/fxite/files/patch-src_migration.cpp29
-rw-r--r--editors/fxite/files/patch-src_outpane.cpp (renamed from editors/fxite/files/patch-src__outpane.cpp)0
-rw-r--r--editors/fxite/files/patch-src_prefdlg.cpp (renamed from editors/fxite/files/patch-src__prefdlg.cpp)0
-rw-r--r--editors/fxite/files/patch-src_prefdlg__sntx.cpp (renamed from editors/fxite/files/patch-src__prefdlg_sntx.cpp)2
-rw-r--r--editors/fxite/files/patch-src_recorder.cpp19
-rw-r--r--editors/fxite/files/patch-src_scidoc.cpp (renamed from editors/fxite/files/patch-src__scidoc.cpp)2
-rw-r--r--editors/fxite/files/patch-src_scisrch.cpp (renamed from editors/fxite/files/patch-src__scisrch.cpp)10
-rw-r--r--editors/fxite/files/patch-src_tagread.cpp (renamed from editors/fxite/files/patch-src__tagread.cpp)0
-rw-r--r--editors/fxite/files/patch-src_tagread.h (renamed from editors/fxite/files/patch-src__tagread.h)2
-rw-r--r--editors/fxite/files/patch-src_theme.cpp (renamed from editors/fxite/files/patch-src__theme.cpp)0
37 files changed, 127 insertions, 57 deletions
diff --git a/editors/fxite/Makefile b/editors/fxite/Makefile
index 060ed9130784..1d43994b548a 100644
--- a/editors/fxite/Makefile
+++ b/editors/fxite/Makefile
@@ -38,6 +38,7 @@ FOX16_CONFIGURE_ENV= FOX_CFLAGS="$$(fox-config --cflags)" \
FOX_LIBS="$$(fox-config --libs)" \
RESWRAP="${LOCALBASE}/bin/reswrap"
FOX17_DESC= Fox 1.7 GUI toolkit support
+FOX17_BROKEN= Fails to build: recorder.cpp:104:9: error: no matching member function for call to 'prepend'
FOX17_LIB_DEPENDS= libFOX-1.7.so:x11-toolkits/fox17
FOX17_CONFIGURE_ENV= FOX_CFLAGS="$$(pkgconf fox17 --cflags)" \
FOX_LIBS="$$(pkgconf fox17 --libs) -lX11" \
diff --git a/editors/fxite/files/patch-fxscintilla__ScintillaFOX.cxx b/editors/fxite/files/patch-fxscintilla_ScintillaFOX.cxx
index 5bd90deeb58f..e3ed009afb9d 100644
--- a/editors/fxite/files/patch-fxscintilla__ScintillaFOX.cxx
+++ b/editors/fxite/files/patch-fxscintilla_ScintillaFOX.cxx
@@ -1,6 +1,6 @@
--- fxscintilla/ScintillaFOX.cxx.orig 2013-10-03 09:22:51 UTC
+++ fxscintilla/ScintillaFOX.cxx
-@@ -171,7 +171,7 @@ private:
+@@ -171,7 +171,7 @@ class ScintillaFOX : public ScintillaBase { (private)
// From ScintillaBase
virtual bool ModifyScrollBars(int nMax, int nPage);
virtual void ReconfigureScrollBars();
@@ -18,7 +18,7 @@
// Have to call FXScrollArea::getViewportXxxx instead of getViewportXxxx
// to prevent infinite loop
#ifdef FOX_1_6
-@@ -1256,7 +1256,7 @@ long FXScintilla::onDNDMotion(FXObject*
+@@ -1256,7 +1256,7 @@ long FXScintilla::onDNDMotion(FXObject* sender,FXSelec
FXDragAction action;
FXint pos;
// Scroll into view
diff --git a/editors/fxite/files/patch-jef__compat.h b/editors/fxite/files/patch-jef_compat.h
index d49c441fafe0..3b7635dda742 100644
--- a/editors/fxite/files/patch-jef__compat.h
+++ b/editors/fxite/files/patch-jef_compat.h
@@ -78,7 +78,7 @@
FXID GetNetActiveWindow();
void WaitForWindowFocus(FXTopWindow*w, FXuint msecs=1000);
-
++
+// #define SetPadLRTB(o,l,r,t,b) \
+// (o)->setPadLeft(l); \
+// (o)->setPadRight(r); \
@@ -86,4 +86,4 @@
+// (o)->setPadBottom(b);
+//
+// #define SetPad(o,p) SetPadLRTB(o,p,p,p,p)
-+
+
diff --git a/editors/fxite/files/patch-jef__interproc.cpp b/editors/fxite/files/patch-jef_interproc.cpp
index d39489805875..58eff0c0be65 100644
--- a/editors/fxite/files/patch-jef__interproc.cpp
+++ b/editors/fxite/files/patch-jef_interproc.cpp
@@ -1,6 +1,6 @@
--- jef/interproc.cpp.orig 2013-10-03 09:22:51 UTC
+++ jef/interproc.cpp
-@@ -323,6 +323,18 @@ static int SocketFailure(const char*func
+@@ -323,7 +323,19 @@ static int SocketFailure(const char*func)
}
@@ -9,17 +9,18 @@
+# define FOX_1_7_50_OR_NEWER
+# endif
+#endif
-+
+
+#ifdef FOX_1_7_50_OR_NEWER
+# define LookupInHash(d,k) ((d)->at(k))
+#else
+# define LookupInHash(d,k) ((d)->find(k))
+#endif
+
-
++
long InterProc::onSocketRead(FXObject*o,FXSelector sel,void*p)
{
-@@ -344,7 +356,7 @@ long InterProc::onSocketRead(FXObject*o,
+ switch (FXSELID(sel)) {
+@@ -344,7 +356,7 @@ long InterProc::onSocketRead(FXObject*o,FXSelector sel
ssize_t len=0;
char buf[bufsize];
int read_fd=(FXival)p;
diff --git a/editors/fxite/files/patch-jef__shady_tabs.h b/editors/fxite/files/patch-jef_shady__tabs.h
index f0872eab7531..5ea203da252f 100644
--- a/editors/fxite/files/patch-jef__shady_tabs.h
+++ b/editors/fxite/files/patch-jef_shady__tabs.h
@@ -1,6 +1,6 @@
--- jef/shady_tabs.h.orig 2013-10-03 09:22:51 UTC
+++ jef/shady_tabs.h
-@@ -28,7 +28,7 @@ protected:
+@@ -28,7 +28,7 @@ class ShadyTabs: public FXTabBook { (protected)
void UpdateTabs();
public:
long onCmdOpenItem ( FXObject* sender, FXSelector sel, void* p );
diff --git a/editors/fxite/files/patch-src__recorder.cpp b/editors/fxite/files/patch-src__recorder.cpp
deleted file mode 100644
index 45c255d9b6c5..000000000000
--- a/editors/fxite/files/patch-src__recorder.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/recorder.cpp.orig 2013-10-03 09:22:51 UTC
-+++ src/recorder.cpp
-@@ -20,6 +20,7 @@
- #include <fx.h>
- #include <Scintilla.h>
-
-+#include "compat.h"
- #include "macro.h"
-
- #include "intl.h"
diff --git a/editors/fxite/files/patch-src__appmain.h b/editors/fxite/files/patch-src_appmain.h
index 09323911d4d3..b0107f2aec1c 100644
--- a/editors/fxite/files/patch-src__appmain.h
+++ b/editors/fxite/files/patch-src_appmain.h
@@ -1,6 +1,6 @@
--- src/appmain.h.orig 2013-10-03 09:22:51 UTC
+++ src/appmain.h
-@@ -49,7 +49,7 @@ public:
+@@ -49,7 +49,7 @@ class AppClass: public FXApp { (public)
long onIpcExec(FXObject*o,FXSelector sel,void*p);
AppClass(const FXString& name, const FXString& title);
void exit(FXint code);
diff --git a/editors/fxite/files/patch-src_appname.cpp b/editors/fxite/files/patch-src_appname.cpp
new file mode 100644
index 000000000000..0544448fa8ec
--- /dev/null
+++ b/editors/fxite/files/patch-src_appname.cpp
@@ -0,0 +1,16 @@
+Fix build with clang 6
+
+appname.cpp:145:32: error: invalid suffix on literal; C++11 requires a space between literal and identifier [-Wreserved-user-defined-literal]
+ dlg=new FxAsqWin(_("About "EXE_NAME), btns, i++);
+
+--- src/appname.cpp.orig 2018-02-16 06:02:39 UTC
++++ src/appname.cpp
+@@ -142,7 +142,7 @@ void AppAbout::AboutBox()
+ FxAsqWin*dlg=NULL;
+ FXString msg;
+ int rv=-1;
+- dlg=new FxAsqWin(_("About "EXE_NAME), btns, i++);
++ dlg=new FxAsqWin(_("About " EXE_NAME), btns, i++);
+ msg.format(App_About, _("Version"), VERSION, "yetanothergeek@gmail.com",
+ _(" This program is free software, under the terms of the \n"),
+ _("Running"),
diff --git a/editors/fxite/files/patch-src__appwin.cpp b/editors/fxite/files/patch-src_appwin.cpp
index 845e84ecb8de..845e84ecb8de 100644
--- a/editors/fxite/files/patch-src__appwin.cpp
+++ b/editors/fxite/files/patch-src_appwin.cpp
diff --git a/editors/fxite/files/patch-src__appwin_base.cpp b/editors/fxite/files/patch-src_appwin__base.cpp
index 0ad468754a09..b9195e5be157 100644
--- a/editors/fxite/files/patch-src__appwin_base.cpp
+++ b/editors/fxite/files/patch-src_appwin__base.cpp
@@ -16,7 +16,7 @@
#include "intl.h"
#include "appwin_base.h"
-@@ -405,7 +405,14 @@ long TopWindowBase::onTimer(FXObject*o,
+@@ -405,7 +405,14 @@ long TopWindowBase::onTimer(FXObject*o, FXSelector sel
long TopWindowBase::onCloseWait(FXObject*o, FXSelector sel, void*p)
{
if (FXSELTYPE(sel)==SEL_CHORE) {
@@ -32,7 +32,7 @@
} else {
close();
}
-@@ -1246,7 +1253,12 @@ void TopWindowBase::ParseCommands(FXStri
+@@ -1246,7 +1253,12 @@ void TopWindowBase::ParseCommands(FXString &commands)
FXString filename=sect.text();
if (rowcol.empty()) {
FXint beg,end;
diff --git a/editors/fxite/files/patch-src__appwin_base.h b/editors/fxite/files/patch-src_appwin__base.h
index 849a37bfc991..122006fcae3e 100644
--- a/editors/fxite/files/patch-src__appwin_base.h
+++ b/editors/fxite/files/patch-src_appwin__base.h
@@ -1,6 +1,6 @@
--- src/appwin_base.h.orig 2013-10-03 09:22:51 UTC
+++ src/appwin_base.h
-@@ -114,7 +114,7 @@ public:
+@@ -114,7 +114,7 @@ class TopWindowBase: public MainWinWithClipBrd { (publ
virtual ~TopWindowBase();
static TopWindowBase* instance();
virtual void create();
diff --git a/editors/fxite/files/patch-src__appwin_pub.h b/editors/fxite/files/patch-src_appwin__pub.h
index fad09bf9d714..148ab8483101 100644
--- a/editors/fxite/files/patch-src__appwin_pub.h
+++ b/editors/fxite/files/patch-src_appwin__pub.h
@@ -1,6 +1,6 @@
--- src/appwin_pub.h.orig 2013-10-03 09:22:51 UTC
+++ src/appwin_pub.h
-@@ -55,7 +55,7 @@ public:
+@@ -55,7 +55,7 @@ class TopWinPub: public FXObject { (public)
static void ParseCommands(FXString &commands);
static FXMainWindow* instantiate(FXApp*a);
static void create();
diff --git a/editors/fxite/files/patch-src__doctabs.cpp b/editors/fxite/files/patch-src_doctabs.cpp
index 173ceaf8d513..ca947fab0c9f 100644
--- a/editors/fxite/files/patch-src__doctabs.cpp
+++ b/editors/fxite/files/patch-src_doctabs.cpp
@@ -1,6 +1,6 @@
--- src/doctabs.cpp.orig 2013-10-03 09:22:51 UTC
+++ src/doctabs.cpp
-@@ -56,7 +56,7 @@ long DocTabs::onDnd(FXObject* sender,FXS
+@@ -56,7 +56,7 @@ long DocTabs::onDnd(FXObject* sender,FXSelector sel, v
switch (FXSELTYPE(sel)) {
case SEL_DND_ENTER: {
if (getApp()->getCursorWindow()==this) { return 0; }
@@ -9,7 +9,7 @@
if (offeredDNDType(FROM_DRAGNDROP,urilistType)) {
acceptDrop();
dnd_accept=true;
-@@ -504,7 +504,7 @@ long DocTab::onDnd(FXObject* sender,FXSe
+@@ -504,7 +504,7 @@ long DocTab::onDnd(FXObject* sender,FXSelector sel, vo
FXEvent* ev=(FXEvent*)p;
switch(FXSELTYPE(sel)) {
case SEL_DND_ENTER: {
diff --git a/editors/fxite/files/patch-src_export.cpp b/editors/fxite/files/patch-src_export.cpp
index 9ab9a02b96a4..81c563a706d7 100644
--- a/editors/fxite/files/patch-src_export.cpp
+++ b/editors/fxite/files/patch-src_export.cpp
@@ -1,5 +1,14 @@
--- src/export.cpp.orig 2013-10-03 09:22:51 UTC
+++ src/export.cpp
+@@ -73,7 +73,7 @@ void SaveToHTML(SciDoc*sci, FILE *fp )
+ fprintf(fp, "<title>%s</title>\n", FXPath::name(sci->Filename()).text());
+ // Probably not used by robots, but making a little advertisement for those looking
+ // at the source code doesn't hurt...
+- fputs("<meta name=\"Generator\" content=\""APP_NAME" HTML export\" />\n", fp);
++ fputs("<meta name=\"Generator\" content=\"" APP_NAME " HTML export\" />\n", fp);
+ if ( sci->sendMessage(SCI_GETCODEPAGE,0,0) == SC_CP_UTF8) {
+ fputs("<meta http-equiv=\"Content-Type\" content=\"text/html; charset=utf-8\" />\n", fp);
+ }
@@ -464,7 +464,7 @@ void SaveToPDF(SciDoc*sci, FILE *fp)
}
// start to write PDF file here (PDF1.4Ref(p63))
diff --git a/editors/fxite/files/patch-src__fxasq.cpp b/editors/fxite/files/patch-src_fxasq.cpp
index a5f5c123439e..ab32d0a5460a 100644
--- a/editors/fxite/files/patch-src__fxasq.cpp
+++ b/editors/fxite/files/patch-src_fxasq.cpp
@@ -20,7 +20,7 @@
FXWindow*obj=(FXWindow*)keylist.data(i);
if (k&&obj) {
if (IsGroup(obj)) {
-@@ -299,7 +299,7 @@ void FxAsqWin::Select(const char*key, co
+@@ -299,7 +299,7 @@ void FxAsqWin::Select(const char*key, const char*value
{
FXHorizontalFrame *frm = new FXHorizontalFrame(userbox,LAYOUT_FILL_X);
new FXLabel(frm,label,NULL);
@@ -29,7 +29,7 @@
if (list) {
list->reparent(frm);
void*p=list->getUserData();
-@@ -315,7 +315,7 @@ void FxAsqWin::Select(const char*key, co
+@@ -315,7 +315,7 @@ void FxAsqWin::Select(const char*key, const char*value
void FxAsqWin::Option(const char*key, const char*value, const char*label)
{
@@ -38,7 +38,7 @@
if (!IsList(list)) {
list=new FXListBox(userbox,NULL,0,LISTBOX_OPTS);
keylist.insert(key,list);
-@@ -327,7 +327,7 @@ void FxAsqWin::Option(const char*key, co
+@@ -327,7 +327,7 @@ void FxAsqWin::Option(const char*key, const char*value
void FxAsqWin::Group(const char*key, const char*value, const char*label)
{
@@ -47,7 +47,7 @@
if (grp) {
((FXWindow*)grp)->reparent(userbox);
grp->setText(label);
-@@ -341,7 +341,7 @@ void FxAsqWin::Group(const char*key, con
+@@ -341,7 +341,7 @@ void FxAsqWin::Group(const char*key, const char*value,
void FxAsqWin::Radio(const char*key, const char*value, const char*label)
{
@@ -56,7 +56,7 @@
if (!IsGroup(grp)) {
grp=new GroupBox(userbox,NULL);
keylist.insert(key,grp);
-@@ -505,7 +505,7 @@ void FxAsqWin::Font(const char*key, cons
+@@ -505,7 +505,7 @@ void FxAsqWin::Font(const char*key, const char*value,
FxAsqWin::~FxAsqWin()
{
void*p=NULL;
diff --git a/editors/fxite/files/patch-src__fxasq.h b/editors/fxite/files/patch-src_fxasq.h
index d9032ca7f3ac..d9032ca7f3ac 100644
--- a/editors/fxite/files/patch-src__fxasq.h
+++ b/editors/fxite/files/patch-src_fxasq.h
diff --git a/editors/fxite/files/patch-src__fxasq_lua.c b/editors/fxite/files/patch-src_fxasq__lua.c
index 9c92e66a8a70..9c92e66a8a70 100644
--- a/editors/fxite/files/patch-src__fxasq_lua.c
+++ b/editors/fxite/files/patch-src_fxasq__lua.c
diff --git a/editors/fxite/files/patch-src__help.cpp b/editors/fxite/files/patch-src_help.cpp
index dc7bad20050f..3707f29dc9a0 100644
--- a/editors/fxite/files/patch-src__help.cpp
+++ b/editors/fxite/files/patch-src_help.cpp
@@ -1,6 +1,6 @@
--- src/help.cpp.orig 2013-10-03 09:22:51 UTC
+++ src/help.cpp
-@@ -36,6 +36,12 @@
+@@ -36,7 +36,13 @@
#define sendString(iMessage, wParam, lParam) sendMessage(iMessage, wParam, reinterpret_cast<long>(lParam))
@@ -9,11 +9,12 @@
+#else
+# define RxFind(rx,subj,start,beg,end,npar) (rx.match(subj,beg,end,REX_FORWARD,npar,start))
+#endif
-+
++
enum {
SCHLP_FIXED,
-@@ -224,7 +230,7 @@ void SciHelp::replace(const char*oldstr,
+ SCHLP_ITALIC,
+@@ -224,7 +230,7 @@ void SciHelp::replace(const char*oldstr, const char*ne
FXRex generic_rx(oldstr, REX_NORMAL|REX_NEWLINE);
content=(const char*)(sendMessage(SCI_GETCHARACTERPOINTER,0,0));
FXint n=strlen(newstr);
@@ -22,7 +23,7 @@
sendMessage(SCI_SETTARGETSTART,beg[0],0);
sendMessage(SCI_SETTARGETEND,end[0],0);
sendString(SCI_REPLACETARGET,n,newstr);
-@@ -261,7 +267,7 @@ void SciHelp::parse(const char*txt, unsi
+@@ -261,7 +267,7 @@ void SciHelp::parse(const char*txt, unsigned int size)
for (FXint i=SCHLP_FIRST; i<SCHLP_LAST; i++) {
content=(const char*)(sendMessage(SCI_GETCHARACTERPOINTER,0,0));
FXRex rx(phrases[i], REX_CAPTURE|REX_NEWLINE);
@@ -31,8 +32,12 @@
sendMessage(SCI_SETTARGETSTART,beg[0],0);
sendMessage(SCI_SETTARGETEND,end[0],0);
char*tmp=my_strndup(content+beg[1], end[1]-beg[1]);
-@@ -292,7 +298,7 @@ void SciHelp::parse(const char*txt, unsi
- FXRex appname_rx("\\<"APP_NAME"\\>", REX_NORMAL|REX_NEWLINE);
+@@ -289,10 +295,10 @@ void SciHelp::parse(const char*txt, unsigned int size)
+ }
+
+ // Make the editor's name stand out a little...
+- FXRex appname_rx("\\<"APP_NAME"\\>", REX_NORMAL|REX_NEWLINE);
++ FXRex appname_rx("\\<" APP_NAME "\\>", REX_NORMAL|REX_NEWLINE);
content=(const char*)(sendMessage(SCI_GETCHARACTERPOINTER,0,0));
FXint p=0;
- while (appname_rx.match(content,beg,end,REX_FORWARD,1, p)) {
diff --git a/editors/fxite/files/patch-src__luacmds.cpp b/editors/fxite/files/patch-src_luacmds.cpp
index 43fa2429a1c4..511769d5cf4c 100644
--- a/editors/fxite/files/patch-src__luacmds.cpp
+++ b/editors/fxite/files/patch-src_luacmds.cpp
@@ -1,6 +1,6 @@
--- src/luacmds.cpp.orig 2013-10-03 09:22:51 UTC
+++ src/luacmds.cpp
-@@ -530,7 +530,7 @@ static int view_clear_output(lua_State*
+@@ -530,7 +530,7 @@ static int view_clear_output(lua_State* L)
}
@@ -9,7 +9,7 @@
{"file_new", file_new},
{"file_open", file_open},
{"file_reload", file_reload},
-@@ -585,7 +585,7 @@ static const struct luaL_reg fxte_comman
+@@ -585,7 +585,7 @@ static const struct luaL_reg fxte_commands[] = {
diff --git a/editors/fxite/files/patch-src__luacmds.h b/editors/fxite/files/patch-src_luacmds.h
index 657419a31227..657419a31227 100644
--- a/editors/fxite/files/patch-src__luacmds.h
+++ b/editors/fxite/files/patch-src_luacmds.h
diff --git a/editors/fxite/files/patch-src__luafuncs.cpp b/editors/fxite/files/patch-src_luafuncs.cpp
index 804beff6f3cd..a09ac0b50623 100644
--- a/editors/fxite/files/patch-src__luafuncs.cpp
+++ b/editors/fxite/files/patch-src_luafuncs.cpp
@@ -20,7 +20,7 @@
/*
-@@ -86,7 +89,7 @@ static bool check_find_flags(lua_State*
+@@ -86,7 +89,7 @@ static bool check_find_flags(lua_State* L, int pos, in
{
flags=0;
luaL_argcheck(L, lua_istable(L,pos), pos, _("expected table"));
@@ -47,7 +47,7 @@
{"seltext", seltext},
{"text", text},
{"documents", documents},
-@@ -1403,7 +1406,7 @@ static const struct luaL_reg fxte_funcs[
+@@ -1403,7 +1406,7 @@ static const struct luaL_reg fxte_funcs[] = {
diff --git a/editors/fxite/files/patch-src__luafuncs.h b/editors/fxite/files/patch-src_luafuncs.h
index 1e98226b584b..1e98226b584b 100644
--- a/editors/fxite/files/patch-src__luafuncs.h
+++ b/editors/fxite/files/patch-src_luafuncs.h
diff --git a/editors/fxite/files/patch-src_luafx.cpp b/editors/fxite/files/patch-src_luafx.cpp
index f89fa587563e..ec6d0ba2af98 100644
--- a/editors/fxite/files/patch-src_luafx.cpp
+++ b/editors/fxite/files/patch-src_luafx.cpp
@@ -38,7 +38,7 @@
{"message", message},
{"confirm", confirm},
{"input", input},
-@@ -620,7 +624,7 @@ static const struct luaL_reg fx_util_fun
+@@ -620,7 +624,7 @@ static const struct luaL_reg fx_util_funcs[] = {
diff --git a/editors/fxite/files/patch-src__luafx.h b/editors/fxite/files/patch-src_luafx.h
index bd22047dbfde..bd22047dbfde 100644
--- a/editors/fxite/files/patch-src__luafx.h
+++ b/editors/fxite/files/patch-src_luafx.h
diff --git a/editors/fxite/files/patch-src__macro.cpp b/editors/fxite/files/patch-src_macro.cpp
index fef9271204e0..d9d6a1957d3c 100644
--- a/editors/fxite/files/patch-src__macro.cpp
+++ b/editors/fxite/files/patch-src_macro.cpp
@@ -9,7 +9,7 @@
if (!lua_istable(L, -1)) {
lua_pop(L, 1);
return 1;
-@@ -324,7 +324,7 @@ static void debug_hook(lua_State *L, lua
+@@ -324,7 +324,7 @@ static void debug_hook(lua_State *L, lua_Debug *ar)
/* Override a builtin Lua function, or add a new one if it doesn't exist */
static void override(lua_State *L, const char*module, const char* funcname, lua_CFunction newfunc)
{
@@ -18,7 +18,7 @@
if (lua_istable(L,-1)) {
lua_pushstring(L,funcname);
if (newfunc) {
-@@ -342,7 +342,7 @@ static void override(lua_State *L, const
+@@ -342,7 +342,7 @@ static void override(lua_State *L, const char*module,
/* Don't let scripts try to read from stdin, as this would block indefinitely */
static void close_stdin(lua_State *L)
{
@@ -36,7 +36,7 @@
PersistRecord*pr=(PersistRecord*)keepers.data(i);
if (pr) {
if (pr->t==LUA_TSTRING) {
-@@ -406,11 +406,12 @@ void MacroRunner::PushKeepers(lua_State
+@@ -406,11 +406,12 @@ void MacroRunner::PushKeepers(lua_State *L)
lua_pushstring(L,PERSIST_TABLE_NAME);
lua_newtable(L);
lua_settable(L, -3);
@@ -51,7 +51,7 @@
switch (pr->t) {
case LUA_TNUMBER: { lua_pushnumber(L, pr->n); break;}
case LUA_TBOOLEAN:{ lua_pushboolean(L, pr->b); break;}
-@@ -455,7 +456,7 @@ void MacroRunner::PopKeepers(lua_State *
+@@ -455,7 +456,7 @@ void MacroRunner::PopKeepers(lua_State *L)
}
}
if (pr) {
@@ -60,7 +60,7 @@
}
}
lua_pop(L, 1);
-@@ -479,6 +480,9 @@ bool MacroRunner::RunMacro(const FXStrin
+@@ -479,6 +480,9 @@ bool MacroRunner::RunMacro(const FXString &source, boo
lua_State *L=luaL_newstate();
luaL_openlibs(L);
luaopen_dialog(L);
@@ -70,7 +70,7 @@
override(L,"os","exit", osexit);
override(L,"io","stdin", NULL);
override(L,"_G","print", print);
-@@ -487,11 +491,27 @@ bool MacroRunner::RunMacro(const FXStrin
+@@ -487,11 +491,27 @@ bool MacroRunner::RunMacro(const FXString &source, boo
si->script=isfilename?source.text():NULL;
states.append(si);
lua_sethook(L,debug_hook,LUA_MASKLINE,1);
diff --git a/editors/fxite/files/patch-src__macro.h b/editors/fxite/files/patch-src_macro.h
index ff45d40f6315..ff45d40f6315 100644
--- a/editors/fxite/files/patch-src__macro.h
+++ b/editors/fxite/files/patch-src_macro.h
diff --git a/editors/fxite/files/patch-src__menuspec.cpp b/editors/fxite/files/patch-src_menuspec.cpp
index 7ae765afdc31..94346f03664b 100644
--- a/editors/fxite/files/patch-src__menuspec.cpp
+++ b/editors/fxite/files/patch-src_menuspec.cpp
@@ -1,6 +1,6 @@
--- src/menuspec.cpp.orig 2013-10-03 09:22:51 UTC
+++ src/menuspec.cpp
-@@ -616,7 +616,8 @@ void MenuMgr::ReadPopupMenu(FXRegistry*r
+@@ -616,7 +616,8 @@ void MenuMgr::ReadPopupMenu(FXRegistry*reg, const char
memset(keyname,0, sizeof(keyname));
snprintf(keyname,sizeof(keyname)-1,"Command_%d", i+1);
if (reg->existingEntry(popup_sect,keyname)) {
diff --git a/editors/fxite/files/patch-src_migration.cpp b/editors/fxite/files/patch-src_migration.cpp
new file mode 100644
index 000000000000..e775fccfd599
--- /dev/null
+++ b/editors/fxite/files/patch-src_migration.cpp
@@ -0,0 +1,29 @@
+Fix build with clang 6
+
+migration.cpp:134:27: error: invalid suffix on literal; C++11 requires a space between literal and identifier [-Wreserved-user-defined-literal]
+ "The location of the "APP_NAME" configuration directory has changed.\n"
+ ^
+
+migration.cpp:144:33: error: invalid suffix on literal; C++11 requires a space between literal and identifier [-Wreserved-user-defined-literal]
+ " Click [Cancel] to exit "APP_NAME" now without any changes.\n"
+
+--- src/migration.cpp.orig 2013-10-03 09:22:51 UTC
++++ src/migration.cpp
+@@ -131,7 +131,7 @@ void MigrateConfigDir(FXApp*a, const FXString &src, co
+ _("IMPORTANT NOTICE"),
+ _(
+ "\n"
+- "The location of the "APP_NAME" configuration directory has changed.\n"
++ "The location of the " APP_NAME " configuration directory has changed.\n"
+ "\n"
+ #ifndef WIN32
+ "This is due to changes in the FOX toolkit, in accordance with\n"
+@@ -141,7 +141,7 @@ void MigrateConfigDir(FXApp*a, const FXString &src, co
+ "Migration options:\n"
+ " Click [ Yes ] to automatically copy your old settings (recommended).\n"
+ " Click [ No ] to create a new configuration.\n"
+- " Click [Cancel] to exit "APP_NAME" now without any changes.\n"
++ " Click [Cancel] to exit " APP_NAME " now without any changes.\n"
+ "\n"
+ "Do you want me to copy your existing configuration?"
+ ),
diff --git a/editors/fxite/files/patch-src__outpane.cpp b/editors/fxite/files/patch-src_outpane.cpp
index 4de84587e609..4de84587e609 100644
--- a/editors/fxite/files/patch-src__outpane.cpp
+++ b/editors/fxite/files/patch-src_outpane.cpp
diff --git a/editors/fxite/files/patch-src__prefdlg.cpp b/editors/fxite/files/patch-src_prefdlg.cpp
index 9d13ddeb7feb..9d13ddeb7feb 100644
--- a/editors/fxite/files/patch-src__prefdlg.cpp
+++ b/editors/fxite/files/patch-src_prefdlg.cpp
diff --git a/editors/fxite/files/patch-src__prefdlg_sntx.cpp b/editors/fxite/files/patch-src_prefdlg__sntx.cpp
index 759f33e41f8d..bda6c8e36160 100644
--- a/editors/fxite/files/patch-src__prefdlg_sntx.cpp
+++ b/editors/fxite/files/patch-src_prefdlg__sntx.cpp
@@ -1,6 +1,6 @@
--- src/prefdlg_sntx.cpp.orig 2013-10-03 09:22:51 UTC
+++ src/prefdlg_sntx.cpp
-@@ -84,7 +84,7 @@ long MyColorWell::onDoubleClicked(FXObje
+@@ -84,7 +84,7 @@ long MyColorWell::onDoubleClicked(FXObject*o,FXSelecto
colordialog.setSelector(ID_COLORDIALOG);
colordialog.setRGBA(oldcolor);
colordialog.setOpaqueOnly(isOpaqueOnly());
diff --git a/editors/fxite/files/patch-src_recorder.cpp b/editors/fxite/files/patch-src_recorder.cpp
new file mode 100644
index 000000000000..951f1f6c5370
--- /dev/null
+++ b/editors/fxite/files/patch-src_recorder.cpp
@@ -0,0 +1,19 @@
+--- src/recorder.cpp.orig 2013-10-03 09:22:51 UTC
++++ src/recorder.cpp
+@@ -20,6 +20,7 @@
+ #include <fx.h>
+ #include <Scintilla.h>
+
++#include "compat.h"
+ #include "macro.h"
+
+ #include "intl.h"
+@@ -288,7 +289,7 @@ void MacroRecorder::translate(TranslateFunc callback,
+ break;
+ }
+ case SCI_SELECTALL: {
+- text=_LUAMOD_".select(0,"_LUAMOD_".nchars())";
++ text=_LUAMOD_".select(0," _LUAMOD_ ".nchars())";
+ break;
+ }
+
diff --git a/editors/fxite/files/patch-src__scidoc.cpp b/editors/fxite/files/patch-src_scidoc.cpp
index 4f0a69100b71..03092bb5f720 100644
--- a/editors/fxite/files/patch-src__scidoc.cpp
+++ b/editors/fxite/files/patch-src_scidoc.cpp
@@ -1,6 +1,6 @@
--- src/scidoc.cpp.orig 2013-10-03 09:22:51 UTC
+++ src/scidoc.cpp
-@@ -620,7 +620,11 @@ bool SciDoc::SetLanguageForHeader(const
+@@ -620,7 +620,11 @@ bool SciDoc::SetLanguageForHeader(const FXString &fn)
} else {
// Take a wild guess - if the file contains the word "class" it's probably C++
const char *content=(const char*)(sendMessage(SCI_GETCHARACTERPOINTER,0,0));
diff --git a/editors/fxite/files/patch-src__scisrch.cpp b/editors/fxite/files/patch-src_scisrch.cpp
index 7d6637034e85..691107187dfa 100644
--- a/editors/fxite/files/patch-src__scisrch.cpp
+++ b/editors/fxite/files/patch-src_scisrch.cpp
@@ -13,7 +13,7 @@
#if 1
// The capitalization of text inserted by `&' or `\1', `\2', ... `\9' can be altered by
-@@ -222,7 +228,7 @@ int SciSearch::FindTextNoSel(const FXStr
+@@ -222,7 +228,7 @@ int SciSearch::FindTextNoSel(const FXString &what, FXu
if (fm<0) { fm=0; }
if (to>len) { to=len; }
FXuint dirn=isfwd?REX_FORWARD:REX_BACKWARD;
@@ -22,7 +22,7 @@
beg=isfwd?begs[0]:ends[0];
end=isfwd?ends[0]:begs[0];
return 1;
-@@ -256,8 +262,8 @@ bool SciSearch::FindText(const FXString
+@@ -256,8 +262,8 @@ bool SciSearch::FindText(const FXString &what, FXuint
long fm = isfwd? pos : 0;
long to = isfwd? len : (pos-1);
if (
@@ -33,7 +33,7 @@
) {
SciMsg(SCI_SETTARGETSTART,begs[0],0);
SciMsg(SCI_SETTARGETEND,ends[0],0);
-@@ -383,8 +389,8 @@ long SciSearch::ReplaceAllInDoc(const FX
+@@ -383,8 +389,8 @@ long SciSearch::ReplaceAllInDoc(const FXString &search
SciMsg(SCI_SETSEARCHFLAGS,0,0);
SciMsg(SCI_BEGINUNDOACTION,0,0);
while (1) {
@@ -44,7 +44,7 @@
SciMsg(SCI_SETTARGETSTART,begs[0],0);
SciMsg(SCI_SETTARGETEND,ends[0],0);
FXString newstr=DoSubstitute(content,begs,ends,repl_template,MAX_CAPTURES);
-@@ -438,7 +444,7 @@ long SciSearch::ReplaceAllInSel(const FX
+@@ -438,7 +444,7 @@ long SciSearch::ReplaceAllInSel(const FXString &search
SciMsg(SCI_SETSEARCHFLAGS,0,0);
if (bol_only) { // Special case, start of first line
@@ -53,7 +53,7 @@
SciMsg(SCI_SETTARGETSTART,begs[0],0);
SciMsg(SCI_SETTARGETEND,ends[0],0);
FXString newstr=DoSubstitute(content,begs,ends,repl_template,MAX_CAPTURES);
-@@ -452,7 +458,7 @@ long SciSearch::ReplaceAllInSel(const FX
+@@ -452,7 +458,7 @@ long SciSearch::ReplaceAllInSel(const FXString &search
long substart=start;
while (1) {
if (end<=substart) { break; }
diff --git a/editors/fxite/files/patch-src__tagread.cpp b/editors/fxite/files/patch-src_tagread.cpp
index 27f04d9f001e..27f04d9f001e 100644
--- a/editors/fxite/files/patch-src__tagread.cpp
+++ b/editors/fxite/files/patch-src_tagread.cpp
diff --git a/editors/fxite/files/patch-src__tagread.h b/editors/fxite/files/patch-src_tagread.h
index 29c522b77740..bfb0b9ad5f0b 100644
--- a/editors/fxite/files/patch-src__tagread.h
+++ b/editors/fxite/files/patch-src_tagread.h
@@ -1,6 +1,6 @@
--- src/tagread.h.orig 2013-10-03 09:22:51 UTC
+++ src/tagread.h
-@@ -26,7 +26,7 @@ public:
+@@ -26,7 +26,7 @@ class TagHandler: public FXObject { (public)
diff --git a/editors/fxite/files/patch-src__theme.cpp b/editors/fxite/files/patch-src_theme.cpp
index a59bd9fb9c37..a59bd9fb9c37 100644
--- a/editors/fxite/files/patch-src__theme.cpp
+++ b/editors/fxite/files/patch-src_theme.cpp