aboutsummaryrefslogtreecommitdiff
path: root/editors/hexcurse
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2020-09-22 13:06:59 +0000
committerStefan Eßer <se@FreeBSD.org>2020-09-22 13:06:59 +0000
commitdae78a3e29d1fd860c011c1e320e7fef114bc1c3 (patch)
treefd8dbb96331f95231b8e741287dcfa0e93181ca2 /editors/hexcurse
parent168b96ce123104755a4ff691997ce3d597d56ad9 (diff)
downloadports-dae78a3e29d1fd860c011c1e320e7fef114bc1c3.tar.gz
ports-dae78a3e29d1fd860c011c1e320e7fef114bc1c3.zip
Fix build with -fno-common
While here add license (GPLv2)
Notes
Notes: svn path=/head/; revision=549585
Diffstat (limited to 'editors/hexcurse')
-rw-r--r--editors/hexcurse/Makefile4
-rw-r--r--editors/hexcurse/files/patch-include_hex.h11
-rw-r--r--editors/hexcurse/files/patch-src_file.c13
-rw-r--r--editors/hexcurse/files/patch-src_getopt.c (renamed from editors/hexcurse/files/patch-getopt.c)0
4 files changed, 28 insertions, 0 deletions
diff --git a/editors/hexcurse/Makefile b/editors/hexcurse/Makefile
index 8f6363a834e4..9be2314f8554 100644
--- a/editors/hexcurse/Makefile
+++ b/editors/hexcurse/Makefile
@@ -3,12 +3,16 @@
PORTNAME= hexcurse
PORTVERSION= 1.55
+PORTREVISION= 1
CATEGORIES= editors
MASTER_SITES= https://BSDforge.com/projects/source/editors/hexcurse/
MAINTAINER= jadawin@FreeBSD.org
COMMENT= Versatile ncurses-based hex editor
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
USES= ncurses
GNU_CONFIGURE= yes
diff --git a/editors/hexcurse/files/patch-include_hex.h b/editors/hexcurse/files/patch-include_hex.h
new file mode 100644
index 000000000000..6f150b71928e
--- /dev/null
+++ b/editors/hexcurse/files/patch-include_hex.h
@@ -0,0 +1,11 @@
+--- include/hex.h.orig 2003-12-23 03:08:25 UTC
++++ include/hex.h
+@@ -111,7 +111,7 @@ extern char EBCDIC[256];
+ #define max(a,b) ((a) >(b) ? (a) : (b))
+ #endif
+
+-FILE *fpIN, *fpOUT; /* global file ptrs */
++extern FILE *fpIN, *fpOUT; /* global file ptrs */
+
+ /* function prototypes */
+
diff --git a/editors/hexcurse/files/patch-src_file.c b/editors/hexcurse/files/patch-src_file.c
new file mode 100644
index 000000000000..b124799c813a
--- /dev/null
+++ b/editors/hexcurse/files/patch-src_file.c
@@ -0,0 +1,13 @@
+--- src/file.c.orig 2003-12-15 13:43:47 UTC
++++ src/file.c
+@@ -18,7 +18,9 @@
+ \******************************************************************************/
+ #include "hex.h"
+
+-/*******************************************************\
++FILE *fpIN, *fpOUT; /* global file ptrs */
++
++/******************************************************* \
+ * Description: prints out a line of text to the screen*
+ * the current address line and both the *
+ * hex and decimal values for the current *
diff --git a/editors/hexcurse/files/patch-getopt.c b/editors/hexcurse/files/patch-src_getopt.c
index 627eefbb997f..627eefbb997f 100644
--- a/editors/hexcurse/files/patch-getopt.c
+++ b/editors/hexcurse/files/patch-src_getopt.c