aboutsummaryrefslogtreecommitdiff
path: root/editors/hexedit/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-01-28 20:52:03 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-01-28 20:52:03 +0000
commitc927827bea7812655bdbc55c1e87fd43d2e55a72 (patch)
treef1c501a098a21dde5d03bfda589a56cabbf8a864 /editors/hexedit/Makefile
parentcf2238c8805fc8737908b1258aa44a7c54048f15 (diff)
downloadports-c927827bea7812655bdbc55c1e87fd43d2e55a72.tar.gz
ports-c927827bea7812655bdbc55c1e87fd43d2e55a72.zip
Notes
Diffstat (limited to 'editors/hexedit/Makefile')
-rw-r--r--editors/hexedit/Makefile17
1 files changed, 8 insertions, 9 deletions
diff --git a/editors/hexedit/Makefile b/editors/hexedit/Makefile
index a0b400d05181..14c4a730d228 100644
--- a/editors/hexedit/Makefile
+++ b/editors/hexedit/Makefile
@@ -2,25 +2,24 @@
# $FreeBSD$
PORTNAME= hexedit
-PORTVERSION= 1.2.13
-DISTVERSIONSUFFIX= .src
+PORTVERSION= 1.3
CATEGORIES= editors
-MASTER_SITES= http://rigaux.org/ \
- LOCAL/sunpoet
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= View and edit files in hexadecimal or ASCII
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
GNU_CONFIGURE= yes
-USES= ncurses tar:tgz
-WRKSRC= ${WRKDIR}/${PORTNAME}
+USES= autoreconf ncurses
PLIST_FILES= bin/hexedit man/man1/hexedit.1.gz
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/hexedit ${STAGEDIR}${PREFIX}/bin/
- ${INSTALL_MAN} ${WRKSRC}/hexedit.1 ${STAGEDIR}${PREFIX}/man/man1/
+GH_ACCOUNT= pixel
+USE_GITHUB= yes
+
+post-build:
+ m4 -DVERSION=${PORTVERSION} ${WRKSRC}/hexedit.1.in > ${WRKSRC}/hexedit.1
.include <bsd.port.mk>