aboutsummaryrefslogtreecommitdiff
path: root/editors/hte
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2009-09-27 12:54:38 +0000
committerMarcus von Appen <mva@FreeBSD.org>2009-09-27 12:54:38 +0000
commit8ff906eb42be3794e0aedcb5111999e5a1da3ccf (patch)
tree31889d7d83722cecdd9e908a7e7a066cbf371645 /editors/hte
parentfd262bb0003c29ed93e753559a3040ebaa803a0a (diff)
downloadports-8ff906eb42be3794e0aedcb5111999e5a1da3ccf.tar.gz
ports-8ff906eb42be3794e0aedcb5111999e5a1da3ccf.zip
Fix automated lzo2 linking - use OPTIONs instead.
Approved by: miwi (mentor) Feature safe: yes
Notes
Notes: svn path=/head/; revision=242165
Diffstat (limited to 'editors/hte')
-rw-r--r--editors/hte/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/editors/hte/Makefile b/editors/hte/Makefile
index 2857d887e8e9..09f0f6ea8d24 100644
--- a/editors/hte/Makefile
+++ b/editors/hte/Makefile
@@ -20,15 +20,23 @@ GNU_CONFIGURE= yes
PLIST_FILES= bin/ht
+OPTIONS= LZO2 "Enable external lzo2 compresssion support" off
+
.include <bsd.port.pre.mk>
.if ${ARCH} == "ia64"
BROKEN= Does not build on ia64
.endif
+.if defined(WITH_LZO2)
+LIB_DEPENDS+= lzo2.2:${PORTSDIR}/archivers/lzo2
+.else
+CONFIGURE_ARGS= --with-included-lzo
+.endif
+
.if defined(WITHOUT_X11)
PKGNAMESUFFIX= -nox11
-CONFIGURE_ARGS=--disable-x11-textmode
+CONFIGURE_ARGS+=--disable-x11-textmode
.else
USE_XORG= x11
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"