aboutsummaryrefslogtreecommitdiff
path: root/editors/jed
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2008-06-02 11:28:24 +0000
committerRenato Botelho <garga@FreeBSD.org>2008-06-02 11:28:24 +0000
commitd0383e1ee9c467eabbec8748eb8ffcf6ce951086 (patch)
treece7e883db846611bc90178a896ca2994b9c8e6bb /editors/jed
parentc28ac67f6abd172e35a7eaa6ad555929cc33e65b (diff)
downloadports-d0383e1ee9c467eabbec8748eb8ffcf6ce951086.tar.gz
ports-d0383e1ee9c467eabbec8748eb8ffcf6ce951086.zip
- Fix installation when NOPORTDOCS is set, preventing it to create doc dirs.
Bump PORTREVISION is unecessary since the default package will be untouched Reported by: itetcu
Notes
Notes: svn path=/head/; revision=214175
Diffstat (limited to 'editors/jed')
-rw-r--r--editors/jed/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/editors/jed/Makefile b/editors/jed/Makefile
index 87df857f32e5..08481e8a5634 100644
--- a/editors/jed/Makefile
+++ b/editors/jed/Makefile
@@ -28,13 +28,14 @@ USE_BZIP2= yes
DIST_SUBDIR= jed
GNU_CONFIGURE= yes
CONFIGURE_ENV+= JED_ROOT=${PREFIX}/lib/jed
-MAKE_ENV+= DEST_DOC_DIR=${DOCSDIR}
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
PORTDOCS= *
+MAKE_ENV+= DEST_DOC_DIR=${DOCSDIR}
.if defined(NOPORTDOCS)
MAKE_ENV+= JED_DOC_FILES="" \
JED_DOC_TXT_FILES="" \
+ JED_DOC_HLP_FILES="" \
JED_DOC_MAN_FILES=""
.endif
@@ -62,6 +63,10 @@ post-patch:
-e 's,\.\./info/\*,,' \
-e 's,^\(JED_DOC_.*FILES\) =,\1 \?=,g' \
${WRKSRC}/src/Makefile.in
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e '/MKINSDIR.*DEST_DOC_DIR/d' \
+ ${WRKSRC}/src/Makefile.in
+.endif
post-configure:
@${REINPLACE_CMD} -e 's,\(.usr.bin.install\) *-c,\1 -s -m 555,' \