aboutsummaryrefslogtreecommitdiff
path: root/editors/jed
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-11-01 19:12:09 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-11-01 19:12:09 +0000
commitd3dede95529f346f2fa71b431fcde9f0a730b24d (patch)
treeb584b7c9c181003b920c33d7e443827301b99545 /editors/jed
parent6c96f268b50c93745f1f03e4cea2b76e50348728 (diff)
downloadports-d3dede95529f346f2fa71b431fcde9f0a730b24d.tar.gz
ports-d3dede95529f346f2fa71b431fcde9f0a730b24d.zip
- Fix losing setuid/setgid bits on files when saving
- Portlint PR: ports/72652 Submitted by: Renato Botelho <renato@galle.com.br> Approved by: maintainer timeout (2 weeks)
Notes
Notes: svn path=/head/; revision=120603
Diffstat (limited to 'editors/jed')
-rw-r--r--editors/jed/Makefile3
-rw-r--r--editors/jed/files/patch-src-file.c20
-rw-r--r--editors/jed/files/patch-src-unix.c11
3 files changed, 33 insertions, 1 deletions
diff --git a/editors/jed/Makefile b/editors/jed/Makefile
index 42d634bc2129..57d593510623 100644
--- a/editors/jed/Makefile
+++ b/editors/jed/Makefile
@@ -7,6 +7,7 @@
PORTNAME= jed
PORTVERSION= 0.99.16
+PORTREVISION= 1
CATEGORIES= editors
MASTER_SITES= ftp://space.mit.edu/pub/davis/jed/v${PORTVERSION:R}/
DISTNAME= ${PORTNAME}-${PORTVERSION:R}-${PORTVERSION:E}
@@ -19,7 +20,7 @@ LIB_DEPENDS= slang.1:${PORTSDIR}/devel/libslang
.if !defined(WITHOUT_X11)
USE_XLIB= yes
XJED= xjed
-PLIST_SUB+= NOXJED=""
+PLIST_SUB+= NOXJED=""
.else
PLIST_SUB+= NOXJED="@comment "
.endif
diff --git a/editors/jed/files/patch-src-file.c b/editors/jed/files/patch-src-file.c
new file mode 100644
index 000000000000..274b382e2c56
--- /dev/null
+++ b/editors/jed/files/patch-src-file.c
@@ -0,0 +1,20 @@
+--- src/file.c.orig Wed Oct 13 14:52:57 2004
++++ src/file.c Wed Oct 13 14:53:07 2004
+@@ -173,7 +173,7 @@
+ case FAB$C_STMLF: rfm = "stmlf"; break;
+ case FAB$C_STMCR: rfm = "stmcr"; break;
+ }
+- mode = s.st_mode & 0777;
++ mode = s.st_mode & 07777;
+ }
+ else strcpy (rat_buf, "rat=cr");
+
+@@ -1729,7 +1729,7 @@
+ #ifdef REAL_UNIX_SYSTEM
+ int u;
+
+- u = umask (mask & 0777);
++ u = umask (mask & 07777);
+ if (default_umask == 0) default_umask = u;
+ #endif
+ }
diff --git a/editors/jed/files/patch-src-unix.c b/editors/jed/files/patch-src-unix.c
new file mode 100644
index 000000000000..b6e7a0e0958e
--- /dev/null
+++ b/editors/jed/files/patch-src-unix.c
@@ -0,0 +1,11 @@
+--- src/unix.c.orig Wed Oct 13 14:52:19 2004
++++ src/unix.c Wed Oct 13 14:52:32 2004
+@@ -722,7 +722,7 @@
+ # endif
+ #endif
+
+- *mode = m & 0777;
++ *mode = m & 07777;
+
+ if (S_ISDIR(m)) return (2);
+ return(1);