aboutsummaryrefslogtreecommitdiff
path: root/editors/jedit
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-04-18 16:57:19 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-04-18 16:57:19 +0000
commit8b5b461fdcc3f04b7824c92e1ae300241a9bc3dd (patch)
tree8af9d4e7209d581b5bdd21b39615fa4cc8d22c9f /editors/jedit
parentd0b959f002ac05e38e254c3677b1c5aa77bff811 (diff)
downloadports-8b5b461fdcc3f04b7824c92e1ae300241a9bc3dd.tar.gz
ports-8b5b461fdcc3f04b7824c92e1ae300241a9bc3dd.zip
Update to 4.0.0.
Notes
Notes: svn path=/head/; revision=57859
Diffstat (limited to 'editors/jedit')
-rw-r--r--editors/jedit/Makefile15
-rw-r--r--editors/jedit/distinfo3
-rw-r--r--editors/jedit/files/instscript1
-rw-r--r--editors/jedit/files/jedit.sh8
-rw-r--r--editors/jedit/pkg-plist276
5 files changed, 264 insertions, 39 deletions
diff --git a/editors/jedit/Makefile b/editors/jedit/Makefile
index 80b77aa4a7be..8d1420379873 100644
--- a/editors/jedit/Makefile
+++ b/editors/jedit/Makefile
@@ -6,23 +6,21 @@
#
PORTNAME= jedit
-PORTVERSION= 3.2.2
+PORTVERSION= 4.0.0
CATEGORIES= editors java
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
- http://members.nbci.com/romainguy/ \
- http://members.xoom.com/romainguy/
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
_DISTNAME= ${PORTNAME}${PORTVERSION:S/.//g}install
DISTNAME= ${_DISTNAME:S/0install$/install/}
-DISTFILES= ${DISTNAME}.jar swingall.jar
+EXTRACT_SUFX= .jar
EXTRACT_ONLY=
MAINTAINER= sobomax@FreeBSD.org
BUILD_DEPENDS= javavm:${PORTSDIR}/java/javavmwrapper \
- ${LOCALBASE}/etc/javavms:${PORTSDIR}/java/jre
+ ${LOCALBASE}/etc/javavms:${PORTSDIR}/java/jdk13
RUN_DEPENDS= javavm:${PORTSDIR}/java/javavmwrapper \
- ${LOCALBASE}/etc/javavms:${PORTSDIR}/java/jre
+ ${LOCALBASE}/etc/javavms:${PORTSDIR}/java/jdk13
USE_XLIB= yes
NO_BUILD= yes
@@ -33,9 +31,8 @@ do-configure:
do-install:
@${SED} "s|%%PREFIX%%|${PREFIX}| ; s|%%WRKDIR%%|${WRKDIR}|" ${FILESDIR}/instscript | \
- ${SETENV} CLASSPATH=${DISTDIR}/${DISTNAME}.jar:${DISTDIR}/swingall.jar \
+ ${SETENV} CLASSPATH=${DISTDIR}/${DISTNAME}.jar \
${LOCALBASE}/bin/javavm installer.Install text
- @${INSTALL_DATA} ${DISTDIR}/swingall.jar ${PREFIX}/share/java/jedit
@${INSTALL_SCRIPT} ${WRKDIR}/jedit.sh ${PREFIX}/bin/jedit
.if defined(PARALLEL_PACKAGE_BUILD)
diff --git a/editors/jedit/distinfo b/editors/jedit/distinfo
index f879d79d814c..b1482e470bfd 100644
--- a/editors/jedit/distinfo
+++ b/editors/jedit/distinfo
@@ -1,2 +1 @@
-MD5 (jedit322install.jar) = f49a6f5fd0b39b234019e6da0c4eca0d
-MD5 (swingall.jar) = 356f8091f94afcb128a3477dec5e8755
+MD5 (jedit40install.jar) = 1529f8ed897cac582a0bc098fdc26a70
diff --git a/editors/jedit/files/instscript b/editors/jedit/files/instscript
index 6fc9bb3eba8b..97e361decb7f 100644
--- a/editors/jedit/files/instscript
+++ b/editors/jedit/files/instscript
@@ -2,5 +2,4 @@
%%WRKDIR%%
Y
Y
-Y
diff --git a/editors/jedit/files/jedit.sh b/editors/jedit/files/jedit.sh
index 2d74fbb1e80c..10a8359c5def 100644
--- a/editors/jedit/files/jedit.sh
+++ b/editors/jedit/files/jedit.sh
@@ -1,6 +1,8 @@
#!/bin/sh
# $FreeBSD$
-CLASSPATH=${CLASSPATH}:%%PREFIX%%/share/java/jedit/swingall.jar:%%PREFIX%%/share/java/jedit/jedit.jar
-export CLASSPATH
-exec %%LOCALBASE%%/bin/javavm org.gjt.sp.jedit.jEdit "$@"
+# Java heap size, in megabytes
+JAVA_HEAP_SIZE=32
+
+exec %%LOCALBASE%%/bin/javavm -mx${JAVA_HEAP_SIZE}m ${JEDIT} -jar \
+ "%%PREFIX%%/share/java/jedit/jedit.jar" "$@"
diff --git a/editors/jedit/pkg-plist b/editors/jedit/pkg-plist
index 37f4c1573fb0..53699de0e224 100644
--- a/editors/jedit/pkg-plist
+++ b/editors/jedit/pkg-plist
@@ -2,55 +2,275 @@ bin/jedit
share/java/jedit/doc/CHANGES.txt
share/java/jedit/doc/COPYING.DOC.txt
share/java/jedit/doc/COPYING.txt
+share/java/jedit/doc/FAQ/appendix.html
+share/java/jedit/doc/FAQ/getting-jedit.html
+share/java/jedit/doc/FAQ/index.html
+share/java/jedit/doc/FAQ/installing-jedit.html
+share/java/jedit/doc/FAQ/legal-notice.html
+share/java/jedit/doc/FAQ/macros.html
+share/java/jedit/doc/FAQ/other-customizing.html
+share/java/jedit/doc/FAQ/plugins.html
+share/java/jedit/doc/FAQ/problems.html
+share/java/jedit/doc/FAQ/toc.xml
+share/java/jedit/doc/FAQ/working-files.html
+share/java/jedit/doc/FAQ/working-source-code.html
+share/java/jedit/doc/FAQ/working-text.html
share/java/jedit/doc/ICONS.LICENSE.txt
share/java/jedit/doc/NEWS.txt
share/java/jedit/doc/README.txt
share/java/jedit/doc/TODO.txt
-share/java/jedit/jars/Firewall.jar
+share/java/jedit/doc/jedit.gif
+share/java/jedit/doc/tips/tip0.html
+share/java/jedit/doc/tips/tip1.html
+share/java/jedit/doc/tips/tip10.html
+share/java/jedit/doc/tips/tip11.html
+share/java/jedit/doc/tips/tip12.html
+share/java/jedit/doc/tips/tip13.html
+share/java/jedit/doc/tips/tip14.html
+share/java/jedit/doc/tips/tip15.html
+share/java/jedit/doc/tips/tip16.html
+share/java/jedit/doc/tips/tip17.html
+share/java/jedit/doc/tips/tip18.html
+share/java/jedit/doc/tips/tip19.html
+share/java/jedit/doc/tips/tip2.html
+share/java/jedit/doc/tips/tip20.html
+share/java/jedit/doc/tips/tip21.html
+share/java/jedit/doc/tips/tip22.html
+share/java/jedit/doc/tips/tip23.html
+share/java/jedit/doc/tips/tip24.html
+share/java/jedit/doc/tips/tip25.html
+share/java/jedit/doc/tips/tip26.html
+share/java/jedit/doc/tips/tip27.html
+share/java/jedit/doc/tips/tip28.html
+share/java/jedit/doc/tips/tip29.html
+share/java/jedit/doc/tips/tip3.html
+share/java/jedit/doc/tips/tip30.html
+share/java/jedit/doc/tips/tip31.html
+share/java/jedit/doc/tips/tip32.html
+share/java/jedit/doc/tips/tip33.html
+share/java/jedit/doc/tips/tip34.html
+share/java/jedit/doc/tips/tip35.html
+share/java/jedit/doc/tips/tip36.html
+share/java/jedit/doc/tips/tip37.html
+share/java/jedit/doc/tips/tip38.html
+share/java/jedit/doc/tips/tip39.html
+share/java/jedit/doc/tips/tip4.html
+share/java/jedit/doc/tips/tip40.html
+share/java/jedit/doc/tips/tip41.html
+share/java/jedit/doc/tips/tip42.html
+share/java/jedit/doc/tips/tip43.html
+share/java/jedit/doc/tips/tip44.html
+share/java/jedit/doc/tips/tip45.html
+share/java/jedit/doc/tips/tip46.html
+share/java/jedit/doc/tips/tip47.html
+share/java/jedit/doc/tips/tip48.html
+share/java/jedit/doc/tips/tip49.html
+share/java/jedit/doc/tips/tip5.html
+share/java/jedit/doc/tips/tip50.html
+share/java/jedit/doc/tips/tip51.html
+share/java/jedit/doc/tips/tip52.html
+share/java/jedit/doc/tips/tip53.html
+share/java/jedit/doc/tips/tip54.html
+share/java/jedit/doc/tips/tip55.html
+share/java/jedit/doc/tips/tip56.html
+share/java/jedit/doc/tips/tip57.html
+share/java/jedit/doc/tips/tip58.html
+share/java/jedit/doc/tips/tip59.html
+share/java/jedit/doc/tips/tip6.html
+share/java/jedit/doc/tips/tip60.html
+share/java/jedit/doc/tips/tip61.html
+share/java/jedit/doc/tips/tip62.html
+share/java/jedit/doc/tips/tip63.html
+share/java/jedit/doc/tips/tip64.html
+share/java/jedit/doc/tips/tip65.html
+share/java/jedit/doc/tips/tip66.html
+share/java/jedit/doc/tips/tip67.html
+share/java/jedit/doc/tips/tip68.html
+share/java/jedit/doc/tips/tip69.html
+share/java/jedit/doc/tips/tip7.html
+share/java/jedit/doc/tips/tip70.html
+share/java/jedit/doc/tips/tip71.html
+share/java/jedit/doc/tips/tip72.html
+share/java/jedit/doc/tips/tip73.html
+share/java/jedit/doc/tips/tip74.html
+share/java/jedit/doc/tips/tip75.html
+share/java/jedit/doc/tips/tip8.html
+share/java/jedit/doc/tips/tip9.html
+share/java/jedit/doc/users-guide/abbrevs.html
+share/java/jedit/doc/users-guide/activity-log.html
+share/java/jedit/doc/users-guide/add-prefix-and-suffix.html
+share/java/jedit/doc/users-guide/api-guide-part.html
+share/java/jedit/doc/users-guide/api-guide.html
+share/java/jedit/doc/users-guide/api-message.html
+share/java/jedit/doc/users-guide/api-option-classes.html
+share/java/jedit/doc/users-guide/api-other-resources.html
+share/java/jedit/doc/users-guide/basics.html
+share/java/jedit/doc/users-guide/beanshell-commands-file.html
+share/java/jedit/doc/users-guide/beanshell-commands-object.html
+share/java/jedit/doc/users-guide/beanshell-commands-other.html
+share/java/jedit/doc/users-guide/beanshell-commands-resource.html
+share/java/jedit/doc/users-guide/beanshell-commands-script.html
+share/java/jedit/doc/users-guide/beanshell-commands-serial.html
+share/java/jedit/doc/users-guide/beanshell-commands.html
+share/java/jedit/doc/users-guide/bracket-matching.html
+share/java/jedit/doc/users-guide/buffer-local.html
+share/java/jedit/doc/users-guide/class-abstractoptionpane.html
+share/java/jedit/doc/users-guide/class-beanshell.html
+share/java/jedit/doc/users-guide/class-buffer.html
+share/java/jedit/doc/users-guide/class-bufferupdate.html
+share/java/jedit/doc/users-guide/class-dockablewindowmanager.html
+share/java/jedit/doc/users-guide/class-ebcomponent.html
+share/java/jedit/doc/users-guide/class-ebmessage.html
+share/java/jedit/doc/users-guide/class-editorexiting.html
+share/java/jedit/doc/users-guide/class-editorexitrequested.html
+share/java/jedit/doc/users-guide/class-editorstarted.html
+share/java/jedit/doc/users-guide/class-editpaneupdate.html
+share/java/jedit/doc/users-guide/class-guiutilities.html
+share/java/jedit/doc/users-guide/class-jedittextarea.html
+share/java/jedit/doc/users-guide/class-macros.html
+share/java/jedit/doc/users-guide/class-macroschanged.html
+share/java/jedit/doc/users-guide/class-miscutilities.html
+share/java/jedit/doc/users-guide/class-optiongroup.html
+share/java/jedit/doc/users-guide/class-propertieschanged.html
+share/java/jedit/doc/users-guide/class-registers.html
+share/java/jedit/doc/users-guide/class-searchandreplace.html
+share/java/jedit/doc/users-guide/class-searchsettingschanged.html
+share/java/jedit/doc/users-guide/class-textutilities.html
+share/java/jedit/doc/users-guide/class-vfsupdate.html
+share/java/jedit/doc/users-guide/class-view.html
+share/java/jedit/doc/users-guide/class-viewupdate.html
+share/java/jedit/doc/users-guide/cli-usage.html
+share/java/jedit/doc/users-guide/closing-exiting.html
+share/java/jedit/doc/users-guide/commenting.html
+share/java/jedit/doc/users-guide/customizing.html
+share/java/jedit/doc/users-guide/dialog-macro.html
+share/java/jedit/doc/users-guide/editing.html
+share/java/jedit/doc/users-guide/encodings.html
+share/java/jedit/doc/users-guide/entering-text.html
+share/java/jedit/doc/users-guide/example-building.html
+share/java/jedit/doc/users-guide/files.html
+share/java/jedit/doc/users-guide/folding.html
+share/java/jedit/doc/users-guide/global-opts.html
+share/java/jedit/doc/users-guide/globs.html
+share/java/jedit/doc/users-guide/helpful-methods.html
+share/java/jedit/doc/users-guide/history.html
+share/java/jedit/doc/users-guide/host-design-conclusion.html
+share/java/jedit/doc/users-guide/host-design-display.html
+share/java/jedit/doc/users-guide/host-design-editbus.html
+share/java/jedit/doc/users-guide/host-design-resources.html
+share/java/jedit/doc/users-guide/host-design.html
+share/java/jedit/doc/users-guide/indent.html
+share/java/jedit/doc/users-guide/index.html
+share/java/jedit/doc/users-guide/installing-modes.html
+share/java/jedit/doc/users-guide/installing-plugins.html
+share/java/jedit/doc/users-guide/launcher-examples.html
+share/java/jedit/doc/users-guide/launcher-guide.html
+share/java/jedit/doc/users-guide/launcher-interface.html
+share/java/jedit/doc/users-guide/launcher-jedidiff.html
+share/java/jedit/doc/users-guide/launcher-legalnotice.html
+share/java/jedit/doc/users-guide/launcher-logging.html
+share/java/jedit/doc/users-guide/launcher-menu.html
+share/java/jedit/doc/users-guide/launcher-starting.html
+share/java/jedit/doc/users-guide/launcher-uninstall.html
+share/java/jedit/doc/users-guide/line-separators.html
+share/java/jedit/doc/users-guide/lines.html
+share/java/jedit/doc/users-guide/macro-analysis.html
+share/java/jedit/doc/users-guide/macro-basics.html
+share/java/jedit/doc/users-guide/macro-index.html
+share/java/jedit/doc/users-guide/macro-tips-BeanShell.html
+share/java/jedit/doc/users-guide/macro-tips-debugging.html
+share/java/jedit/doc/users-guide/macro-tips.html
+share/java/jedit/doc/users-guide/macros-java.html
+share/java/jedit/doc/users-guide/macros-misc.html
+share/java/jedit/doc/users-guide/macros-properties.html
+share/java/jedit/doc/users-guide/macros-text.html
+share/java/jedit/doc/users-guide/markers.html
+share/java/jedit/doc/users-guide/mode-preamble.html
+share/java/jedit/doc/users-guide/mode-tag-props.html
+share/java/jedit/doc/users-guide/mode-tag-rules.html
+share/java/jedit/doc/users-guide/opening.html
+share/java/jedit/doc/users-guide/option-implement.html
+share/java/jedit/doc/users-guide/organizing-macros.html
+share/java/jedit/doc/users-guide/paragraphs.html
+share/java/jedit/doc/users-guide/plugin-api.html
+share/java/jedit/doc/users-guide/plugin-implement-class.html
+share/java/jedit/doc/users-guide/plugin-implement.html
+share/java/jedit/doc/users-guide/plugin-intro.html
+share/java/jedit/doc/users-guide/printing.html
+share/java/jedit/doc/users-guide/regexps.html
+share/java/jedit/doc/users-guide/reloading.html
+share/java/jedit/doc/users-guide/repeat.html
+share/java/jedit/doc/users-guide/resources-implement.html
+share/java/jedit/doc/users-guide/running-macros.html
+share/java/jedit/doc/users-guide/saving.html
+share/java/jedit/doc/users-guide/scripts-command-line.html
+share/java/jedit/doc/users-guide/scrolling.html
+share/java/jedit/doc/users-guide/search-replace.html
+share/java/jedit/doc/users-guide/selection.html
+share/java/jedit/doc/users-guide/settings-directory.html
+share/java/jedit/doc/users-guide/shortcuts.html
+share/java/jedit/doc/users-guide/simple-macros.html
+share/java/jedit/doc/users-guide/single-macros.html
+share/java/jedit/doc/users-guide/something-useful.html
+share/java/jedit/doc/users-guide/source-edit.html
+share/java/jedit/doc/users-guide/starting-any-os.html
+share/java/jedit/doc/users-guide/starting-windows.html
+share/java/jedit/doc/users-guide/starting.html
+share/java/jedit/doc/users-guide/startup-scripts.html
+share/java/jedit/doc/users-guide/text-transfer.html
+share/java/jedit/doc/users-guide/textarea.html
+share/java/jedit/doc/users-guide/threaded-io.html
+share/java/jedit/doc/users-guide/toc.xml
+share/java/jedit/doc/users-guide/undo-redo.html
+share/java/jedit/doc/users-guide/updating-plugins.html
+share/java/jedit/doc/users-guide/using-jedit-part.html
+share/java/jedit/doc/users-guide/using-macros.html
+share/java/jedit/doc/users-guide/using-plugins.html
+share/java/jedit/doc/users-guide/vfs-browser.html
+share/java/jedit/doc/users-guide/views.html
+share/java/jedit/doc/users-guide/window-implement.html
+share/java/jedit/doc/users-guide/window-visible-implement.html
+share/java/jedit/doc/users-guide/word-wrap.html
+share/java/jedit/doc/users-guide/words.html
+share/java/jedit/doc/users-guide/writing-macros-part.html
+share/java/jedit/doc/users-guide/writing-modes-part.html
+share/java/jedit/doc/users-guide/writing-modes.html
+share/java/jedit/doc/users-guide/writing-plugins-part.html
+share/java/jedit/doc/welcome.html
share/java/jedit/jars/LatestVersion.jar
+share/java/jedit/jars/QuickNotepad.jar
share/java/jedit/jedit.jar
share/java/jedit/macros/Files/Browse_Directory.bsh
share/java/jedit/macros/Files/Close_All_Except_Active.bsh
-share/java/jedit/macros/Files/Go_to_File_System_Browser.bsh
share/java/jedit/macros/Files/Open_Path.bsh
share/java/jedit/macros/Files/Open_Selection.bsh
share/java/jedit/macros/Java/Get_Class_Name.bsh
share/java/jedit/macros/Java/Get_Package_Name.bsh
share/java/jedit/macros/Java/Make_Get_and_Set_Methods.bsh
-share/java/jedit/macros/Java/Tidy_Block_Comments.bsh
+share/java/jedit/macros/Java/Preview_Javadoc_of_Buffer.bsh
share/java/jedit/macros/Misc/Cascade_jEdit_Windows.bsh
-share/java/jedit/macros/Misc/Copy_Mode_Abbrevs.bsh
share/java/jedit/macros/Misc/Display_Abbreviations.bsh
share/java/jedit/macros/Misc/Display_Shortcuts.bsh
share/java/jedit/macros/Misc/Evaluate_Buffer_in_BeanShell.bsh
-share/java/jedit/macros/Misc/Go_to_Text_Area.bsh
+share/java/jedit/macros/Misc/Hex_Convert.bsh
share/java/jedit/macros/Misc/Include_Guard.bsh
-share/java/jedit/macros/Misc/List_Plugin_Internal_Names.bsh
share/java/jedit/macros/Misc/Make_Bug_Report.bsh
share/java/jedit/macros/Misc/Properties/Look_and_Feel_Properties.bsh
share/java/jedit/macros/Misc/Properties/System_Properties.bsh
share/java/jedit/macros/Misc/Properties/jEdit_Properties.bsh
-share/java/jedit/macros/Misc/Run_Macro_at_Caret.bsh
-share/java/jedit/macros/Misc/Show_Free_Memory.bsh
-share/java/jedit/macros/Search/Find_First_Occurrence.bsh
-share/java/jedit/macros/Search/Find_Last_Occurrence.bsh
-share/java/jedit/macros/Search/Find_Matching_File.bsh
-share/java/jedit/macros/Search/Find_Next_Occurrence.bsh
-share/java/jedit/macros/Search/Find_Occurrence.bsh
-share/java/jedit/macros/Search/Find_Previous_Occurrence.bsh
-share/java/jedit/macros/Search/Next_Char.bsh
-share/java/jedit/macros/Search/Return_From_Find.bsh
-share/java/jedit/macros/Search/Write_HyperSearch_Results.bsh
+share/java/jedit/macros/Misc/Run_Script.bsh
+share/java/jedit/macros/Misc/Show_Threads.bsh
+share/java/jedit/macros/Misc/Write_HyperSearch_Results.bsh
share/java/jedit/macros/Text/Add_Prefix_and_Suffix.bsh
share/java/jedit/macros/Text/Color_Picker.bsh
share/java/jedit/macros/Text/Duplicate_Line.bsh
share/java/jedit/macros/Text/Insert_Date.bsh
share/java/jedit/macros/Text/Insert_Tag.bsh
-share/java/jedit/macros/Text/Make_Double_Box_Comment.bsh
-share/java/jedit/macros/Text/Reverse.bsh
-share/java/jedit/macros/Text/Rot13.bsh
+share/java/jedit/macros/Text/Next_Char.bsh
share/java/jedit/macros/Text/Toggle_Line_Comment.bsh
-share/java/jedit/macros/Text/Write_File_Header.bsh
+share/java/jedit/macros/Text/Vertical_Paste.bsh
+share/java/jedit/modes/4gl.xml
+share/java/jedit/modes/actionscript.xml
share/java/jedit/modes/ada95.xml
share/java/jedit/modes/asp.xml
share/java/jedit/modes/assembly-r2000.xml
@@ -58,8 +278,10 @@ share/java/jedit/modes/assembly-x86.xml
share/java/jedit/modes/awk.xml
share/java/jedit/modes/b.xml
share/java/jedit/modes/batch.xml
+share/java/jedit/modes/bbj.xml
share/java/jedit/modes/bcel.xml
share/java/jedit/modes/beanshell.xml
+share/java/jedit/modes/bibtex.xml
share/java/jedit/modes/c.xml
share/java/jedit/modes/catalog
share/java/jedit/modes/cobol.xml
@@ -71,6 +293,7 @@ share/java/jedit/modes/dsssl.xml
share/java/jedit/modes/eiffel.xml
share/java/jedit/modes/foxpro.xml
share/java/jedit/modes/haskell.xml
+share/java/jedit/modes/hex.xml
share/java/jedit/modes/html.xml
share/java/jedit/modes/idl.xml
share/java/jedit/modes/inform.xml
@@ -83,8 +306,10 @@ share/java/jedit/modes/jsp.xml
share/java/jedit/modes/lisp.xml
share/java/jedit/modes/makefile.xml
share/java/jedit/modes/ml.xml
+share/java/jedit/modes/modula3.xml
share/java/jedit/modes/netrexx.xml
share/java/jedit/modes/objective-c.xml
+share/java/jedit/modes/objectrexx.xml
share/java/jedit/modes/occam.xml
share/java/jedit/modes/omnimark.xml
share/java/jedit/modes/pascal.xml
@@ -95,15 +320,18 @@ share/java/jedit/modes/pl-sql.xml
share/java/jedit/modes/postscript.xml
share/java/jedit/modes/povray.xml
share/java/jedit/modes/progress.xml
+share/java/jedit/modes/prolog.xml
share/java/jedit/modes/props.xml
share/java/jedit/modes/pvwave.xml
share/java/jedit/modes/python.xml
+share/java/jedit/modes/rebol.xml
share/java/jedit/modes/rpmspec.xml
share/java/jedit/modes/ruby.xml
share/java/jedit/modes/rview.xml
share/java/jedit/modes/sgml.xml
share/java/jedit/modes/shellscript.xml
share/java/jedit/modes/shtml.xml
+share/java/jedit/modes/smalltalk.xml
share/java/jedit/modes/sqr.xml
share/java/jedit/modes/tcl.xml
share/java/jedit/modes/tex.xml
@@ -118,18 +346,18 @@ share/java/jedit/modes/xml.xml
share/java/jedit/modes/xsl.xml
share/java/jedit/properties/README.txt
share/java/jedit/startup/README.txt
-share/java/jedit/startup/changeUIFonts.bsh
-share/java/jedit/swingall.jar
@dirrm share/java/jedit/startup
@dirrm share/java/jedit/properties
@dirrm share/java/jedit/modes
@dirrm share/java/jedit/macros/Text
-@dirrm share/java/jedit/macros/Search
@dirrm share/java/jedit/macros/Misc/Properties
@dirrm share/java/jedit/macros/Misc
@dirrm share/java/jedit/macros/Java
@dirrm share/java/jedit/macros/Files
@dirrm share/java/jedit/macros
@dirrm share/java/jedit/jars
+@dirrm share/java/jedit/doc/users-guide
+@dirrm share/java/jedit/doc/tips
+@dirrm share/java/jedit/doc/FAQ
@dirrm share/java/jedit/doc
@dirrm share/java/jedit