aboutsummaryrefslogtreecommitdiff
path: root/editors/kate-plugins
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2004-03-09 12:56:31 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2004-03-09 12:56:31 +0000
commitc726e8e6f34a5a230d144029accbc96869835542 (patch)
tree4c6754347adad0ec229fb133cc4725530aa263b2 /editors/kate-plugins
parente20877a3a93950a65b7723430c213ba23cd2eb22 (diff)
downloadports-c726e8e6f34a5a230d144029accbc96869835542.tar.gz
ports-c726e8e6f34a5a230d144029accbc96869835542.zip
Notes
Diffstat (limited to 'editors/kate-plugins')
-rw-r--r--editors/kate-plugins/Makefile36
-rw-r--r--editors/kate-plugins/distinfo2
-rw-r--r--editors/kate-plugins/pkg-descr5
-rw-r--r--editors/kate-plugins/pkg-plist79
4 files changed, 122 insertions, 0 deletions
diff --git a/editors/kate-plugins/Makefile b/editors/kate-plugins/Makefile
new file mode 100644
index 000000000000..58818e76d56f
--- /dev/null
+++ b/editors/kate-plugins/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: kdeaddons-kate-plugins
+# Date created: 11 Feb 2004 19:51:40
+# Whom: Michael Nottebrock <lofi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ${KATEPLUGINS_PORTNAME}
+PORTVERSION= ${KATEPLUGINS_PORTVERSION}
+PORTREVISION= ${KATEPLUGINS_PORTREVISION}
+CATEGORIES= editors kde
+MASTER_SITES= ${MASTER_SITE_KDE}
+MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
+DIST_SUBDIR= KDE
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Additonal plugins and features for kate
+
+IGNORE= This port is part of KDE 3.2.1 and is not yet ready
+
+KDE_SPLIT= kate
+KDE_DOC_SPLIT= kate-plugins
+USE_KDEBASE_VER=3
+USE_KDELIBS_VER=3
+
+USE_BZIP2= yes
+PREFIX= ${KDE_PREFIX}
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+INSTALLS_SHLIB= yes
+LDCONFIG_DIRS+= %%PREFIX%%/lib/kde3
+
+.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
+.include "${.CURDIR}/../../misc/kdeaddons3/Makefile.split"
+.include <bsd.port.mk>
diff --git a/editors/kate-plugins/distinfo b/editors/kate-plugins/distinfo
new file mode 100644
index 000000000000..95aca618ce40
--- /dev/null
+++ b/editors/kate-plugins/distinfo
@@ -0,0 +1,2 @@
+MD5 (KDE/kdeaddons-3.2.1.tar.bz2) = c73c1777d3f5c25f46cd782fcca9fc35
+SIZE (KDE/kdeaddons-3.2.1.tar.bz2) = 1371322
diff --git a/editors/kate-plugins/pkg-descr b/editors/kate-plugins/pkg-descr
new file mode 100644
index 000000000000..b1b917e9cd96
--- /dev/null
+++ b/editors/kate-plugins/pkg-descr
@@ -0,0 +1,5 @@
+Additional plugins and features for Kate.
+
+WWW: http://www.kde.org/
+
+
diff --git a/editors/kate-plugins/pkg-plist b/editors/kate-plugins/pkg-plist
new file mode 100644
index 000000000000..934c872a263d
--- /dev/null
+++ b/editors/kate-plugins/pkg-plist
@@ -0,0 +1,79 @@
+lib/kde3/katecppsymbolviewerplugin.la
+lib/kde3/katecppsymbolviewerplugin.so
+lib/kde3/katefll_initplugin.la
+lib/kde3/katefll_initplugin.so
+lib/kde3/katefll_plugin.la
+lib/kde3/katefll_plugin.so
+lib/kde3/katehtmltoolsplugin.la
+lib/kde3/katehtmltoolsplugin.so
+lib/kde3/kateinsertcommandplugin.la
+lib/kde3/kateinsertcommandplugin.so
+lib/kde3/katemodelineplugin.la
+lib/kde3/katemodelineplugin.so
+lib/kde3/kateopenheaderplugin.la
+lib/kde3/kateopenheaderplugin.so
+lib/kde3/katepybrowseplugin.la
+lib/kde3/katepybrowseplugin.so
+lib/kde3/katetextfilterplugin.la
+lib/kde3/katetextfilterplugin.so
+lib/kde3/katexmlcheckplugin.la
+lib/kde3/katexmlcheckplugin.so
+lib/kde3/katexmltoolsplugin.la
+lib/kde3/katexmltoolsplugin.so
+share/applications/kdeaddons-kate-plugins-3.2.1
+share/applnk/.hidden/katefll.desktop
+share/apps/kate/plugins/katecppsymbolviewer/ui.rc
+share/apps/kate/plugins/katefll/ui.rc
+share/apps/kate/plugins/katehtmltools/ui.rc
+share/apps/kate/plugins/kateinsertcommand/ui.rc
+share/apps/kate/plugins/katemodeline/ui.rc
+share/apps/kate/plugins/kateopenheader/ui.rc
+share/apps/kate/plugins/katepybrowse/ui.rc
+share/apps/kate/plugins/katetextfilter/ui.rc
+share/apps/kate/plugins/katexmlcheck/ui.rc
+share/apps/kate/plugins/katexmltools/ui.rc
+share/apps/kate/scripts/html-tidy.desktop
+share/apps/kate/scripts/html-tidy.sh
+share/apps/katexmltools/html4-loose.dtd.xml
+share/apps/katexmltools/html4-strict.dtd.xml
+share/apps/katexmltools/kde-docbook.dtd.xml
+share/apps/katexmltools/kpartgui.dtd.xml
+share/apps/katexmltools/language.dtd.xml
+share/apps/katexmltools/simplify_dtd.xsl
+share/apps/katexmltools/testcases.xml
+share/apps/katexmltools/xhtml1-frameset.dtd.xml
+share/apps/katexmltools/xhtml1-strict.dtd.xml
+share/apps/katexmltools/xhtml1-transitional.dtd.xml
+share/apps/katexmltools/xslt-1.0.dtd.xml
+share/doc/HTML/en/kate-plugins/common
+share/doc/HTML/en/kate-plugins/htmltools.docbook
+share/doc/HTML/en/kate-plugins/index.cache.bz2
+share/doc/HTML/en/kate-plugins/index.docbook
+share/doc/HTML/en/kate-plugins/insertcommand.docbook
+share/doc/HTML/en/kate-plugins/openheader.docbook
+share/doc/HTML/en/kate-plugins/textfilter.docbook
+share/doc/HTML/en/kate-plugins/xmlcheck.docbook
+share/doc/HTML/en/kate-plugins/xmltools.docbook
+share/services/katecppsymbolviewer.desktop
+share/services/katefll_initplugin.desktop
+share/services/katefll_plugin.desktop
+share/services/katehtmltools.desktop
+share/services/kateinsertcommand.desktop
+share/services/katemodeline.desktop
+share/services/kateopenheader.desktop
+share/services/katepybrowse.desktop
+share/services/katetextfilter.desktop
+share/services/katexmlcheck.desktop
+share/services/katexmltools.desktop
+@dirrm share/doc/HTML/en/kate-plugins
+@dirrm share/apps/katexmltools
+@dirrm share/apps/kate/plugins/katexmltools
+@dirrm share/apps/kate/plugins/katexmlcheck
+@dirrm share/apps/kate/plugins/katetextfilter
+@dirrm share/apps/kate/plugins/katepybrowse
+@dirrm share/apps/kate/plugins/kateopenheader
+@dirrm share/apps/kate/plugins/katemodeline
+@dirrm share/apps/kate/plugins/kateinsertcommand
+@dirrm share/apps/kate/plugins/katehtmltools
+@dirrm share/apps/kate/plugins/katefll
+@dirrm share/apps/kate/plugins/katecppsymbolviewer