aboutsummaryrefslogtreecommitdiff
path: root/editors/lazarus
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2018-01-30 18:54:06 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2018-01-30 18:54:06 +0000
commit227069da3b0a99549b9590459a307d17bd33307c (patch)
treedc624c95533fd1930c16c5960ec391664b79aaca /editors/lazarus
parenteaf0b332d992a25bad04a843e456821cd3f12c4c (diff)
downloadports-227069da3b0a99549b9590459a307d17bd33307c.tar.gz
ports-227069da3b0a99549b9590459a307d17bd33307c.zip
- Update to 1.8.0
- Connect editors/lazarus-lcl-qt5 port
Notes
Notes: svn path=/head/; revision=460429
Diffstat (limited to 'editors/lazarus')
-rw-r--r--editors/lazarus/Makefile17
-rw-r--r--editors/lazarus/distinfo6
-rw-r--r--editors/lazarus/files/patch-components-synedit_synedit.pp20
-rw-r--r--editors/lazarus/files/pkg-message.in3
4 files changed, 37 insertions, 9 deletions
diff --git a/editors/lazarus/Makefile b/editors/lazarus/Makefile
index 19fac27b03aa..d40ea24ad6e0 100644
--- a/editors/lazarus/Makefile
+++ b/editors/lazarus/Makefile
@@ -2,11 +2,10 @@
# $FreeBSD$
PORTNAME= lazarus
-PORTVERSION= 1.6.4
-DISTVERSIONSUFFIX= -0
+PORTVERSION= 1.8.0
PORTREVISION?= 0
CATEGORIES= editors devel
-MASTER_SITES= SF/${PORTNAME}/Lazarus%20Zip%20_%20GZip/Lazarus%20${PORTVERSION:S/.0//} \
+MASTER_SITES= SF/${PORTNAME}/Lazarus%20Zip%20_%20GZip/Lazarus%20${PORTVERSION} \
LOCAL/acm/freepascal
DIST_SUBDIR= freepascal
@@ -33,11 +32,12 @@ DATADIR?= ${PREFIX}/share/${PORTNAME}-${PORTVERSION}
.if !defined(PKGNAMESUFFIX)
OPTIONS_DEFINE= GDB
OPTIONS_SINGLE= LCL
-OPTIONS_SINGLE_LCL= GTK2 QT4
+OPTIONS_SINGLE_LCL= GTK2 QT4 QT5
GDB_DESC= Install a newest version of gdb
GTK2_DESC= Use gtk20 interface
QT4_DESC= Use qt4 interface
+QT5_DESC= Use qt5 interface
OPTIONS_DEFAULT= GTK2 GDB
.endif
@@ -82,6 +82,13 @@ BUILD_DEPENDS+= ${LCL_UNITS_DIR}/${LCL_PLATFORM}/interfaces.ppu:editors/lazarus-
RUN_DEPENDS+= ${LCL_UNITS_DIR}/${LCL_PLATFORM}/interfaces.ppu:editors/lazarus-lcl-qt
.endif
+.if ${PORT_OPTIONS:MQT5}
+LIB_DEPENDS+= libQt5Pas.so:x11-toolkits/qt5pas
+LCL_PLATFORM= qt5
+BUILD_DEPENDS+= ${LCL_UNITS_DIR}/${LCL_PLATFORM}/interfaces.ppu:editors/lazarus-lcl-qt5
+RUN_DEPENDS+= ${LCL_UNITS_DIR}/${LCL_PLATFORM}/interfaces.ppu:editors/lazarus-lcl-qt5
+.endif
+
post-extract:
@${MKDIR} ${WRKDIR}/man1
@${MV} ${WRKSRC}/install/man/man1/lazarus-ide.1 ${WRKDIR}/man1/
@@ -92,7 +99,7 @@ post-extract:
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' -e 's|%%DATADIR%%|${DATADIR}|g' \
- -e 's|tools: lcl|tools:|g' -e '3080d' -e '3082d' -e '3083d' -e '3084d' -e '3085d' -e '3086d' ${WRKSRC}/${MAKEFILE}
+ -e 's|tools: lcl|tools:|g' -e '3267d' -e '3269d' -e '3270d' -e '3271d' -e '3272d' -e '3273d' ${WRKSRC}/${MAKEFILE}
pre-build:
@${LN} -sf ${LOCALBASE}/share/${PORTNAME}-${PORTVERSION}/lcl/units ${WRKSRC}/lcl/units
diff --git a/editors/lazarus/distinfo b/editors/lazarus/distinfo
index 8530e29429c0..fc2574cebbdf 100644
--- a/editors/lazarus/distinfo
+++ b/editors/lazarus/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1488377664
-SHA256 (freepascal/lazarus-1.6.4-0.tar.gz) = 336654c5ad32244e64a56511108965b6b8eb25fe5882f61b2c15a24d8435a5e2
-SIZE (freepascal/lazarus-1.6.4-0.tar.gz) = 57180961
+TIMESTAMP = 1513100874
+SHA256 (freepascal/lazarus-1.8.0.tar.gz) = 320888ba1af17295b8d3993d50c31780d137e363e05797e3575eee90f3b3a844
+SIZE (freepascal/lazarus-1.8.0.tar.gz) = 62114372
diff --git a/editors/lazarus/files/patch-components-synedit_synedit.pp b/editors/lazarus/files/patch-components-synedit_synedit.pp
new file mode 100644
index 000000000000..92a6300235d4
--- /dev/null
+++ b/editors/lazarus/files/patch-components-synedit_synedit.pp
@@ -0,0 +1,20 @@
+--- components/synedit/synedit.pp 2018-01-30 13:41:54.904942000 -0500
++++ components/synedit/synedit.pp 2018-01-30 13:40:23.811860000 -0500
+@@ -8945,7 +8945,7 @@
+ while not Highlighter.GetEol do begin
+ Start := Highlighter.GetTokenPos + 1;
+ Token := Highlighter.GetToken;
+- if (PosX >= Start) and (PosX <= Start + Length(Token)) then begin
++ if (PosX >= Start) and (PosX < Start + Length(Token)) then begin
+ Attri := Highlighter.GetTokenAttribute;
+ TokenType := Highlighter.GetTokenKind;
+ exit(True);
+@@ -8990,7 +8990,7 @@
+ //TokenType := Highlighter.GetTokenKind;
+ Attri := Highlighter.GetTokenAttribute;
+ //DebugLn([' TCustomSynEdit.CaretAtIdentOrString: Start=', Start, ', Token=', Token]);
+- if (PosX >= Start) and (PosX <= Start + Length(Token)) then
++ if (PosX >= Start) and (PosX < Start + Length(Token)) then
+ begin
+ AtIdent := Attri = Highlighter.IdentifierAttribute;
+ NearString := (Attri = Highlighter.StringAttribute)
diff --git a/editors/lazarus/files/pkg-message.in b/editors/lazarus/files/pkg-message.in
index c9404b376f8e..185aa361e4c4 100644
--- a/editors/lazarus/files/pkg-message.in
+++ b/editors/lazarus/files/pkg-message.in
@@ -27,8 +27,9 @@ The Lazarus RAD was installed
editors/lazarus-lcl-nogui
editors/lazarus-lcl-gtk2
editors/lazarus-lcl-qt
+ editors/lazarus-lcl-qt5
- You can added those ports if you want support for nogui, gtk2 or qt
+ You can added those ports if you want support for nogui, gtk2, qt or qt5
interfaces. Please look at net-p2p/transmission-remote-gui like a example of
how use it