aboutsummaryrefslogtreecommitdiff
path: root/editors/lazarus
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2021-01-14 21:11:15 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2021-01-14 21:11:15 +0000
commit82ac7a6addf4acd4d46be4160b98e4b693dda1ed (patch)
tree9a3489c5baea68abb431eb168363d0435883d18b /editors/lazarus
parent769d44d09e80baaff52c32908e4b1d0dc7c0e2b1 (diff)
downloadports-82ac7a6addf4acd4d46be4160b98e4b693dda1ed.tar.gz
ports-82ac7a6addf4acd4d46be4160b98e4b693dda1ed.zip
- lang/fpc revert way like linker is taken by fpc compiler
- lang/fpc add binutils to RUN_DEPENDS - editors/lazarus add binutils to RUN_DEPENDS - editors/lazarus add gmake to RUN_DEPENDS - editors/lazarus install fpc units like RUN_DEPENDS too - Bump PORTREVISiON of fpc/lazarus ports PR: 251712 Reported by: amdmi3
Notes
Notes: svn path=/head/; revision=561593
Diffstat (limited to 'editors/lazarus')
-rw-r--r--editors/lazarus/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/editors/lazarus/Makefile b/editors/lazarus/Makefile
index 8d318b69f626..88e32620ecf6 100644
--- a/editors/lazarus/Makefile
+++ b/editors/lazarus/Makefile
@@ -4,7 +4,7 @@ PORTNAME= lazarus
PORTVERSION= 2.0.10
DISTVERSIONSUFFIX= -2
PKGNAMESUFFIX?= -gtk2
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES= editors devel
MASTER_SITES= SF/${PORTNAME}/Lazarus%20Zip%20_%20GZip/Lazarus%20${PORTVERSION} \
LOCAL/acm/freepascal
@@ -18,12 +18,13 @@ CONFLICTS?= ${PORTNAME}-qt5-*
BUILD_DEPENDS?= ${LOCALBASE}/bin/as:devel/binutils \
fpcres:lang/fpc-utils
RUN_DEPENDS?= ${LOCALBASE}/bin/as:devel/binutils \
+ gmake:devel/gmake \
fpcres:lang/fpc-utils \
${LOCALBASE}/share/fpc-source-${FPC_DEFAULT}/Makefile.fpc:lang/fpc-source
ONLY_FOR_ARCHS= i386 amd64
-USES= desktop-file-utils fpc gettext gmake iconv shared-mime-info xorg
+USES= desktop-file-utils fpc:run gettext gmake iconv shared-mime-info xorg
USE_FPC?= chm cairo dblib fcl-base fcl-db fcl-fpcunit fcl-image fcl-json fcl-net \
fcl-registry fcl-res fcl-web fcl-xml fppkg gtk2 ibase iconvenc mysql \
numlib odbc opengl openssl oracle pasjpeg postgres regexpr rtl-extra \
@@ -38,7 +39,7 @@ DATADIR?= ${PREFIX}/share/${PORTNAME}-${PORTVERSION}
OPTIONS_DEFINE= GDB
GDB_DESC= Install a newest version of gdb
-OPTIONS_DEFAULT= GTK2 GDB
+OPTIONS_DEFAULT= GDB
.include <bsd.port.options.mk>