aboutsummaryrefslogtreecommitdiff
path: root/editors/lazarus
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2018-01-30 22:11:13 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2018-01-30 22:11:13 +0000
commita78ac4eb9990a0c44bf11bdb522cbe7a3bf3ad45 (patch)
tree8f9016d16db947e0cef35ace15f5a66fd43323f0 /editors/lazarus
parent8d7b87d25932583d8d3c37792b2aa8f9dd29c0bf (diff)
downloadports-a78ac4eb9990a0c44bf11bdb522cbe7a3bf3ad45.tar.gz
ports-a78ac4eb9990a0c44bf11bdb522cbe7a3bf3ad45.zip
Revert recent fpc changes, they were obviously untested
With hat: portmgr
Notes
Notes: svn path=/head/; revision=460445
Diffstat (limited to 'editors/lazarus')
-rw-r--r--editors/lazarus/Makefile17
-rw-r--r--editors/lazarus/distinfo6
-rw-r--r--editors/lazarus/files/patch-components-synedit_synedit.pp20
-rw-r--r--editors/lazarus/files/pkg-message.in3
4 files changed, 9 insertions, 37 deletions
diff --git a/editors/lazarus/Makefile b/editors/lazarus/Makefile
index d40ea24ad6e0..19fac27b03aa 100644
--- a/editors/lazarus/Makefile
+++ b/editors/lazarus/Makefile
@@ -2,10 +2,11 @@
# $FreeBSD$
PORTNAME= lazarus
-PORTVERSION= 1.8.0
+PORTVERSION= 1.6.4
+DISTVERSIONSUFFIX= -0
PORTREVISION?= 0
CATEGORIES= editors devel
-MASTER_SITES= SF/${PORTNAME}/Lazarus%20Zip%20_%20GZip/Lazarus%20${PORTVERSION} \
+MASTER_SITES= SF/${PORTNAME}/Lazarus%20Zip%20_%20GZip/Lazarus%20${PORTVERSION:S/.0//} \
LOCAL/acm/freepascal
DIST_SUBDIR= freepascal
@@ -32,12 +33,11 @@ DATADIR?= ${PREFIX}/share/${PORTNAME}-${PORTVERSION}
.if !defined(PKGNAMESUFFIX)
OPTIONS_DEFINE= GDB
OPTIONS_SINGLE= LCL
-OPTIONS_SINGLE_LCL= GTK2 QT4 QT5
+OPTIONS_SINGLE_LCL= GTK2 QT4
GDB_DESC= Install a newest version of gdb
GTK2_DESC= Use gtk20 interface
QT4_DESC= Use qt4 interface
-QT5_DESC= Use qt5 interface
OPTIONS_DEFAULT= GTK2 GDB
.endif
@@ -82,13 +82,6 @@ BUILD_DEPENDS+= ${LCL_UNITS_DIR}/${LCL_PLATFORM}/interfaces.ppu:editors/lazarus-
RUN_DEPENDS+= ${LCL_UNITS_DIR}/${LCL_PLATFORM}/interfaces.ppu:editors/lazarus-lcl-qt
.endif
-.if ${PORT_OPTIONS:MQT5}
-LIB_DEPENDS+= libQt5Pas.so:x11-toolkits/qt5pas
-LCL_PLATFORM= qt5
-BUILD_DEPENDS+= ${LCL_UNITS_DIR}/${LCL_PLATFORM}/interfaces.ppu:editors/lazarus-lcl-qt5
-RUN_DEPENDS+= ${LCL_UNITS_DIR}/${LCL_PLATFORM}/interfaces.ppu:editors/lazarus-lcl-qt5
-.endif
-
post-extract:
@${MKDIR} ${WRKDIR}/man1
@${MV} ${WRKSRC}/install/man/man1/lazarus-ide.1 ${WRKDIR}/man1/
@@ -99,7 +92,7 @@ post-extract:
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' -e 's|%%DATADIR%%|${DATADIR}|g' \
- -e 's|tools: lcl|tools:|g' -e '3267d' -e '3269d' -e '3270d' -e '3271d' -e '3272d' -e '3273d' ${WRKSRC}/${MAKEFILE}
+ -e 's|tools: lcl|tools:|g' -e '3080d' -e '3082d' -e '3083d' -e '3084d' -e '3085d' -e '3086d' ${WRKSRC}/${MAKEFILE}
pre-build:
@${LN} -sf ${LOCALBASE}/share/${PORTNAME}-${PORTVERSION}/lcl/units ${WRKSRC}/lcl/units
diff --git a/editors/lazarus/distinfo b/editors/lazarus/distinfo
index fc2574cebbdf..8530e29429c0 100644
--- a/editors/lazarus/distinfo
+++ b/editors/lazarus/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1513100874
-SHA256 (freepascal/lazarus-1.8.0.tar.gz) = 320888ba1af17295b8d3993d50c31780d137e363e05797e3575eee90f3b3a844
-SIZE (freepascal/lazarus-1.8.0.tar.gz) = 62114372
+TIMESTAMP = 1488377664
+SHA256 (freepascal/lazarus-1.6.4-0.tar.gz) = 336654c5ad32244e64a56511108965b6b8eb25fe5882f61b2c15a24d8435a5e2
+SIZE (freepascal/lazarus-1.6.4-0.tar.gz) = 57180961
diff --git a/editors/lazarus/files/patch-components-synedit_synedit.pp b/editors/lazarus/files/patch-components-synedit_synedit.pp
deleted file mode 100644
index 92a6300235d4..000000000000
--- a/editors/lazarus/files/patch-components-synedit_synedit.pp
+++ /dev/null
@@ -1,20 +0,0 @@
---- components/synedit/synedit.pp 2018-01-30 13:41:54.904942000 -0500
-+++ components/synedit/synedit.pp 2018-01-30 13:40:23.811860000 -0500
-@@ -8945,7 +8945,7 @@
- while not Highlighter.GetEol do begin
- Start := Highlighter.GetTokenPos + 1;
- Token := Highlighter.GetToken;
-- if (PosX >= Start) and (PosX <= Start + Length(Token)) then begin
-+ if (PosX >= Start) and (PosX < Start + Length(Token)) then begin
- Attri := Highlighter.GetTokenAttribute;
- TokenType := Highlighter.GetTokenKind;
- exit(True);
-@@ -8990,7 +8990,7 @@
- //TokenType := Highlighter.GetTokenKind;
- Attri := Highlighter.GetTokenAttribute;
- //DebugLn([' TCustomSynEdit.CaretAtIdentOrString: Start=', Start, ', Token=', Token]);
-- if (PosX >= Start) and (PosX <= Start + Length(Token)) then
-+ if (PosX >= Start) and (PosX < Start + Length(Token)) then
- begin
- AtIdent := Attri = Highlighter.IdentifierAttribute;
- NearString := (Attri = Highlighter.StringAttribute)
diff --git a/editors/lazarus/files/pkg-message.in b/editors/lazarus/files/pkg-message.in
index 185aa361e4c4..c9404b376f8e 100644
--- a/editors/lazarus/files/pkg-message.in
+++ b/editors/lazarus/files/pkg-message.in
@@ -27,9 +27,8 @@ The Lazarus RAD was installed
editors/lazarus-lcl-nogui
editors/lazarus-lcl-gtk2
editors/lazarus-lcl-qt
- editors/lazarus-lcl-qt5
- You can added those ports if you want support for nogui, gtk2, qt or qt5
+ You can added those ports if you want support for nogui, gtk2 or qt
interfaces. Please look at net-p2p/transmission-remote-gui like a example of
how use it