aboutsummaryrefslogtreecommitdiff
path: root/editors/leafpad
diff options
context:
space:
mode:
authorSimon Barner <barner@FreeBSD.org>2005-06-01 00:31:15 +0000
committerSimon Barner <barner@FreeBSD.org>2005-06-01 00:31:15 +0000
commitb9b8d48bbd123f847d3f9401ec7afeda0457b9e8 (patch)
treeb6db9a24450b98a9603812a0e6e171265ca7854b /editors/leafpad
parent159dc195b9b2cdb06ddd9edec7aa1bd5f7386664 (diff)
downloadports-b9b8d48bbd123f847d3f9401ec7afeda0457b9e8.tar.gz
ports-b9b8d48bbd123f847d3f9401ec7afeda0457b9e8.zip
- Fix build on 4.x
Submitted by: Ports Fury PR: ports/81723 Approved by: Radek Kozlowski <radek@raadradd.com> (maintainer)
Notes
Notes: svn path=/head/; revision=136571
Diffstat (limited to 'editors/leafpad')
-rw-r--r--editors/leafpad/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/editors/leafpad/Makefile b/editors/leafpad/Makefile
index dc09c8494eeb..cee228b1253e 100644
--- a/editors/leafpad/Makefile
+++ b/editors/leafpad/Makefile
@@ -14,15 +14,19 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= radek@raadradd.com
COMMENT= GTK+ based simple text editor
-USE_GNOME= gtk20 gnomehier desktopfileutils
+USE_GNOME= gtk20 gnomehier desktopfileutils intlhack
+USE_GCC= 3.4
+USE_GETOPT_LONG= yes
USE_REINPLACE= yes
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}" \
- LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}" \
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
PTHREAD_LIB="${PTHREAD_LIBS}"
CONFIGURE_ARGS= --enable-chooser
+CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}
+
.if !defined(NOPORTDOCS)
PORTDOCS= AUTHORS COPYING ChangeLog INSTALL README
.endif