aboutsummaryrefslogtreecommitdiff
path: root/editors/libreoffice
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2021-02-06 02:13:47 +0000
committerDima Panov <fluffy@FreeBSD.org>2021-02-06 02:13:47 +0000
commitc714c25600b345ae9b65c7eca8d716a752cbb9d4 (patch)
treef0d53f1f2fa5771b844402dbf8ebb394ef7846c6 /editors/libreoffice
parent5f070c5ed5e13c0ea22b367742421452df8ceb44 (diff)
downloadports-c714c25600b345ae9b65c7eca8d716a752cbb9d4.tar.gz
ports-c714c25600b345ae9b65c7eca8d716a752cbb9d4.zip
editors/libreoffice: Fix build on aarch64
Submitted by: Michael Urankar via github MFH: 2021Q1
Notes
Notes: svn path=/head/; revision=564180
Diffstat (limited to 'editors/libreoffice')
-rw-r--r--editors/libreoffice/files/patch-external_skia_UnpackedTarball__skia.mk12
-rw-r--r--editors/libreoffice/files/patch-external_skia_gfx-skia-skia-src-core-SkCpu.cpp.patch.035
2 files changed, 47 insertions, 0 deletions
diff --git a/editors/libreoffice/files/patch-external_skia_UnpackedTarball__skia.mk b/editors/libreoffice/files/patch-external_skia_UnpackedTarball__skia.mk
new file mode 100644
index 000000000000..e81723fe63d2
--- /dev/null
+++ b/editors/libreoffice/files/patch-external_skia_UnpackedTarball__skia.mk
@@ -0,0 +1,12 @@
+--- external/skia/UnpackedTarball_skia.mk.orig 2021-02-05 14:00:19 UTC
++++ external/skia/UnpackedTarball_skia.mk
+@@ -36,7 +36,8 @@ skia_patches := \
+ c++20.patch.0 \
+ constexpr-debug-std-max.patch.1 \
+ swap-buffers-rect.patch.1 \
+- ubsan.patch.0
++ ubsan.patch.0 \
++ gfx-skia-skia-src-core-SkCpu.cpp.patch.0
+
+ $(eval $(call gb_UnpackedTarball_set_patchlevel,skia,1))
+
diff --git a/editors/libreoffice/files/patch-external_skia_gfx-skia-skia-src-core-SkCpu.cpp.patch.0 b/editors/libreoffice/files/patch-external_skia_gfx-skia-skia-src-core-SkCpu.cpp.patch.0
new file mode 100644
index 000000000000..b4e1e6df11e6
--- /dev/null
+++ b/editors/libreoffice/files/patch-external_skia_gfx-skia-skia-src-core-SkCpu.cpp.patch.0
@@ -0,0 +1,35 @@
+--- external/skia/gfx-skia-skia-src-core-SkCpu.cpp.patch.0.orig 2020-11-11 11:31:37 UTC
++++ external/skia/gfx-skia-skia-src-core-SkCpu.cpp.patch.0
+@@ -0,0 +1,32 @@
++Regressed by https://svnweb.freebsd.org/changeset/base/324815
++
++gfx/skia/skia/src/core/SkCpu.cpp:81:27: error: use of undeclared identifier 'getauxval'
++ uint32_t hwcaps = getauxval(AT_HWCAP);
++ ^
++
++--- src/core/SkCpu.cpp.orig 2020-02-07 22:13:22 UTC
+++++ src/core/SkCpu.cpp
++@@ -72,6 +72,23 @@
++ return features;
++ }
++
+++#elif defined(SK_CPU_ARM64) && defined(__FreeBSD__)
+++ #include <machine/armreg.h>
+++ #ifndef ID_AA64ISAR0_CRC32_VAL
+++ #define ID_AA64ISAR0_CRC32_VAL ID_AA64ISAR0_CRC32
+++ #endif
+++
+++ static uint32_t read_cpu_features() {
+++ uint32_t features = 0;
+++ uint64_t id_aa64isar0;
+++
+++ id_aa64isar0 = READ_SPECIALREG(id_aa64isar0_el1);
+++ if (ID_AA64ISAR0_CRC32_VAL(id_aa64isar0) == ID_AA64ISAR0_CRC32_BASE) {
+++ features |= SkCpu::CRC32;
+++ }
+++ return features;
+++ }
+++
++ #elif defined(SK_CPU_ARM64) && __has_include(<sys/auxv.h>)
++ #include <sys/auxv.h>
++