aboutsummaryrefslogtreecommitdiff
path: root/editors/linux-sublime-text4
diff options
context:
space:
mode:
authorEric Turgeon <ericbsd@FreeBSD.org>2021-10-18 23:43:04 +0000
committerEric Turgeon <ericbsd@FreeBSD.org>2021-10-18 23:43:04 +0000
commit27a7739b648462850151a59319fb7b53666912c5 (patch)
treef014d7f3f47ec7abfd920dbbb28d2d2d9c54a2bb /editors/linux-sublime-text4
parentf3b8c0953312c6dc0975a2733631537dd057e96a (diff)
editors/linux-sublime-text4: updated to 4118
renamed sublime-text4 to linux-sublime-text4
Diffstat (limited to 'editors/linux-sublime-text4')
-rw-r--r--editors/linux-sublime-text4/Makefile46
-rw-r--r--editors/linux-sublime-text4/distinfo3
-rw-r--r--editors/linux-sublime-text4/files/LICENSE.txt21
-rw-r--r--editors/linux-sublime-text4/files/patch-sublime_text.desktop24
-rw-r--r--editors/linux-sublime-text4/files/sublime-text.in2
-rw-r--r--editors/linux-sublime-text4/pkg-descr3
-rw-r--r--editors/linux-sublime-text4/pkg-plist86
7 files changed, 185 insertions, 0 deletions
diff --git a/editors/linux-sublime-text4/Makefile b/editors/linux-sublime-text4/Makefile
new file mode 100644
index 000000000000..85b474be80fc
--- /dev/null
+++ b/editors/linux-sublime-text4/Makefile
@@ -0,0 +1,46 @@
+PORTNAME= sublime-text4
+PORTVERSION= 4118
+PORTREVISION= 1
+CATEGORIES= editors linux
+MASTER_SITES= http://download.sublimetext.com/
+PKGNAMEPREFIX= linux-
+
+MAINTAINER= ericbsd@FreeBSD.org
+COMMENT= Sophisticated text editor for code, markup and prose
+
+LICENSE= SUBLIMEHQ
+LICENSE_NAME= End User License Agreement
+LICENSE_FILE= ${FILESDIR}/LICENSE.txt
+LICENSE_PERMS= dist-mirror no-dist-sell pkg-mirror no-pkg-sell auto-accept
+
+ONLY_FOR_ARCHS= aarch64 amd64
+ONLY_FOR_ARCHS_REASON= Upstream only supports amd64 and aarch64
+
+RUN_DEPENDS= linux-c7-curl>0:ftp/linux-c7-curl
+
+USES= desktop-file-utils gnome linux tar:xz
+USE_LINUX= gtk3
+
+CONFLICTS_INSTALL= linux-sublime[0-9]*
+
+NO_BUILD= yes
+SUB_FILES= sublime-text
+
+WRKSRC= ${WRKDIR}/sublime_text
+
+DISTNAME_amd64= sublime_text_build_${PORTVERSION}_x64
+DISTNAME_aarch64= sublime_text_build_${PORTVERSION}_arm64
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+.for res in 16 32 48 128 256
+ @${MKDIR} \
+ ${STAGEDIR}${PREFIX}/share/icons/hicolor/${res}x${res}/apps/
+ ${INSTALL_DATA} ${WRKSRC}/Icon/${res}x${res}/sublime-text.png \
+ ${STAGEDIR}${PREFIX}/share/icons/hicolor/${res}x${res}/apps/
+.endfor
+ ${INSTALL_DATA} ${WRKSRC}/sublime_text.desktop ${STAGEDIR}${PREFIX}/share/applications/
+ cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKDIR}/sublime-text ${STAGEDIR}${PREFIX}/bin/sublime_text
+
+.include <bsd.port.mk>
diff --git a/editors/linux-sublime-text4/distinfo b/editors/linux-sublime-text4/distinfo
new file mode 100644
index 000000000000..3f9f75fb3ed7
--- /dev/null
+++ b/editors/linux-sublime-text4/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1634600291
+SHA256 (sublime_text_build_4118_x64.tar.xz) = 1cc5a4db95eb1c27f75d1be539bbab45b459744c4250d640aedf839a05ccfea9
+SIZE (sublime_text_build_4118_x64.tar.xz) = 17182668
diff --git a/editors/linux-sublime-text4/files/LICENSE.txt b/editors/linux-sublime-text4/files/LICENSE.txt
new file mode 100644
index 000000000000..24bd2025212f
--- /dev/null
+++ b/editors/linux-sublime-text4/files/LICENSE.txt
@@ -0,0 +1,21 @@
+ The SOFTWARE PRODUCT (SUBLIME TEXT and SUBLIME MERGE) is protected by copyright laws and international copyright treaties, as well as other intellectual property laws and treaties. The SOFTWARE PRODUCT is licensed, not sold.
+
+ LICENSES
+ The SOFTWARE PRODUCT is licensed as follows:
+ Installation and Usage.
+ Licenses are per user and valid for use on all supported operating systems. License keys may be used on multiple computers and operating systems, provided the license key holder is the primary user. Businesses must purchase at least as many licenses as the number of people using the SOFTWARE PRODUCT.
+ Backup Copies.
+ You may make copies of the license key and or the SOFTWARE PRODUCT for backup and archival purposes.
+ DESCRIPTION OF OTHER RIGHTS AND LIMITATIONS
+ Maintenance of Copyright Notices.
+ You must not remove or alter any copyright notices on any copy of the SOFTWARE PRODUCT.
+ Distribution.
+ You may not distribute or sell license keys or the SOFTWARE PRODUCT to third parties. Licenses will be revoked if distributed or sold to third parties.
+ Rental.
+ You may not rent, lease, or lend the license key or the SOFTWARE PRODUCT.
+ COPYRIGHT
+ All title, including but not limited to copyrights, in and to the SOFTWARE PRODUCT and any copies thereof are owned by SUBLIME HQ PTY LTD.
+ NO WARRANTIES
+ SUBLIME HQ PTY LTD expressly disclaims any warranty for the SOFTWARE PRODUCT, which is provided 'as is' without any express or implied warranty of any kind, including but not limited to any warranties of merchantability, non-infringement, or fitness of a particular purpose.
+ LIMITATION OF LIABILITY
+ In no event shall SUBLIME HQ PTY LTD be liable for any damages due to use of the SOFTWARE PRODUCT, to the maximum extent permitted by law. This includes without limitation, lost profits, business interruption, or lost information. In no event will SUBLIME HQ PTY LTD be liable for loss of data or for indirect, special, incidental, consequential (including lost profit), or other damages. SUBLIME HQ PTY LTD shall have no liability with respect to the content of the SOFTWARE PRODUCT or any part thereof, including but not limited to errors or omissions contained therein, libel, trademark rights, business interruption, loss of privacy or the disclosure of confidential information.
diff --git a/editors/linux-sublime-text4/files/patch-sublime_text.desktop b/editors/linux-sublime-text4/files/patch-sublime_text.desktop
new file mode 100644
index 000000000000..9ed68f75a4c3
--- /dev/null
+++ b/editors/linux-sublime-text4/files/patch-sublime_text.desktop
@@ -0,0 +1,24 @@
+--- sublime_text.desktop.orig 2021-09-29 05:18:37 UTC
++++ sublime_text.desktop
+@@ -4,20 +4,9 @@ Type=Application
+ Name=Sublime Text
+ GenericName=Text Editor
+ Comment=Sophisticated text editor for code, markup and prose
+-Exec=/opt/sublime_text/sublime_text %F
++Exec=sublime_text %F
+ Terminal=false
+ MimeType=text/plain;
+ Icon=sublime-text
+ Categories=TextEditor;Development;
+ StartupNotify=true
+-Actions=new-window;new-file;
+-
+-[Desktop Action new-window]
+-Name=New Window
+-Exec=/opt/sublime_text/sublime_text --launch-or-new-window
+-OnlyShowIn=Unity;
+-
+-[Desktop Action new-file]
+-Name=New File
+-Exec=/opt/sublime_text/sublime_text --command new_file
+-OnlyShowIn=Unity;
diff --git a/editors/linux-sublime-text4/files/sublime-text.in b/editors/linux-sublime-text4/files/sublime-text.in
new file mode 100644
index 000000000000..f665b21deb76
--- /dev/null
+++ b/editors/linux-sublime-text4/files/sublime-text.in
@@ -0,0 +1,2 @@
+#! /bin/sh
+exec %%DATADIR%%/sublime_text "$@"
diff --git a/editors/linux-sublime-text4/pkg-descr b/editors/linux-sublime-text4/pkg-descr
new file mode 100644
index 000000000000..b4d307909ed4
--- /dev/null
+++ b/editors/linux-sublime-text4/pkg-descr
@@ -0,0 +1,3 @@
+Sublime Text is a sophisticated text editor for code, markup and prose.
+
+WWW: http://www.sublimetext.com
diff --git a/editors/linux-sublime-text4/pkg-plist b/editors/linux-sublime-text4/pkg-plist
new file mode 100644
index 000000000000..b8e3c5ab7f9b
--- /dev/null
+++ b/editors/linux-sublime-text4/pkg-plist
@@ -0,0 +1,86 @@
+bin/sublime_text
+share/applications/sublime_text.desktop
+share/icons/hicolor/128x128/apps/sublime-text.png
+share/icons/hicolor/16x16/apps/sublime-text.png
+share/icons/hicolor/256x256/apps/sublime-text.png
+share/icons/hicolor/32x32/apps/sublime-text.png
+share/icons/hicolor/48x48/apps/sublime-text.png
+%%DATADIR%%/Icon/128x128/sublime-text.png
+%%DATADIR%%/Icon/16x16/sublime-text.png
+%%DATADIR%%/Icon/256x256/sublime-text.png
+%%DATADIR%%/Icon/32x32/sublime-text.png
+%%DATADIR%%/Icon/48x48/sublime-text.png
+%%DATADIR%%/Lib/python3.3.zip
+%%DATADIR%%/Lib/python3.8.zip
+%%DATADIR%%/Lib/python3/certifi/LICENSE
+%%DATADIR%%/Lib/python3/certifi/__init__.py
+%%DATADIR%%/Lib/python3/certifi/__main__.py
+%%DATADIR%%/Lib/python3/certifi/__pycache__/__init__.cpython-38.opt-1.pyc
+%%DATADIR%%/Lib/python3/certifi/__pycache__/core.cpython-38.opt-1.pyc
+%%DATADIR%%/Lib/python3/certifi/cacert.pem
+%%DATADIR%%/Lib/python3/certifi/core.py
+%%DATADIR%%/Lib/python33/sublime.py
+%%DATADIR%%/Lib/python33/sublime_plugin.py
+%%DATADIR%%/Lib/python38/sublime.py
+%%DATADIR%%/Lib/python38/sublime_plugin.py
+%%DATADIR%%/Packages/ASP.sublime-package
+%%DATADIR%%/Packages/ActionScript.sublime-package
+%%DATADIR%%/Packages/AppleScript.sublime-package
+%%DATADIR%%/Packages/Batch File.sublime-package
+%%DATADIR%%/Packages/C#.sublime-package
+%%DATADIR%%/Packages/C++.sublime-package
+%%DATADIR%%/Packages/CSS.sublime-package
+%%DATADIR%%/Packages/Clojure.sublime-package
+%%DATADIR%%/Packages/Color Scheme - Default.sublime-package
+%%DATADIR%%/Packages/Color Scheme - Legacy.sublime-package
+%%DATADIR%%/Packages/D.sublime-package
+%%DATADIR%%/Packages/Default.sublime-package
+%%DATADIR%%/Packages/Diff.sublime-package
+%%DATADIR%%/Packages/Erlang.sublime-package
+%%DATADIR%%/Packages/Git Formats.sublime-package
+%%DATADIR%%/Packages/Go.sublime-package
+%%DATADIR%%/Packages/Graphviz.sublime-package
+%%DATADIR%%/Packages/Groovy.sublime-package
+%%DATADIR%%/Packages/HTML.sublime-package
+%%DATADIR%%/Packages/Haskell.sublime-package
+%%DATADIR%%/Packages/JSON.sublime-package
+%%DATADIR%%/Packages/Java.sublime-package
+%%DATADIR%%/Packages/JavaScript.sublime-package
+%%DATADIR%%/Packages/LaTeX.sublime-package
+%%DATADIR%%/Packages/Language - English.sublime-package
+%%DATADIR%%/Packages/Lisp.sublime-package
+%%DATADIR%%/Packages/Lua.sublime-package
+%%DATADIR%%/Packages/Makefile.sublime-package
+%%DATADIR%%/Packages/Markdown.sublime-package
+%%DATADIR%%/Packages/Matlab.sublime-package
+%%DATADIR%%/Packages/OCaml.sublime-package
+%%DATADIR%%/Packages/Objective-C.sublime-package
+%%DATADIR%%/Packages/PHP.sublime-package
+%%DATADIR%%/Packages/Pascal.sublime-package
+%%DATADIR%%/Packages/Perl.sublime-package
+%%DATADIR%%/Packages/Python.sublime-package
+%%DATADIR%%/Packages/R.sublime-package
+%%DATADIR%%/Packages/Rails.sublime-package
+%%DATADIR%%/Packages/Regular Expressions.sublime-package
+%%DATADIR%%/Packages/RestructuredText.sublime-package
+%%DATADIR%%/Packages/Ruby.sublime-package
+%%DATADIR%%/Packages/Rust.sublime-package
+%%DATADIR%%/Packages/SQL.sublime-package
+%%DATADIR%%/Packages/Scala.sublime-package
+%%DATADIR%%/Packages/ShellScript.sublime-package
+%%DATADIR%%/Packages/TCL.sublime-package
+%%DATADIR%%/Packages/Text.sublime-package
+%%DATADIR%%/Packages/Textile.sublime-package
+%%DATADIR%%/Packages/Theme - Default.sublime-package
+%%DATADIR%%/Packages/Vintage.sublime-package
+%%DATADIR%%/Packages/XML.sublime-package
+%%DATADIR%%/Packages/YAML.sublime-package
+%%DATADIR%%/changelog.txt
+@(,,555) %%DATADIR%%/crash_reporter
+%%DATADIR%%/libcrypto.so.1.1
+%%DATADIR%%/libssl.so.1.1
+@(,,555) %%DATADIR%%/plugin_host-3.3
+@(,,555) %%DATADIR%%/plugin_host-3.8
+@(,,555) %%DATADIR%%/sublime_text
+%%DATADIR%%/sublime_text.desktop
+%%DATADIR%%/sublime_text.desktop.orig