aboutsummaryrefslogtreecommitdiff
path: root/editors/lpe/Makefile
diff options
context:
space:
mode:
authorMichael Haro <mharo@FreeBSD.org>1999-04-14 05:56:14 +0000
committerMichael Haro <mharo@FreeBSD.org>1999-04-14 05:56:14 +0000
commit3fe0aff43917718b7cdedd4a1f40523f945dac62 (patch)
treef9c4235dc4c6b9ff3efa3c6c3b7af3ec0b889d3c /editors/lpe/Makefile
parentcbce94373c19e307429fb13ef203072f2b769643 (diff)
downloadports-3fe0aff43917718b7cdedd4a1f40523f945dac62.tar.gz
ports-3fe0aff43917718b7cdedd4a1f40523f945dac62.zip
Notes
Diffstat (limited to 'editors/lpe/Makefile')
-rw-r--r--editors/lpe/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/editors/lpe/Makefile b/editors/lpe/Makefile
new file mode 100644
index 000000000000..a6b4fa8246d9
--- /dev/null
+++ b/editors/lpe/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: lpe
+# Version required: 1.1.5
+# Date created: 12 April 1999
+# Whom: Chris Piazza <cpiazza@home.net>
+#
+# $Id$
+#
+
+DISTNAME= lpe-1.1.5
+CATEGORIES= editors
+MASTER_SITES= http://cdsmith.twu.net/lpe/
+
+MAINTAINER= cpiazza@home.net
+
+LIB_DEPENDS= slang.1:${PORTSDIR}/devel/libslang
+
+USE_GMAKE= yes
+
+MAN1= lpe.1
+
+post-patch:
+ @${SED} -e s#__PREFIX__#${PREFIX}#g ${WRKSRC}/options.h > ${WRKSRC}/options.h.new
+ @${MV} -f ${WRKSRC}/options.h.new ${WRKSRC}/options.h
+
+do-install:
+ ${MKDIR} ${PREFIX}/lib/lpe
+ ${INSTALL_PROGRAM} ${WRKSRC}/lpe ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/cmode.so ${PREFIX}/lib/lpe
+ ${INSTALL_DATA} ${WRKSRC}/cppmode.so ${PREFIX}/lib/lpe
+ ${INSTALL_DATA} ${WRKSRC}/htmlmode.so ${PREFIX}/lib/lpe
+ ${INSTALL_DATA} ${WRKSRC}/perlmode.so ${PREFIX}/lib/lpe
+ ${INSTALL_DATA} ${WRKSRC}/sgmlmode.so ${PREFIX}/lib/lpe
+ ${INSTALL_MAN} ${WRKSRC}/lpe.1 ${PREFIX}/man/man1
+
+.include <bsd.port.mk>