aboutsummaryrefslogtreecommitdiff
path: root/editors/mined
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2005-10-18 19:50:22 +0000
committerThierry Thomas <thierry@FreeBSD.org>2005-10-18 19:50:22 +0000
commit26ff5695b2e192da2fb7e8dfdc2b78dc7b70f83f (patch)
treeaae1a843243ee22034896b29f6e1b897bf311d8b /editors/mined
parent0fb395018eb3682d1d2de595f4a32924186bdd03 (diff)
downloadports-26ff5695b2e192da2fb7e8dfdc2b78dc7b70f83f.tar.gz
ports-26ff5695b2e192da2fb7e8dfdc2b78dc7b70f83f.zip
Respect $PREFIX.
Reported by: dosirak via Kris
Notes
Notes: svn path=/head/; revision=145796
Diffstat (limited to 'editors/mined')
-rw-r--r--editors/mined/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/editors/mined/Makefile b/editors/mined/Makefile
index ed0839a9c963..5b4a23abedcc 100644
--- a/editors/mined/Makefile
+++ b/editors/mined/Makefile
@@ -21,12 +21,22 @@ ALL_TARGET= mined manual
PORTDOCS= *
.endif
-USE_GMAKE= YES
+USE_GMAKE= yes
+USE_REINPLACE= yes
+REINPLACE_ARGS= -i ""
MAKE_ARGS= GMAKE=${GMAKE} CC=${CC:T} OPT="${CFLAGS}"
INSTALL_TARGET= localinstall
MAN1= mined.1
+PRFX2FIX= src/makefile.bsd src/makefile.gcc usrshare/xinitrc.mined \
+ usrshare/mined.desktop src/mined1.c
+
+pre-configure:
+.for FILE in ${PRFX2FIX}
+ @${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|' ${WRKSRC}/${FILE}
+.endfor
+
pre-build:
${MV} ${WRKSRC}/src/mkinclud.cc ${WRKSRC}/src/mkinclud.cc.bak
${CP} ${WRKSRC}/src/mkinclud.gcc ${WRKSRC}/src/mkinclud.cc