aboutsummaryrefslogtreecommitdiff
path: root/editors/mousepad
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2018-06-01 20:57:35 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2018-06-01 20:57:35 +0000
commit08a2916984f053d03d7640e62f7ddc08882eb57b (patch)
tree1bf497e62ea86350901716f7575fe7bf90cf1576 /editors/mousepad
parent7cf539b490b96da82151db6b4cb1ea788c79a3d1 (diff)
downloadports-08a2916984f053d03d7640e62f7ddc08882eb57b.tar.gz
ports-08a2916984f053d03d7640e62f7ddc08882eb57b.zip
Notes
Diffstat (limited to 'editors/mousepad')
-rw-r--r--editors/mousepad/Makefile6
-rw-r--r--editors/mousepad/distinfo5
-rw-r--r--editors/mousepad/files/patch-mousepad_mousepad-action-group.c48
-rw-r--r--editors/mousepad/files/patch-mousepad_mousepad-settings.c11
-rw-r--r--editors/mousepad/files/patch-mousepad_mousepad-util.c11
-rw-r--r--editors/mousepad/files/patch-mousepad_mousepad-view.c12
-rw-r--r--editors/mousepad/files/patch-mousepad_mousepad-window.c64
-rw-r--r--editors/mousepad/pkg-plist8
8 files changed, 13 insertions, 152 deletions
diff --git a/editors/mousepad/Makefile b/editors/mousepad/Makefile
index 770165c9caa1..86ea80dcea32 100644
--- a/editors/mousepad/Makefile
+++ b/editors/mousepad/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= mousepad
-PORTVERSION= 0.4.0
-PORTREVISION= 3
+PORTVERSION= 0.4.1
CATEGORIES= editors xfce
MASTER_SITES= XFCE/src/apps/${PORTNAME}/${PORTVERSION:R}
DIST_SUBDIR= xfce4
@@ -17,10 +16,11 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libdbus-glib-1.so:devel/dbus-glib
GNU_CONFIGURE= yes
-USES= desktop-file-utils gettext gmake libtool perl5 pkgconfig tar:bzip2
+USES= desktop-file-utils gettext gmake libtool perl5 pkgconfig tar:bzip2
USE_GNOME= glib20 intltool intlhack
OPTIONS_DEFINE= GTK3
+OPTIONS_DEFAULT= GTK3
GTK3_CONFIGURE_ENABLE= gtk3
GTK3_USE= gnome=gtk30,gtksourceview3,dconf
GTK3_USE_OFF= gnome=gtk20,gtksourceview2
diff --git a/editors/mousepad/distinfo b/editors/mousepad/distinfo
index 5e8fe9c4855f..fa20b380e238 100644
--- a/editors/mousepad/distinfo
+++ b/editors/mousepad/distinfo
@@ -1,2 +1,3 @@
-SHA256 (xfce4/mousepad-0.4.0.tar.bz2) = 60114431eac8db6bb6ce18bd38f1630cccb684375b97a445a1b6fd619848d132
-SIZE (xfce4/mousepad-0.4.0.tar.bz2) = 578483
+TIMESTAMP = 1527835896
+SHA256 (xfce4/mousepad-0.4.1.tar.bz2) = 39a7379b929d964665299c385b2cf705e32e8760698ccc34f91c990bb733518b
+SIZE (xfce4/mousepad-0.4.1.tar.bz2) = 644161
diff --git a/editors/mousepad/files/patch-mousepad_mousepad-action-group.c b/editors/mousepad/files/patch-mousepad_mousepad-action-group.c
deleted file mode 100644
index d5af132b96ac..000000000000
--- a/editors/mousepad/files/patch-mousepad_mousepad-action-group.c
+++ /dev/null
@@ -1,48 +0,0 @@
---- mousepad/mousepad-action-group.c.orig 2014-09-01 20:50:07 UTC
-+++ mousepad/mousepad-action-group.c
-@@ -124,7 +124,7 @@ mousepad_action_group_class_init (MousepadActionGroupC
- G_SIGNAL_RUN_LAST,
- 0, NULL, NULL,
- g_cclosure_marshal_VOID__OBJECT,
-- G_TYPE_NONE, 0,
-+ G_TYPE_NONE, 1,
- GTK_SOURCE_TYPE_LANGUAGE);
- }
-
-@@ -302,11 +302,6 @@ mousepad_action_group_set_active_style_scheme (Mousepa
- gtk_toggle_action_set_active (GTK_TOGGLE_ACTION (action), TRUE);
- self->locked = FALSE;
-
-- /* update the setting when the active action is changed */
-- self->locked = TRUE;
-- MOUSEPAD_SETTING_SET_STRING (COLOR_SCHEME, gtk_source_style_scheme_get_id (scheme));
-- self->locked = FALSE;
--
- g_object_notify (G_OBJECT (self), "active-style-scheme");
- }
-
-@@ -473,6 +468,8 @@ static void
- mousepad_action_group_style_scheme_action_activate (MousepadActionGroup *self,
- MousepadStyleSchemeAction *action)
- {
-+ const gchar *scheme_name = NULL;
-+
- /* only update the active action if we're not already in the process of
- * setting it and the sender action is actually active */
- if (! self->locked &&
-@@ -481,7 +478,14 @@ mousepad_action_group_style_scheme_action_activate (Mo
- GtkSourceStyleScheme *scheme;
-
- scheme = mousepad_style_scheme_action_get_style_scheme (action);
-- mousepad_action_group_set_active_style_scheme (self, scheme);
-+
-+ /* update the setting when the active action is changed */
-+ if (scheme != NULL)
-+ scheme_name = gtk_source_style_scheme_get_id(scheme);
-+
-+ self->locked = TRUE;
-+ MOUSEPAD_SETTING_SET_STRING (COLOR_SCHEME, scheme_name);
-+ self->locked = FALSE;
- }
- }
-
diff --git a/editors/mousepad/files/patch-mousepad_mousepad-settings.c b/editors/mousepad/files/patch-mousepad_mousepad-settings.c
deleted file mode 100644
index bbd300c6b4c0..000000000000
--- a/editors/mousepad/files/patch-mousepad_mousepad-settings.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- mousepad/mousepad-settings.c.orig 2014-09-01 20:50:07 UTC
-+++ mousepad/mousepad-settings.c
-@@ -298,7 +298,7 @@ void
- mousepad_setting_set_string (const gchar *path,
- const gchar *value)
- {
-- mousepad_setting_set (path, "s", value);
-+ mousepad_setting_set (path, "s", value != NULL ? value : "");
- }
-
-
diff --git a/editors/mousepad/files/patch-mousepad_mousepad-util.c b/editors/mousepad/files/patch-mousepad_mousepad-util.c
deleted file mode 100644
index 6197ad04bc92..000000000000
--- a/editors/mousepad/files/patch-mousepad_mousepad-util.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- mousepad/mousepad-util.c.orig 2014-09-01 20:50:07 UTC
-+++ mousepad/mousepad-util.c
-@@ -1063,7 +1063,7 @@ mousepad_util_search (GtkTextBuffer *buffer,
- GtkAction *
- mousepad_util_find_related_action (GtkWidget *widget)
- {
-- GtkAction *action;
-+ GtkAction *action = NULL;
-
- g_return_val_if_fail (GTK_IS_WIDGET (widget), NULL);
-
diff --git a/editors/mousepad/files/patch-mousepad_mousepad-view.c b/editors/mousepad/files/patch-mousepad_mousepad-view.c
deleted file mode 100644
index f11878902ee5..000000000000
--- a/editors/mousepad/files/patch-mousepad_mousepad-view.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- mousepad/mousepad-view.c.orig 2014-09-01 20:50:07 UTC
-+++ mousepad/mousepad-view.c
-@@ -257,7 +257,8 @@ mousepad_view_buffer_changed (MousepadVi
- GtkSourceStyleScheme *scheme;
-
- manager = gtk_source_style_scheme_manager_get_default ();
-- scheme = gtk_source_style_scheme_manager_get_scheme (manager, view->color_scheme);
-+ scheme = gtk_source_style_scheme_manager_get_scheme (manager,
-+ view->color_scheme ? view->color_scheme : "");
- gtk_source_buffer_set_style_scheme (buffer, scheme);
-
- gtk_source_buffer_set_highlight_matching_brackets (buffer, view->match_braces);
diff --git a/editors/mousepad/files/patch-mousepad_mousepad-window.c b/editors/mousepad/files/patch-mousepad_mousepad-window.c
deleted file mode 100644
index c59d47d47963..000000000000
--- a/editors/mousepad/files/patch-mousepad_mousepad-window.c
+++ /dev/null
@@ -1,64 +0,0 @@
---- mousepad/mousepad-window.c.orig 2014-09-01 20:58:02 UTC
-+++ mousepad/mousepad-window.c
-@@ -712,32 +712,6 @@ mousepad_window_create_languages_menu (MousepadWindow
-
-
- static void
--mousepad_window_action_group_style_scheme_changed (MousepadWindow *window,
-- GParamSpec *pspec,
-- MousepadActionGroup *group)
--{
-- GtkSourceStyleScheme *scheme;
-- const gchar *scheme_id;
-- gint npages, i;
--
-- /* get the new active language */
-- scheme = mousepad_action_group_get_active_style_scheme (group);
-- scheme_id = gtk_source_style_scheme_get_id (scheme);
--
-- /* update the color scheme on all the documents */
-- npages = gtk_notebook_get_n_pages (GTK_NOTEBOOK (window->notebook));
-- for (i = 0; i < npages; i++)
-- {
-- MousepadDocument *document;
--
-- document = MOUSEPAD_DOCUMENT (gtk_notebook_get_nth_page (GTK_NOTEBOOK (window->notebook), i));
-- mousepad_view_set_color_scheme (document->textview, scheme_id);
-- }
--}
--
--
--
--static void
- mousepad_window_create_style_schemes_menu (MousepadWindow *window)
- {
- GtkWidget *menu, *item;
-@@ -751,13 +725,6 @@ mousepad_window_create_style_schemes_menu (MousepadWin
- gtk_menu_item_set_submenu (GTK_MENU_ITEM (item), menu);
- gtk_widget_show_all (menu);
- gtk_widget_show (item);
--
-- /* watch for activations of the style schemes actions */
-- g_signal_connect_object (window->action_group,
-- "notify::active-style-scheme",
-- G_CALLBACK (mousepad_window_action_group_style_scheme_changed),
-- window,
-- G_CONNECT_SWAPPED);
- }
-
-
-@@ -2122,7 +2089,14 @@ mousepad_window_notebook_create_window (GtkNotebook
- g_object_ref (G_OBJECT (document));
-
- /* remove the document from the active window */
-+#if GTK_CHECK_VERSION (3, 16, 0)
-+ gtk_notebook_detach_tab (GTK_CONTAINER (window->notebook), page);
-+#else
-+ /* crashes on GTK+ 3 somewhere between 3.10-3.16
-+ * Fixed above using new function added in 3.16
-+ * See: https://bugzilla.gnome.org/show_bug.cgi?id=744385 */
- gtk_container_remove (GTK_CONTAINER (window->notebook), page);
-+#endif
-
- /* emit the new window with document signal */
- g_signal_emit (G_OBJECT (window), window_signals[NEW_WINDOW_WITH_DOCUMENT], 0, document, x, y);
diff --git a/editors/mousepad/pkg-plist b/editors/mousepad/pkg-plist
index c884380000e0..1012a7ae94c5 100644
--- a/editors/mousepad/pkg-plist
+++ b/editors/mousepad/pkg-plist
@@ -3,6 +3,7 @@ share/applications/mousepad.desktop
share/locale/ar/LC_MESSAGES/mousepad.mo
share/locale/ast/LC_MESSAGES/mousepad.mo
share/locale/bg/LC_MESSAGES/mousepad.mo
+share/locale/ca/LC_MESSAGES/mousepad.mo
share/locale/cs/LC_MESSAGES/mousepad.mo
share/locale/da/LC_MESSAGES/mousepad.mo
share/locale/de/LC_MESSAGES/mousepad.mo
@@ -13,8 +14,10 @@ share/locale/es/LC_MESSAGES/mousepad.mo
share/locale/eu/LC_MESSAGES/mousepad.mo
share/locale/fi/LC_MESSAGES/mousepad.mo
share/locale/fr/LC_MESSAGES/mousepad.mo
-share/locale/hu/LC_MESSAGES/mousepad.mo
+share/locale/gl/LC_MESSAGES/mousepad.mo
+share/locale/he/LC_MESSAGES/mousepad.mo
share/locale/hr/LC_MESSAGES/mousepad.mo
+share/locale/hu/LC_MESSAGES/mousepad.mo
share/locale/id/LC_MESSAGES/mousepad.mo
share/locale/is/LC_MESSAGES/mousepad.mo
share/locale/it/LC_MESSAGES/mousepad.mo
@@ -25,6 +28,7 @@ share/locale/lt/LC_MESSAGES/mousepad.mo
share/locale/ms/LC_MESSAGES/mousepad.mo
share/locale/nb/LC_MESSAGES/mousepad.mo
share/locale/nl/LC_MESSAGES/mousepad.mo
+share/locale/nn/LC_MESSAGES/mousepad.mo
share/locale/oc/LC_MESSAGES/mousepad.mo
share/locale/pl/LC_MESSAGES/mousepad.mo
share/locale/pt/LC_MESSAGES/mousepad.mo
@@ -32,6 +36,8 @@ share/locale/pt_BR/LC_MESSAGES/mousepad.mo
share/locale/ro/LC_MESSAGES/mousepad.mo
share/locale/ru/LC_MESSAGES/mousepad.mo
share/locale/sk/LC_MESSAGES/mousepad.mo
+share/locale/sl/LC_MESSAGES/mousepad.mo
+share/locale/sq/LC_MESSAGES/mousepad.mo
share/locale/sr/LC_MESSAGES/mousepad.mo
share/locale/sv/LC_MESSAGES/mousepad.mo
share/locale/te/LC_MESSAGES/mousepad.mo