aboutsummaryrefslogtreecommitdiff
path: root/editors/mousepad
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2012-07-17 21:04:27 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2012-07-17 21:04:27 +0000
commitb122d597380a87076a8cf9abe566124b6b99e81e (patch)
treeca3df6b82c96353f721eccd0787891d17e964003 /editors/mousepad
parent61c2d4565b13f3c50e571487fe66a9aacb203701 (diff)
downloadports-b122d597380a87076a8cf9abe566124b6b99e81e.tar.gz
ports-b122d597380a87076a8cf9abe566124b6b99e81e.zip
Notes
Diffstat (limited to 'editors/mousepad')
-rw-r--r--editors/mousepad/Makefile2
-rw-r--r--editors/mousepad/files/patch-src_search.c28
2 files changed, 29 insertions, 1 deletions
diff --git a/editors/mousepad/Makefile b/editors/mousepad/Makefile
index c0aad455e4e8..4b95693db3f8 100644
--- a/editors/mousepad/Makefile
+++ b/editors/mousepad/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mousepad
PORTVERSION= 0.2.16
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= editors xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
MASTER_SITE_SUBDIR=src/apps/${PORTNAME}/${PORTVERSION:R}
diff --git a/editors/mousepad/files/patch-src_search.c b/editors/mousepad/files/patch-src_search.c
new file mode 100644
index 000000000000..65eed605a0c7
--- /dev/null
+++ b/editors/mousepad/files/patch-src_search.c
@@ -0,0 +1,28 @@
+--- src/search.c.orig
++++ src/search.c
+@@ -210,8 +210,11 @@
+ G_CALLBACK(toggle_sensitivity), NULL);
+ g_signal_connect(G_OBJECT(entry_find), "delete-text",
+ G_CALLBACK(toggle_sensitivity), NULL);
+- if (sd->search.string_find)
++ if (sd->search.string_find) {
+ gtk_entry_set_text(GTK_ENTRY(entry_find), sd->search.string_find);
++ gtk_dialog_set_response_sensitive(GTK_DIALOG(dialog),
++ GTK_RESPONSE_OK, TRUE);
++ }
+
+ gtk_dialog_set_default_response(GTK_DIALOG(dialog), GTK_RESPONSE_OK);
+ gtk_entry_set_activates_default(GTK_ENTRY(entry_find), TRUE);
+@@ -275,8 +278,11 @@
+ G_CALLBACK(toggle_sensitivity), NULL);
+ g_signal_connect(G_OBJECT(entry_find), "delete-text",
+ G_CALLBACK(toggle_sensitivity), NULL);
+- if (sd->search.string_find)
++ if (sd->search.string_find) {
+ gtk_entry_set_text(GTK_ENTRY(entry_find), sd->search.string_find);
++ gtk_dialog_set_response_sensitive(GTK_DIALOG(dialog),
++ GTK_RESPONSE_OK, TRUE);
++ }
+ label_replace = gtk_label_new_with_mnemonic(_("Re_place with: "));
+ gtk_misc_set_alignment(GTK_MISC(label_replace), 0, 0.5);
+ gtk_table_attach_defaults(GTK_TABLE(table), label_replace, 0, 1, 1, 2); \ No newline at end of file