aboutsummaryrefslogtreecommitdiff
path: root/editors/mp
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2015-10-16 16:51:12 +0000
committerJohn Marino <marino@FreeBSD.org>2015-10-16 16:51:12 +0000
commit107c3fd1ced732bab33d295161e12ae7db03df3f (patch)
tree24408bf0cb2b7790450a2316252968ae3d647cc6 /editors/mp
parentef8c547149ed649cf81fd4547507cce86cfd5e51 (diff)
downloadports-107c3fd1ced732bab33d295161e12ae7db03df3f.tar.gz
ports-107c3fd1ced732bab33d295161e12ae7db03df3f.zip
editors/mp: Upgrade version 5.2.9 => 5.2.10
PR: 201840 Submitted by: ports fury
Notes
Notes: svn path=/head/; revision=399491
Diffstat (limited to 'editors/mp')
-rw-r--r--editors/mp/Makefile45
-rw-r--r--editors/mp/distinfo4
-rw-r--r--editors/mp/files/patch-mpdn__config.sh8
-rw-r--r--editors/mp/pkg-plist3
4 files changed, 35 insertions, 25 deletions
diff --git a/editors/mp/Makefile b/editors/mp/Makefile
index a94e28b1ec92..4fc3bfde267e 100644
--- a/editors/mp/Makefile
+++ b/editors/mp/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= mp
-PORTVERSION= 5.2.9
+PORTVERSION= 5.2.10
CATEGORIES= editors
MASTER_SITES= http://triptico.com/download/mp/
@@ -10,6 +10,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Programming text editor
LICENSE= GPLv2 # (or later)
+LICENSE_FILE= ${WRKSRC}/COPYING
USES= iconv ncurses
HAS_CONFIGURE= yes
@@ -18,40 +19,48 @@ CONFIGURE_ARGS= --prefix=${PREFIX} --without-win32 --without-kde4
DATADIR= ${PREFIX}/share/mp-5
-OPTIONS_DEFINE= NLS PCRE DOCS
-OPTIONS_RADIO= GUI
-OPTIONS_RADIO_GUI= GTK3 GTK2 QT4
+OPTIONS_DEFINE= DOCS NLS PCRE
+OPTIONS_RADIO= GUI
+OPTIONS_RADIO_GUI= GTK2 GTK3 QT4
OPTIONS_DEFAULT= PCRE
-OPTIONS_SUB= yes
+OPTIONS_SUB= yes
-NLS_USES= gettext
+NLS_USES= gettext
NLS_CONFIGURE_WITH= gettext
-
+GTK2_USE= gnome=gtk20
+GTK3_USE= gnome=gtk30
PCRE_LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre
PCRE_CONFIGURE_WITH= pcre
-
-QT4_USE= QT4=corelib,gui,moc_build
+QT4_USE= qt4=corelib,gui,moc_build
QT4_CONFIGURE_ENV= CPP="${CXX}" CCLINK="${CXX}"
QT4_CONFIGURE_WITH= qt4
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MGTK3}
-USE_GNOME+= gtk30
-CONFOPT_GTK= 3
+.if ${PORT_OPTIONS:MGTK2} || ${PORT_OPTIONS:MGTK3} || ${PORT_OPTIONS:MQT4}
+USES+= pkgconfig
+PLIST_SUB+= GUI=""
+.else
+PLIST_SUB+= GUI="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MGTK2} || ${PORT_OPTIONS:MGTK3}
+DESKTOP_ENTRIES="Minimum Profit" "" "mp-5" "mp" "Develpment;TextEditor;GTK;" ""
+.else
+CONFIGURE_ARGS+= --without-gtk
+CONFOPT_GTK= 0
.endif
.if ${PORT_OPTIONS:MGTK2}
-USE_GNOME+= gtk20
CONFOPT_GTK= 2
.endif
-.if empty(PORT_OPTIONS:MGTK3) && empty(PORT_OPTIONS:MGTK2)
-CONFIGURE_ARGS+= --without-gtk
-CONFOPT_GTK= 0
+.if ${PORT_OPTIONS:MGTK3}
+CONFOPT_GTK= 3
.endif
.if ${PORT_OPTIONS:MQT4}
+DESKTOP_ENTRIES="Minimum Profit" "" "mp-5" "mp" "Development;TextEditor;Qt;" ""
QT_NONSTANDARD= yes
.endif
@@ -60,7 +69,6 @@ post-patch:
's|<ncursesw/|<| ; \
s|-I/usr/local/include|| ; \
s|-L/usr/local/lib|| ; \
- s|-lX11|| ; \
/gtk+/s|3.0|${CONFOPT_GTK}.0| ; \
/OK/s|3.0|${CONFOPT_GTK}.0| ; \
/CONFOPT_GTK/s|3|${CONFOPT_GTK}|' ${WRKSRC}/config.sh
@@ -83,6 +91,9 @@ do-install:
(cd ${WRKSRC} && ${INSTALL_DATA} mp_*.mpsl ${STAGEDIR}${DATADIR})
@${MKDIR} ${STAGEDIR}${DATADIR}/lang
(cd ${WRKSRC}/lang && ${INSTALL_DATA} *.mpsl ${STAGEDIR}${DATADIR}/lang)
+.if ${PORT_OPTIONS:MGTK2} || ${PORT_OPTIONS:MGTK3} || ${PORT_OPTIONS:MQT4}
+ (cd ${WRKSRC} && ${INSTALL_DATA} mp.png ${STAGEDIR}${PREFIX}/share/pixmaps)
+.endif
.if ${PORT_OPTIONS:MNLS}
.for lang in de es it nl ru sv
@${MKDIR} ${STAGEDIR}${PREFIX}/share/locale/${lang}/LC_MESSAGES
diff --git a/editors/mp/distinfo b/editors/mp/distinfo
index 0d688d6fcea6..16a432ed40a8 100644
--- a/editors/mp/distinfo
+++ b/editors/mp/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mp-5.2.9.tar.gz) = a30403f4b0c07905733168e914d488f48fb449bb95f67a5254d9ca9ecb6b795d
-SIZE (mp-5.2.9.tar.gz) = 557502
+SHA256 (mp-5.2.10.tar.gz) = f3ce1831d2cfb42a8540d197a9fdad163ecd17883a57cd798a2f30bfe791ddc1
+SIZE (mp-5.2.10.tar.gz) = 504306
diff --git a/editors/mp/files/patch-mpdn__config.sh b/editors/mp/files/patch-mpdn__config.sh
index 792476c57f87..e833ba312d2d 100644
--- a/editors/mp/files/patch-mpdn__config.sh
+++ b/editors/mp/files/patch-mpdn__config.sh
@@ -1,6 +1,6 @@
---- mpdm/config.sh.orig 2009-11-05 17:18:27.000000000 +0900
-+++ mpdm/config.sh 2011-03-19 08:40:21.000000000 +0900
-@@ -309,13 +309,15 @@
+--- mpdm/config.sh.orig 2015-05-05 07:29:54 UTC
++++ mpdm/config.sh
+@@ -370,13 +370,15 @@ else
echo "#define CONFOPT_GETTEXT 1" >> config.h
else
# try now with -lintl
@@ -18,7 +18,7 @@
echo "$TMP_LDFLAGS" >> config.ldflags
else
echo "No"
-@@ -342,13 +344,15 @@
+@@ -403,13 +405,15 @@ else
echo "#define CONFOPT_ICONV 1" >> config.h
else
# try now with -liconv
diff --git a/editors/mp/pkg-plist b/editors/mp/pkg-plist
index f7cd96789891..02e717a4836b 100644
--- a/editors/mp/pkg-plist
+++ b/editors/mp/pkg-plist
@@ -6,8 +6,6 @@ man/man1/mp-5.1.gz
%%PORTDOCS%%%%DOCSDIR%%/RELEASE_NOTES
%%PORTDOCS%%%%DOCSDIR%%/mp_actions.html
%%PORTDOCS%%%%DOCSDIR%%/mp_actions.txt
-%%PORTDOCS%%%%DOCSDIR%%/mp_api.html
-%%PORTDOCS%%%%DOCSDIR%%/mp_api.txt
%%PORTDOCS%%%%DOCSDIR%%/mp_configuration.html
%%PORTDOCS%%%%DOCSDIR%%/mp_configuration.txt
%%PORTDOCS%%%%DOCSDIR%%/mp_cookbook.html
@@ -62,3 +60,4 @@ man/man1/mp-5.1.gz
%%DATADIR%%/mp_tui.mpsl
%%DATADIR%%/mp_vcs.mpsl
%%DATADIR%%/mp_writing.mpsl
+%%GUI%%share/pixmaps/mp.png