aboutsummaryrefslogtreecommitdiff
path: root/editors/mp
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
commitb1a1d38bf9ef78334b640d30046388a9c055c3a9 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /editors/mp
parentbc77780d41178cf3d0327c79ac10737af704f236 (diff)
downloadports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.tar.gz
ports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.zip
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk
From now on, ports that depend on Qt4 will have to set USES= qt:4 USE_QT= foo bar ports depending on Qt5 will use USES= qt:5 USE_QT= foo bar PR: 229225 Exp-run by: antoine Reviewed by: mat Approved by: portmgr (antoine) Differential Revision: →https://reviews.freebsd.org/D15540
Notes
Notes: svn path=/head/; revision=473503
Diffstat (limited to 'editors/mp')
-rw-r--r--editors/mp/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/editors/mp/Makefile b/editors/mp/Makefile
index 4d1c395f6794..80d66a5e45d0 100644
--- a/editors/mp/Makefile
+++ b/editors/mp/Makefile
@@ -52,14 +52,15 @@ NCURSES_USES= ncurses
NCURSES_CONFIGURE_WITH= curses
NCURSES_CFLAGS= -I${NCURSESBASE}/include
-QT4_USE= qt4=corelib,gui,moc_build \
+QT4_USES= qmake:no_env qt:4
+QT4_USE= qt=corelib,gui,moc_build \
xorg=x11
QT4_CONFIGURE_WITH= qt4
-QT5_USES= compiler:c++11-lang
+QT5_USES= compiler:c++11-lang qmake:no_env qt:5
QT5_USE= cxxstd=-std=c++11 \
gl=gl \
- qt5=buildtools_build,core,gui,widgets
+ qt=buildtools_build,core,gui,widgets
QT5_CONFIGURE_WITH= qt5
.include <bsd.port.options.mk>
@@ -81,7 +82,6 @@ CONFIGURE_ARGS+= --without-gtk
DESKTOP_ENTRIES="Minimum Profit" "" "mp" "mp-5" "Utility;TextEditor;Qt;" ""
CONFIGURE_ARGS+=--with-moc=${MOC}
CONFIGURE_ENV+= CCLINK="${CXX}"
-QT_NONSTANDARD= yes
.endif
post-patch: