aboutsummaryrefslogtreecommitdiff
path: root/editors/nano/Makefile
diff options
context:
space:
mode:
authorMichael Haro <mharo@FreeBSD.org>2001-04-02 10:02:41 +0000
committerMichael Haro <mharo@FreeBSD.org>2001-04-02 10:02:41 +0000
commitb1fbcd066e4dd59ad267a5e7ecde55266260828f (patch)
tree64b3d985ffc254123f7294a77fdb693a556d8e12 /editors/nano/Makefile
parente5c35d051fb77b42225b4550479e47220d4a4004 (diff)
downloadports-b1fbcd066e4dd59ad267a5e7ecde55266260828f.tar.gz
ports-b1fbcd066e4dd59ad267a5e7ecde55266260828f.zip
Notes
Diffstat (limited to 'editors/nano/Makefile')
-rw-r--r--editors/nano/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/editors/nano/Makefile b/editors/nano/Makefile
index 36e435da5e81..a635203fb211 100644
--- a/editors/nano/Makefile
+++ b/editors/nano/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= nano
-PORTVERSION= 0.9.24
+PORTVERSION= 1.0.0
CATEGORIES= editors
MASTER_SITES= http://www.nano-editor.org/dist/ \
http://www.asty.org/nano/dist/ \
@@ -21,6 +21,12 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -lintl"
+.if defined(LITE)
+CONFIGURE_ARGS+= --disable-tabcomp --enable-tiny --disable-speller \
+ --disable-justify --disable-nls --disable-browser --disable-help
+PLIST= ${PKGDIR}/pkg-plist.nonls
+.endif
+
MAN1= nano.1
.include <bsd.port.mk>