aboutsummaryrefslogtreecommitdiff
path: root/editors/neovim
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2022-10-14 17:30:10 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2022-10-14 17:30:15 +0000
commit8e76912d7e6892e7c8cbf0dcd6f1f57f65fd59f7 (patch)
tree60255ed0881471a77a05992e676628dc74c50419 /editors/neovim
parent82af9c9c62bd58237656015afd5430b636a9d984 (diff)
downloadports-8e76912d7e6892e7c8cbf0dcd6f1f57f65fd59f7.tar.gz
ports-8e76912d7e6892e7c8cbf0dcd6f1f57f65fd59f7.zip
devel/luv, editors/neovim: Use USES=luajit (changes luajit to luajit-devel)
Diffstat (limited to 'editors/neovim')
-rw-r--r--editors/neovim/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/editors/neovim/Makefile b/editors/neovim/Makefile
index df7246dfe3bc..e7ae2e81ef67 100644
--- a/editors/neovim/Makefile
+++ b/editors/neovim/Makefile
@@ -1,6 +1,7 @@
PORTNAME= neovim
DISTVERSIONPREFIX= v
DISTVERSION= 0.8.0
+PORTREVISION= 1
CATEGORIES= editors
MAINTAINER= adamw@FreeBSD.org
@@ -12,8 +13,7 @@ LICENSE= APACHE20
BUILD_DEPENDS= gperf:devel/gperf \
${LUA_MODLIBDIR}/bit.so:devel/lua-bitop@${LUA_FLAVOR} \
${LUA_MODLIBDIR}/lpeg.so:devel/lua-lpeg@${LUA_FLAVOR}
-LIB_DEPENDS= libluajit-5.1.so:lang/luajit-openresty \
- libluv.so:devel/luv \
+LIB_DEPENDS= libluv.so:devel/luv \
libmsgpackc.so:devel/msgpack \
libtermkey.so:devel/libtermkey \
libtree-sitter.so:devel/tree-sitter \
@@ -21,7 +21,7 @@ LIB_DEPENDS= libluajit-5.1.so:lang/luajit-openresty \
libuv.so:devel/libuv \
libvterm.so:devel/libvterm
-USES= cmake cpe iconv lua:52,build pathfix pkgconfig
+USES= cmake cpe iconv lua:52,build luajit pathfix pkgconfig
USE_GITHUB= yes
GH_TUPLE= libmpack:libmpack:1.0.5:libmpack \
libmpack:libmpack-lua:1.0.9:libmpack_lua