aboutsummaryrefslogtreecommitdiff
path: root/editors/neovim
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2018-05-27 14:41:44 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2018-05-27 14:41:44 +0000
commitcb6bd0990663c710a474f307c6d8825e2f76d679 (patch)
tree2082627ba2f0e2b20800595cd577096ef39ce586 /editors/neovim
parent890f555f3d2d5c0634717dc08e50513a57bf7d9d (diff)
downloadports-cb6bd0990663c710a474f307c6d8825e2f76d679.tar.gz
ports-cb6bd0990663c710a474f307c6d8825e2f76d679.zip
Notes
Diffstat (limited to 'editors/neovim')
-rw-r--r--editors/neovim/Makefile28
-rw-r--r--editors/neovim/distinfo6
-rw-r--r--editors/neovim/pkg-descr11
3 files changed, 26 insertions, 19 deletions
diff --git a/editors/neovim/Makefile b/editors/neovim/Makefile
index 98723203032b..0370c7af313a 100644
--- a/editors/neovim/Makefile
+++ b/editors/neovim/Makefile
@@ -4,28 +4,28 @@
PORTNAME= neovim
DISTVERSIONPREFIX= v
DISTVERSION= 0.2.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= editors
-MAINTAINER= gor@clogic.com.ua
-COMMENT= Next generation Vim
+MAINTAINER= adamw@FreeBSD.org
+COMMENT= Next-generation Vim
LICENSE= APACHE20
-BUILD_DEPENDS= ${LUA_MODLIBDIR}/bit.so:devel/lua-bitop \
- ${LUA_MODLIBDIR}/lpeg.so:devel/lua-lpeg \
- gperf:devel/gperf
-LIB_DEPENDS= libunibilium.so:devel/unibilium \
- libvterm.so:devel/libvterm \
+BUILD_DEPENDS= gperf:devel/gperf \
+ ${LUA_MODLIBDIR}/bit.so:devel/lua-bitop \
+ ${LUA_MODLIBDIR}/lpeg.so:devel/lua-lpeg
+LIB_DEPENDS= libluajit-5.1.so:lang/luajit \
+ libmsgpackc.so:devel/msgpack \
libtermkey.so:devel/libtermkey \
- libluajit-5.1.so:lang/luajit \
+ libunibilium.so:devel/unibilium \
libuv.so:devel/libuv \
- libmsgpackc.so:devel/msgpack
+ libvterm.so:devel/libvterm
USES= cmake:outsource iconv lua:build pathfix pkgconfig
USE_GITHUB= yes
GH_TUPLE= libmpack:libmpack:1.0.5:libmpack \
- libmpack:libmpack-lua:1.0.6:libmpack_lua
+ libmpack:libmpack-lua:1.0.7:libmpack_lua
CMAKE_ARGS= -DLUA_PRG:FILEPATH="${LUA_CMD}" \
-DCMAKE_INSTALL_MANDIR:PATH="${MANPREFIX}/man" \
@@ -46,12 +46,12 @@ post-patch-NLS-off:
@${REINPLACE_CMD} -e '/find_package(LibIntl)/ d' ${WRKSRC}/CMakeLists.txt
pre-build:
- @${LN} -s ${WRKSRC_libmpack} ${WRKSRC_libmpack_lua}/mpack-src
+ ${LN} -s ${WRKSRC_libmpack} ${WRKSRC_libmpack_lua}/mpack-src
@${MKDIR} ${BUILD_WRKSRC}/src/nvim
- @(cd ${WRKSRC_libmpack_lua} && ${CC} ${CFLAGS} -fPIC \
+ (cd ${WRKSRC_libmpack_lua} && ${CC} ${CFLAGS} -fPIC \
-I${LUA_INCDIR} -shared lmpack.c -o \
${BUILD_WRKSRC}/src/nvim/mpack.so \
${LUA_LIBDIR}/liblua-${LUA_VER}.so)
- @${LN} -s ${BUILD_WRKSRC}/src/nvim/mpack.so ${BUILD_WRKSRC}/runtime/mpack.so
+ ${LN} -s ${BUILD_WRKSRC}/src/nvim/mpack.so ${BUILD_WRKSRC}/runtime/mpack.so
.include <bsd.port.mk>
diff --git a/editors/neovim/distinfo b/editors/neovim/distinfo
index c24b7ec4dde1..443c1c380cce 100644
--- a/editors/neovim/distinfo
+++ b/editors/neovim/distinfo
@@ -1,7 +1,7 @@
-TIMESTAMP = 1511096400
+TIMESTAMP = 1527353327
SHA256 (neovim-neovim-v0.2.2_GH0.tar.gz) = a838ee07cc9a2ef8ade1b31a2a4f2d5e9339e244ade68e64556c1f4b40ccc5ed
SIZE (neovim-neovim-v0.2.2_GH0.tar.gz) = 8325879
SHA256 (libmpack-libmpack-1.0.5_GH0.tar.gz) = 4ce91395d81ccea97d3ad4cb962f8540d166e59d3e2ddce8a22979b49f108956
SIZE (libmpack-libmpack-1.0.5_GH0.tar.gz) = 32966
-SHA256 (libmpack-libmpack-lua-1.0.6_GH0.tar.gz) = 66811e30b316b53d1e3c4225248d4813b8b852c3e19121ba5ad47a9d4537d1ae
-SIZE (libmpack-libmpack-lua-1.0.6_GH0.tar.gz) = 14557
+SHA256 (libmpack-libmpack-lua-1.0.7_GH0.tar.gz) = 2ebe9c8972c378040c9b8505f5fb40a0c64d990cd68be6a62989362b18294d0a
+SIZE (libmpack-libmpack-lua-1.0.7_GH0.tar.gz) = 15606
diff --git a/editors/neovim/pkg-descr b/editors/neovim/pkg-descr
index 7da94a43a4a1..5c1b9860b76a 100644
--- a/editors/neovim/pkg-descr
+++ b/editors/neovim/pkg-descr
@@ -1,3 +1,10 @@
-Neovim is a project that seeks to aggresively refactor Vim
+Neovim is an aggressive refactor of editors/vim. It represents a
+complete overhaul of the codebase with many sanity improvements,
+including sensible defaults, a built-in terminal emulator,
+asynchronous plugin architecture, and powerful APIs designed for
+speed and extensibility. It retains full compatibility
+with almost all Vim plugins and scripts.
-WWW: http://neovim.org/
+For most users, Neovim is a drop-in Vim replacement.
+
+WWW: https://neovim.org/