aboutsummaryrefslogtreecommitdiff
path: root/editors/neovim
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-06-11 17:44:02 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-06-11 17:44:02 +0000
commitd512d4b6c822f716c654561bee1bbbbd50f52afd (patch)
tree6c37917a80eefd97a39f58adbd29c0697e1fe790 /editors/neovim
parent8b8fb92b63f6574c296bba03e85d54cdc85ce592 (diff)
downloadports-d512d4b6c822f716c654561bee1bbbbd50f52afd.tar.gz
ports-d512d4b6c822f716c654561bee1bbbbd50f52afd.zip
editors/neovim: fix build on powerpc64 elfv2
Use GCC instead of Clang, Clang-compiled binary crashes at testing. Strangely, it doesn't crash when built with WITH_DEBUG=yes, but that makes debugging hard.
Notes
Notes: svn path=/head/; revision=538515
Diffstat (limited to 'editors/neovim')
-rw-r--r--editors/neovim/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/editors/neovim/Makefile b/editors/neovim/Makefile
index 6c83414a34a0..13cda5587855 100644
--- a/editors/neovim/Makefile
+++ b/editors/neovim/Makefile
@@ -57,6 +57,12 @@ NLS_USES= gettext
PYNVIM_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pynvim>=0.3.0:editors/py-pynvim@${PY_FLAVOR}
PYNVIM_USES= python:run
+.include <bsd.port.options.mk>
+
+.if ${ARCH} == powerpc64
+USES+= compiler:gcc-c++11-lib
+.endif
+
post-patch:
${REINPLACE_CMD} -e \
's|lua_objlen|lua_rawlen| ; \