aboutsummaryrefslogtreecommitdiff
path: root/editors/o
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-10-13 20:32:49 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-10-13 20:32:49 +0000
commitf8db3b9196c84c07bdb945a25f7d03def0b5350e (patch)
tree431b0ce683526962d1df1647ed88f2cb0e0c674d /editors/o
parent256e5eca530d9f3fc1a038e8c6602a30cc70b5bd (diff)
downloadports-f8db3b9196c84c07bdb945a25f7d03def0b5350e.tar.gz
ports-f8db3b9196c84c07bdb945a25f7d03def0b5350e.zip
New port: editors/o: Small, fast and limited text editor in Go
Notes
Notes: svn path=/head/; revision=514419
Diffstat (limited to 'editors/o')
-rw-r--r--editors/o/Makefile26
-rw-r--r--editors/o/distinfo15
-rw-r--r--editors/o/pkg-descr16
3 files changed, 57 insertions, 0 deletions
diff --git a/editors/o/Makefile b/editors/o/Makefile
new file mode 100644
index 000000000000..1ba1aeaa14f9
--- /dev/null
+++ b/editors/o/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= o
+DISTVERSION= 2.3.1
+CATEGORIES= editors
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Small, fast and limited text editor in Go
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= go:modules
+USE_GITHUB= yes
+GH_ACCOUNT= xyproto
+GH_TUPLE= \
+ golang:sys:b09406accb47:golang_sys/vendor/golang.org/x/sys \
+ pkg:term:aa71e9d9e942:pkg_term/vendor/github.com/pkg/term \
+ sourcegraph:annotate:f4cad6c6324d:sourcegraph_annotate/vendor/github.com/sourcegraph/annotate \
+ xyproto:syntax:1aa81d747d75:xyproto_syntax/vendor/github.com/xyproto/syntax \
+ xyproto:textoutput:v1.8.0:xyproto_textoutput/vendor/github.com/xyproto/textoutput \
+ xyproto:vt100:f1727647a85e:xyproto_vt100/vendor/github.com/xyproto/vt100
+
+PLIST_FILES= bin/o
+
+.include <bsd.port.mk>
diff --git a/editors/o/distinfo b/editors/o/distinfo
new file mode 100644
index 000000000000..af7f5f0cf36e
--- /dev/null
+++ b/editors/o/distinfo
@@ -0,0 +1,15 @@
+TIMESTAMP = 1570998155
+SHA256 (xyproto-o-2.3.1_GH0.tar.gz) = 82d20977170391b7e37fb6dbf3883d077e0dba8b77fa0d61df3b96ec8d16b0e9
+SIZE (xyproto-o-2.3.1_GH0.tar.gz) = 1282670
+SHA256 (golang-sys-b09406accb47_GH0.tar.gz) = 732651ee709d3443e992f716796c5dac7cbc29a345a8ffe3fb80f505c93503d2
+SIZE (golang-sys-b09406accb47_GH0.tar.gz) = 1496780
+SHA256 (pkg-term-aa71e9d9e942_GH0.tar.gz) = dc6f1cf8c71916dd12b31a09a2b1e5b7022afb5c372beb9d6d3f35dd9d14d6b6
+SIZE (pkg-term-aa71e9d9e942_GH0.tar.gz) = 9497
+SHA256 (sourcegraph-annotate-f4cad6c6324d_GH0.tar.gz) = 9586ee91b45741f018ac91993dcf794283150aac952e10f965d4daa7c4bdd95f
+SIZE (sourcegraph-annotate-f4cad6c6324d_GH0.tar.gz) = 5960
+SHA256 (xyproto-syntax-1aa81d747d75_GH0.tar.gz) = dc775175311541e1bdcd731fbe5328c7d18cb1cc04532a84c8ce19813f4e0ed0
+SIZE (xyproto-syntax-1aa81d747d75_GH0.tar.gz) = 1240926
+SHA256 (xyproto-textoutput-v1.8.0_GH0.tar.gz) = c4e3cf8d1c3653353eb21db679bf58e0ed400f417955b6d2712f48791e53b987
+SIZE (xyproto-textoutput-v1.8.0_GH0.tar.gz) = 1235365
+SHA256 (xyproto-vt100-f1727647a85e_GH0.tar.gz) = b575bcef171549405630ddb6da262d07e49ec47a8d003e555374c44ccc800b7a
+SIZE (xyproto-vt100-f1727647a85e_GH0.tar.gz) = 1389891
diff --git a/editors/o/pkg-descr b/editors/o/pkg-descr
new file mode 100644
index 000000000000..30fffee1ef51
--- /dev/null
+++ b/editors/o/pkg-descr
@@ -0,0 +1,16 @@
+Small, fast and limited text editor
+
+Features and limitations:
+* Has syntax highlighting for Go code.
+* Never asks before saving or quitting. Be careful.
+* Home and End are not detected by the key handler.
+* Can format Go code using gofmt (press ctrl-f).
+* Expects utilities like gofmt to be in /usr/bin.
+* Will strip trailing whitespace whenever it can.
+* Must be given a filename at start.
+* Requires that /dev/tty is available.
+* Copy, cut and paste is only for one line at a time.
+* Some letters can not be typed in. Like the "ash" grapheme
+ formed from the letters a and e.
+
+WWW: https://github.com/xyproto/o