aboutsummaryrefslogtreecommitdiff
path: root/editors/openoffice-4/Makefile
diff options
context:
space:
mode:
authorDon Lewis <truckman@FreeBSD.org>2015-09-26 07:40:47 +0000
committerDon Lewis <truckman@FreeBSD.org>2015-09-26 07:40:47 +0000
commit19bbc1b1cd97a5c1fee89f9dcc4a860e83443fbf (patch)
treea174a56302213f75af8f982612d9906640b20104 /editors/openoffice-4/Makefile
parent506ed9efd6fed4c0af8f70b4cbbe8db9346a5e17 (diff)
Add Caladea and Carlito fonts. They are metrically equivalent to some
Microsoft fonts and the proper definitions within OpenOffice have been added so that they are recognized as such. [1] The Linux ports handle the mapping from the printeradmin command to the spadmin executable in the shell wrapper. Do the same in the FreeBSD port rather than munging the printeradmin.desktop file. Retain the spadmin link to the wrapper for backwards compatability. The setofficelang command went away a long time ago. Remove it from the shell wrapper and remove the link. Exec the OpenOffice executables from the wrapper so that the shell for the wrapper doesn't hang around as an extra process until OpenOffice terminates. Nuke an extraneous shell continuation in the Makefile. Suggested by: pfg [1]
Notes
Notes: svn path=/head/; revision=397932
Diffstat (limited to 'editors/openoffice-4/Makefile')
-rw-r--r--editors/openoffice-4/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/editors/openoffice-4/Makefile b/editors/openoffice-4/Makefile
index effd27fa780a..66cf1c1f8be5 100644
--- a/editors/openoffice-4/Makefile
+++ b/editors/openoffice-4/Makefile
@@ -3,7 +3,7 @@
PORTNAME= apache-openoffice
PORTVERSION= ${AOOVERSION}
-PORTREVISION= 15
+PORTREVISION= 16
CATEGORIES= editors java
MASTER_SITES= APACHE/openoffice/${PORTVERSION}/source \
http://tools.openoffice.org/unowinreg_prebuild/680/:unoreg \
@@ -91,6 +91,8 @@ RUN_DEPENDS= \
${LOCALBASE}/share/icons/hicolor/index.theme:${PORTSDIR}/misc/hicolor-icon-theme \
${JAVALIBDIR}/commons-httpclient.jar:${PORTSDIR}/java/jakarta-commons-httpclient \
${JAVALIBDIR}/bsh.jar:${PORTSDIR}/lang/bsh \
+ ${LOCALBASE}/share/fonts/Caladea/Caladea-Bold.ttf:${PORTSDIR}/x11-fonts/crosextrafonts-caladea-ttf \
+ ${LOCALBASE}/share/fonts/Carlito/Carlito-Bold.ttf:${PORTSDIR}/x11-fonts/crosextrafonts-carlito-ttf \
${LOCALBASE}/share/fonts/ChromeOS/Arimo-Bold.ttf:${PORTSDIR}/x11-fonts/croscorefonts-fonts-ttf
AOOVERSION1= 4
@@ -402,7 +404,7 @@ do-install:
@cd ${STAGEDIR}${OOPATH}/program ; \
${ECHO_CMD} "stripping executables and shared libraries" ; \
${STRIP_CMD} crashrep pagein uri-encode javaldx regmerge \
- regview *.so* *.bin ; \
+ regview *.so* *.bin
${FIND} ${STAGEDIR}${PRINSTALLATION_BASEDIR} -type d -exec ${CHMOD} 755 {} \;
${REINPLACE_CMD} \
-e '/^UserInstallation/s/=.*/=$$SYSUSERCONFIG\/${AOOUDIR}/' \
@@ -415,8 +417,8 @@ do-install:
${WRKDIR}/openoffice-wrapper
${INSTALL_SCRIPT} ${WRKDIR}/openoffice-wrapper \
${STAGEDIR}${PREFIX}/bin/${EXECBASE}
- @cd ${STAGEDIR}${PREFIX}/bin; for i in sbase scalc sdraw \
- setofficelang simpress smath spadmin swriter ; do \
+ @cd ${STAGEDIR}${PREFIX}/bin; for i in printeradmin sbase scalc sdraw \
+ simpress smath spadmin swriter ; do \
${LN} -f ${EXECBASE} ${EXECBASE}-$${i} ; \
done
${LN} -sf ${XDGDIR} ${STAGEDIR}${DESKTOPDIR}/${EXECBASE}