aboutsummaryrefslogtreecommitdiff
path: root/editors/openoffice-4/Makefile
diff options
context:
space:
mode:
authorDon Lewis <truckman@FreeBSD.org>2018-06-12 03:55:02 +0000
committerDon Lewis <truckman@FreeBSD.org>2018-06-12 03:55:02 +0000
commit32aa25d3bc637e5615a562226e287afb5818fbd8 (patch)
tree649c49ea63638358c5475d8f6d74464eedf086e7 /editors/openoffice-4/Makefile
parentf9e43c71cd3afe141bba19c8810168cc8150164e (diff)
Instead of symlinking the directory containing the OpenOffice .desktop
files under $PREFIX/share/applications, symlink the individual .desktop files. This is what upstream does on Linux and what LibreOffice does as well. The Plasma 5 desktop ignores symlinks to directories when it is scanning for .desktop files. PR: 228030 Reported by: kan@FreeBSD.org
Notes
Notes: svn path=/head/; revision=472229
Diffstat (limited to 'editors/openoffice-4/Makefile')
-rw-r--r--editors/openoffice-4/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/editors/openoffice-4/Makefile b/editors/openoffice-4/Makefile
index 30426a721a1e..a53e8da05905 100644
--- a/editors/openoffice-4/Makefile
+++ b/editors/openoffice-4/Makefile
@@ -3,7 +3,7 @@
PORTNAME= apache-openoffice
PORTVERSION= ${AOOVERSION}
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= editors java
MASTER_SITES= APACHE/openoffice/${PORTVERSION}/sources \
http://tools.openoffice.org/unowinreg_prebuild/680/:unoreg \
@@ -454,7 +454,6 @@ do-install:
${LN} -f ${EXECBASE} ${EXECBASE}-$${i} ; \
done
@${ECHO_CMD} "adding desktop support"
- @${LN} -sf ${XDGREL} ${STAGEDIR}${DESKTOPDIR}/${EXECBASE}
@cd ${WRKSRC} ; \
. ${FREEBSD_ENV_SET} ; \
cd sysui/$${INPATH}/misc/openoffice ; \
@@ -468,6 +467,10 @@ do-install:
${SH} ${CREATE_TREE} ; \
${INSTALL_DATA} apacheopenoffice.xml \
${STAGEDIR}/${PREFIX}/share/mime/packages
+ @cd ${STAGEDIR}${DESKTOPDIR}; for i in base calc draw impress \
+ javafilter math printeradmin qstart startcenter writer ; do \
+ ${LN} -sf ${XDGREL}/$${i}.desktop ${EXECBASE}-$${i}.desktop ; \
+ done
do-install-SDK-on:
${TAR} -s '|./[^/]*/||' -xz -C ${STAGEDIR}${PRINSTALLATION_BASEDIR} \