aboutsummaryrefslogtreecommitdiff
path: root/editors/openoffice-4/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2021-02-06 19:45:40 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2021-02-06 19:45:40 +0000
commit7d5aafb64f12d92df4e70c5c4f37a3fb16fd437d (patch)
tree2fcde745cc79c5007c6e5864640042a9ae320bca /editors/openoffice-4/Makefile
parent4e5d5b5a511dc0dc1e28fcbc38f0ff9a57c6ce93 (diff)
Remove dependency on deprecated gnome2 libraries:
gnomevfs and gconf
Notes
Notes: svn path=/head/; revision=564243
Diffstat (limited to 'editors/openoffice-4/Makefile')
-rw-r--r--editors/openoffice-4/Makefile18
1 files changed, 7 insertions, 11 deletions
diff --git a/editors/openoffice-4/Makefile b/editors/openoffice-4/Makefile
index baac7d017e28..5d34ac0cdbca 100644
--- a/editors/openoffice-4/Makefile
+++ b/editors/openoffice-4/Makefile
@@ -3,6 +3,7 @@
PORTNAME= apache-openoffice
PORTVERSION= ${AOOVERSION}
+PORTREVISION= 1
CATEGORIES= editors java
MASTER_SITES= APACHE/openoffice/${PORTVERSION}/source \
http://tools.openoffice.org/unowinreg_prebuild/680/:unoreg \
@@ -135,14 +136,13 @@ WITHOUT_CPU_CFLAGS= true
CPE_PRODUCT= ${PORTNAME:S|apache-||}
CPE_VENDOR= apache
-OPTIONS_DEFINE= CRASHDUMP CUPS DBGUTIL DEBUG GNOME GNOMEVFS \
+OPTIONS_DEFINE= CRASHDUMP CUPS DBGUTIL DEBUG GNOME \
SDK WIKI_PUBLISHER
-OPTIONS_DEFAULT= CUPS GNOME GNOMEVFS WIKI_PUBLISHER
+OPTIONS_DEFAULT= CUPS GNOME WIKI_PUBLISHER
CRASHDUMP_DESC= Enable crashdumps, you also need to set WITH_DEBUG_PORTS+=${PKGORIGIN}
DBGUTIL_DESC= Enable assertions, object counting. (non-production)
DEBUG_DESC= Compile with -O0, you also need to set WITH_DEBUG_PORTS+=${PKGORIGIN}
-GNOME_DESC= GConf + screensaver presentation control via DBUS
-GNOMEVFS_DESC= GNOME Virtual File System
+GNOME_DESC= Screensaver presentation control via DBUS
SDK_DESC= Build and install software development kit
WIKI_PUBLISHER_DESC= Build and install Wiki Publisher extension
@@ -155,15 +155,9 @@ DBGUTIL_CONFIGURE_ENABLE= dbgutil
DEBUG_CONFIGURE_ENABLE= debug
-GNOME_CONFIGURE_ENABLE= dbus gconf lockdown
+GNOME_CONFIGURE_ENABLE= dbus lockdown
GNOME_LIB_DEPENDS= libdbus-1.so:devel/dbus \
libdbus-glib-1.so:devel/dbus-glib
-GNOME_USE= GNOME=gconf2
-
-GNOMEVFS_CONFIGURE_ENABLE= gnome-vfs
-GNOMEVFS_CONFIGURE_OFF= --enable-gio
-GNOMEVFS_CONFIGURE_ON= --disable-gio
-GNOMEVFS_USE= GNOME=gnomevfs2
SDK_CONFIGURE_ENABLE= odk
SDK_DISTFILES= unowinreg.dll:unoreg
@@ -243,6 +237,8 @@ SUB_LIST= EXECBASE=${EXECBASE} AOOTAG=${AOOTAG} AOOUDIR=${AOOUDIR} \
PRINSTALLATION_BASEDIR=${PRINSTALLATION_BASEDIR}
CONFIGURE_ARGS+= \
+ --disable-gconf \
+ --enable-gio \
--with-unix-wrapper=${EXECBASE} \
--with-alloc=system \
--with-ant-home=${LOCALBASE}/share/java/apache-ant \