aboutsummaryrefslogtreecommitdiff
path: root/editors/openoffice-4/Makefile
diff options
context:
space:
mode:
authorDon Lewis <truckman@FreeBSD.org>2015-10-23 23:22:24 +0000
committerDon Lewis <truckman@FreeBSD.org>2015-10-23 23:22:24 +0000
commita17bc80cb5dbdf95d7c0b2ef63c7f171c46473e5 (patch)
tree64d42f2dbe55521f0bf3c278aa64d953081a8ed3 /editors/openoffice-4/Makefile
parentbf534872af32214a929b225f23ce51d8510563b4 (diff)
downloadports-a17bc80cb5dbdf95d7c0b2ef63c7f171c46473e5.tar.gz
ports-a17bc80cb5dbdf95d7c0b2ef63c7f171c46473e5.zip
Notes
Diffstat (limited to 'editors/openoffice-4/Makefile')
-rw-r--r--editors/openoffice-4/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/editors/openoffice-4/Makefile b/editors/openoffice-4/Makefile
index 35c87e9618ac..bbdb60c6797f 100644
--- a/editors/openoffice-4/Makefile
+++ b/editors/openoffice-4/Makefile
@@ -3,7 +3,7 @@
PORTNAME= apache-openoffice
PORTVERSION= ${AOOVERSION}
-PORTREVISION= 17
+PORTREVISION= 18
CATEGORIES= editors java
MASTER_SITES= APACHE/openoffice/${PORTVERSION}/source \
http://tools.openoffice.org/unowinreg_prebuild/680/:unoreg \
@@ -121,6 +121,7 @@ USE_GL= gl glu
USE_GNOME= gtk20 libxslt libidl glib20
USE_JAVA= yes
JAVA_BUILD= jdk
+JAVA_RUN= jdk
JAVA_VENDOR= openjdk
JAVA_VERSION= 1.6+
USE_PERL5= build
@@ -323,6 +324,8 @@ post-extract:
post-patch:
${REINPLACE_CMD} -e "/^ICONVERSION/s/=.*/= '-${AOOSUFFIX}'/" \
${WRKSRC}/sysui/desktop/productversion.mk
+ ${REINPLACE_CMD} -e "s|%%JAVA_HOME%%|${JAVA_HOME}|" \
+ ${WRKSRC}/desktop/scripts/soffice.sh
.if ${COMPILER_TYPE} == gcc
# g++49 -Os sometimes leaves inline class methods undefined,
# affects fmgridif.cxx and ColumnControl.cxx