aboutsummaryrefslogtreecommitdiff
path: root/editors/openoffice-4
diff options
context:
space:
mode:
authorDon Lewis <truckman@FreeBSD.org>2016-03-20 21:42:08 +0000
committerDon Lewis <truckman@FreeBSD.org>2016-03-20 21:42:08 +0000
commit42956fde4570864d251d6b478566349b305bd437 (patch)
tree262f9d837bccb59350993db3a02483a0fa3b3712 /editors/openoffice-4
parent5aa4a113c07243331a839b0652d88fca0d566c68 (diff)
downloadports-42956fde4570864d251d6b478566349b305bd437.tar.gz
ports-42956fde4570864d251d6b478566349b305bd437.zip
Notes
Diffstat (limited to 'editors/openoffice-4')
-rw-r--r--editors/openoffice-4/Makefile5
-rw-r--r--editors/openoffice-4/files/patch-r172887298
2 files changed, 102 insertions, 1 deletions
diff --git a/editors/openoffice-4/Makefile b/editors/openoffice-4/Makefile
index a554cd62f7f5..45a2812e122f 100644
--- a/editors/openoffice-4/Makefile
+++ b/editors/openoffice-4/Makefile
@@ -3,7 +3,7 @@
PORTNAME= apache-openoffice
PORTVERSION= ${AOOVERSION}
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= editors java
MASTER_SITES= APACHE/openoffice/${PORTVERSION}/source \
http://tools.openoffice.org/unowinreg_prebuild/680/:unoreg \
@@ -165,6 +165,9 @@ SDK_CONFIGURE_ENABLE= odk
WIKI_PUBLISHER_CONFIGURE_ENABLE= wiki-publisher
WIKI_PUBLISHER_VARS= BUNDLED_EXTENSIONS+=swext/wiki-publisher.oxt
+# Don't run gnome-post-install until after post-install generates the plist
+TARGET_ORDER_OVERRIDE= 710:gnome-post-install
+
.include <bsd.port.pre.mk>
.include <${FILESDIR}/Makefile.localized>
diff --git a/editors/openoffice-4/files/patch-r1728872 b/editors/openoffice-4/files/patch-r1728872
new file mode 100644
index 000000000000..7570eabe5694
--- /dev/null
+++ b/editors/openoffice-4/files/patch-r1728872
@@ -0,0 +1,98 @@
+--- sal/osl/unx/pipe.c.orig 2014-02-25 08:31:45 UTC
++++ sal/osl/unx/pipe.c
+@@ -115,7 +115,7 @@ oslPipe __osl_createPipeImpl()
+ pPipeImpl = (oslPipe)calloc(1, sizeof(struct oslPipeImpl));
+ pPipeImpl->m_nRefCount =1;
+ pPipeImpl->m_bClosed = sal_False;
+-#if defined(LINUX)
++#if CLOSESOCKET_DOESNT_WAKE_UP_ACCEPT
+ pPipeImpl->m_bIsInShutdown = sal_False;
+ pPipeImpl->m_bIsAccepting = sal_False;
+ #endif
+@@ -321,7 +321,7 @@ void SAL_CALL osl_releasePipe( oslPipe p
+ void SAL_CALL osl_closePipe( oslPipe pPipe )
+ {
+ int nRet;
+-#if defined(LINUX)
++#if CLOSESOCKET_DOESNT_WAKE_UP_ACCEPT
+ size_t len;
+ struct sockaddr_un addr;
+ int fd;
+@@ -341,10 +341,10 @@ void SAL_CALL osl_closePipe( oslPipe pPi
+ ConnFD = pPipe->m_Socket;
+
+ /*
+- Thread does not return from accept on linux, so
++ Thread does not return from accept on some operating systems, so
+ connect to the accepting pipe
+ */
+-#if defined(LINUX)
++#if CLOSESOCKET_DOESNT_WAKE_UP_ACCEPT
+ if ( pPipe->m_bIsAccepting )
+ {
+ pPipe->m_bIsInShutdown = sal_True;
+@@ -356,7 +356,11 @@ void SAL_CALL osl_closePipe( oslPipe pPi
+
+ addr.sun_family = AF_UNIX;
+ strncpy(addr.sun_path, pPipe->m_Name, sizeof(addr.sun_path));
+- len = sizeof(addr);
++#if defined(FREEBSD)
++ len = SUN_LEN(&addr);
++#else
++ len = sizeof(addr);
++#endif
+
+ nRet = connect( fd, (struct sockaddr *)&addr, len);
+ #if OSL_DEBUG_LEVEL > 1
+@@ -367,7 +371,7 @@ void SAL_CALL osl_closePipe( oslPipe pPi
+ #endif /* OSL_DEBUG_LEVEL */
+ close(fd);
+ }
+-#endif /* LINUX */
++#endif /* CLOSESOCKET_DOESNT_WAKE_UP_ACCEPT */
+
+
+ nRet = shutdown(ConnFD, 2);
+@@ -408,13 +412,13 @@ oslPipe SAL_CALL osl_acceptPipe(oslPipe
+
+ OSL_ASSERT(strlen(pPipe->m_Name) > 0);
+
+-#if defined(LINUX)
++#if CLOSESOCKET_DOESNT_WAKE_UP_ACCEPT
+ pPipe->m_bIsAccepting = sal_True;
+ #endif
+
+ s = accept(pPipe->m_Socket, NULL, NULL);
+
+-#if defined(LINUX)
++#if CLOSESOCKET_DOESNT_WAKE_UP_ACCEPT
+ pPipe->m_bIsAccepting = sal_False;
+ #endif
+
+@@ -424,13 +428,13 @@ oslPipe SAL_CALL osl_acceptPipe(oslPipe
+ return NULL;
+ }
+
+-#if defined(LINUX)
++#if CLOSESOCKET_DOESNT_WAKE_UP_ACCEPT
+ if ( pPipe->m_bIsInShutdown )
+ {
+ close(s);
+ return NULL;
+ }
+-#endif /* LINUX */
++#endif /* CLOSESOCKET_DOESNT_WAKE_UP_ACCEPT */
+ else
+ {
+ /* alloc memory */
+--- sal/osl/unx/sockimpl.h.orig 2015-10-21 07:03:17 UTC
++++ sal/osl/unx/sockimpl.h
+@@ -63,7 +63,7 @@ struct oslPipeImpl {
+ sal_Char m_Name[PATH_MAX + 1];
+ oslInterlockedCount m_nRefCount;
+ sal_Bool m_bClosed;
+-#if defined(LINUX)
++#if CLOSESOCKET_DOESNT_WAKE_UP_ACCEPT
+ sal_Bool m_bIsAccepting;
+ sal_Bool m_bIsInShutdown;
+ #endif