aboutsummaryrefslogtreecommitdiff
path: root/editors/openoffice-4
diff options
context:
space:
mode:
authorDon Lewis <truckman@FreeBSD.org>2019-09-20 16:56:36 +0000
committerDon Lewis <truckman@FreeBSD.org>2019-09-20 16:56:36 +0000
commitaa4b132ed3b693a4f6c66ee6b540dd8bd756b8be (patch)
tree077407e881a463dd25be06493aaa82402af804ad /editors/openoffice-4
parentc8a2293cdcdc4a663736eaca7664e90c7fb8766a (diff)
downloadports-aa4b132ed3b693a4f6c66ee6b540dd8bd756b8be.tar.gz
ports-aa4b132ed3b693a4f6c66ee6b540dd8bd756b8be.zip
Upgrade editors/openoffice-4 to 4.1.7.
The build wants to include the git hash value in the build artifact for display on the Help -> About popup, but it can't determine that when building from a source tarball, as opposed to a git checkout. Patch around that until upstream implements a way to include this info into the tarball and pick it up from there. Add xorg to USES for correctness. patch-i127929 has been committed upstream.
Notes
Notes: svn path=/head/; revision=512422
Diffstat (limited to 'editors/openoffice-4')
-rw-r--r--editors/openoffice-4/Makefile13
-rw-r--r--editors/openoffice-4/distinfo6
-rw-r--r--editors/openoffice-4/files/patch-i12792920
3 files changed, 10 insertions, 29 deletions
diff --git a/editors/openoffice-4/Makefile b/editors/openoffice-4/Makefile
index 8fee87431b08..85260c07a06b 100644
--- a/editors/openoffice-4/Makefile
+++ b/editors/openoffice-4/Makefile
@@ -3,7 +3,6 @@
PORTNAME= apache-openoffice
PORTVERSION= ${AOOVERSION}
-PORTREVISION= 7
CATEGORIES= editors java
MASTER_SITES= APACHE/openoffice/${PORTVERSION}/source \
http://tools.openoffice.org/unowinreg_prebuild/680/:unoreg \
@@ -98,7 +97,7 @@ RUN_DEPENDS= \
USES= autoreconf bison compiler:c++11-lib cpe desktop-file-utils \
gettext-runtime gl gmake gnome iconv jpeg perl5 pkgconfig \
- python:2.7 shared-mime-info ssl tar:bzip2
+ python:2.7 shared-mime-info ssl tar:bzip2 xorg
USE_GL= gl glu
USE_GNOME= gtk20 libxslt libidl glib20
USE_JAVA= yes
@@ -114,16 +113,16 @@ CONFLICTS_INSTALL= apache-openoffice-devel-*
AOOVERSION1= 4
AOOVERSION2= 1
-AOOVERSION3= 6
+AOOVERSION3= 7
# From solenv/inc/minor.mk SOURCEREVISION LAST_MINOR BUILD
-AOOTAG= AOO416m1\(Build:9790\)
-SVNREVISION= 1844436
+AOOTAG= AOO417m1\(Build:9800\)
+GITREVISION= 46059c9192
EXTSRC= ApacheOpenOffice.ext_sources.${AOOVERSION1}.x.x.20150707.tar.gz
AOOVERSION= ${AOOVERSION1}.${AOOVERSION2}.${AOOVERSION3}
AOOXXX= ${AOOVERSION1}${AOOVERSION2}${AOOVERSION3}
AOOSUFFIX= ${PORTVERSION}
-AOOSRC= apache-openoffice-${AOOVERSION}-r${SVNREVISION}-src${EXTRACT_SUFX}
+AOOSRC= apache-openoffice-${AOOVERSION}-${GITREVISION}-src${EXTRACT_SUFX}
AOOUDIR= .openoffice.org\/${AOOVERSION1}
INSTALLATION_BASEDIR?= openoffice-${AOOSUFFIX}
@@ -367,6 +366,8 @@ post-patch:
${WRKSRC}/sysui/desktop/productversion.mk
${REINPLACE_CMD} -e "s|%%JAVA_HOME%%|${JAVA_HOME}|" \
${WRKSRC}/desktop/scripts/soffice.sh
+ ${REINPLACE_CMD} -e "/#test/i\\${.newline} return '${GITREVISION}';" \
+ ${WRKSRC}/solenv/bin/modules/SvnRevision.pm
${REINPLACE_CMD} -e '/^mkdir -p/,$$d' ${CREATE_TREE}
.if ${CHOSEN_COMPILER_TYPE} == gcc
# g++49 -Os sometimes leaves inline class methods undefined,
diff --git a/editors/openoffice-4/distinfo b/editors/openoffice-4/distinfo
index 0554dfed1ab8..e6684f925dce 100644
--- a/editors/openoffice-4/distinfo
+++ b/editors/openoffice-4/distinfo
@@ -1,6 +1,6 @@
-TIMESTAMP = 1542783715
-SHA256 (openoffice/apache-openoffice-4.1.6-r1844436-src.tar.bz2) = 5189880207977a0fd6d4ef5eada7d18d8dbf94cddcc71822889cfb6c82cfed18
-SIZE (openoffice/apache-openoffice-4.1.6-r1844436-src.tar.bz2) = 220017032
+TIMESTAMP = 1568248262
+SHA256 (openoffice/apache-openoffice-4.1.7-46059c9192-src.tar.bz2) = 512952c78b3ec22b15bc1a444b4fa7e7c76c25c985a75b6977e62c6ddae2e3ed
+SIZE (openoffice/apache-openoffice-4.1.7-46059c9192-src.tar.bz2) = 220014716
SHA256 (openoffice/ApacheOpenOffice.ext_sources.4.x.x.20150707.tar.gz) = 966a8333c83a18ddd84401389006d6e0b52b8175924b808b54b88211669985fa
SIZE (openoffice/ApacheOpenOffice.ext_sources.4.x.x.20150707.tar.gz) = 28957004
SHA256 (openoffice/unowinreg.dll) = f563e522922133db9340b0306711c2d8767cc3481dd9e7d9b0d059906d12653c
diff --git a/editors/openoffice-4/files/patch-i127929 b/editors/openoffice-4/files/patch-i127929
deleted file mode 100644
index 176c483deeab..000000000000
--- a/editors/openoffice-4/files/patch-i127929
+++ /dev/null
@@ -1,20 +0,0 @@
-Index: vcl/source/glyphs/gcach_ftyp.cxx
-===================================================================
---- vcl/source/glyphs/gcach_ftyp.cxx (revision 1846187)
-+++ vcl/source/glyphs/gcach_ftyp.cxx (working copy)
-@@ -1361,6 +1361,15 @@
-
- FT_Glyph pGlyphFT;
- rc = FT_Get_Glyph( maFaceFT->glyph, &pGlyphFT );
-+ if( rc != FT_Err_Ok )
-+ {
-+ // we get here e.g. when a PS font lacks the default glyph
-+ rGD.SetCharWidth( 0 );
-+ rGD.SetDelta( 0, 0 );
-+ rGD.SetOffset( 0, 0 );
-+ rGD.SetSize( Size( 0, 0 ) );
-+ return;
-+ }
-
- ApplyGlyphTransform( nGlyphFlags, pGlyphFT, false );
- if( mbArtBold && pFTEmbolden && (nFTVERSION < 2200) ) // #i71094# workaround staircase bug