aboutsummaryrefslogtreecommitdiff
path: root/editors/openoffice-4
diff options
context:
space:
mode:
authorDon Lewis <truckman@FreeBSD.org>2018-11-23 19:26:37 +0000
committerDon Lewis <truckman@FreeBSD.org>2018-11-23 19:26:37 +0000
commitcad6fef0d4a27528ef2fca065defc3dc5b66ec8c (patch)
tree92ed43e07a47c1e4da2b3e9470904df2723f5f42 /editors/openoffice-4
parent10df6d54e984804e8ec1af7459b556837f5b58cb (diff)
downloadports-cad6fef0d4a27528ef2fca065defc3dc5b66ec8c.tar.gz
ports-cad6fef0d4a27528ef2fca065defc3dc5b66ec8c.zip
Fix for crash in Freetype code. Check the return value of the
FT_Get_Glyph() function. See https://bz.apache.org/ooo/show_bug.cgi?id=127929 [1] Ensure that unowinreg.dll is included in DISTFILES when running the makesum and distclean targets. PR: 233404 [1] Obtained from: upstream [1] MFH: 2018Q4
Notes
Notes: svn path=/head/; revision=485699
Diffstat (limited to 'editors/openoffice-4')
-rw-r--r--editors/openoffice-4/Makefile7
-rw-r--r--editors/openoffice-4/files/patch-i12792920
2 files changed, 27 insertions, 0 deletions
diff --git a/editors/openoffice-4/Makefile b/editors/openoffice-4/Makefile
index 60e8387ba224..ff0145744e25 100644
--- a/editors/openoffice-4/Makefile
+++ b/editors/openoffice-4/Makefile
@@ -3,6 +3,7 @@
PORTNAME= apache-openoffice
PORTVERSION= ${AOOVERSION}
+PORTREVISION= 1
CATEGORIES= editors java
MASTER_SITES= APACHE/openoffice/${PORTVERSION}/source \
http://tools.openoffice.org/unowinreg_prebuild/680/:unoreg \
@@ -192,6 +193,12 @@ WIKI_PUBLISHER_VARS= BUNDLED_EXTENSIONS+=swext/wiki-publisher.oxt
# Don't run gnome-post-icons until after post-install generates the plist
TARGET_ORDER_OVERRIDE= 710:gnome-post-icons
+# Force the SDK option on for makesum to ensure that unowinreg.dll is
+# included in distinfo
+.if make(makesum) || make(distclean)
+WITH= SDK
+.endif
+
.include <bsd.port.pre.mk>
.if defined(WITH_DEBUG)
diff --git a/editors/openoffice-4/files/patch-i127929 b/editors/openoffice-4/files/patch-i127929
new file mode 100644
index 000000000000..176c483deeab
--- /dev/null
+++ b/editors/openoffice-4/files/patch-i127929
@@ -0,0 +1,20 @@
+Index: vcl/source/glyphs/gcach_ftyp.cxx
+===================================================================
+--- vcl/source/glyphs/gcach_ftyp.cxx (revision 1846187)
++++ vcl/source/glyphs/gcach_ftyp.cxx (working copy)
+@@ -1361,6 +1361,15 @@
+
+ FT_Glyph pGlyphFT;
+ rc = FT_Get_Glyph( maFaceFT->glyph, &pGlyphFT );
++ if( rc != FT_Err_Ok )
++ {
++ // we get here e.g. when a PS font lacks the default glyph
++ rGD.SetCharWidth( 0 );
++ rGD.SetDelta( 0, 0 );
++ rGD.SetOffset( 0, 0 );
++ rGD.SetSize( Size( 0, 0 ) );
++ return;
++ }
+
+ ApplyGlyphTransform( nGlyphFlags, pGlyphFT, false );
+ if( mbArtBold && pFTEmbolden && (nFTVERSION < 2200) ) // #i71094# workaround staircase bug