aboutsummaryrefslogtreecommitdiff
path: root/editors/p5-Padre
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2016-07-31 13:42:53 +0000
committerKurt Jaeger <pi@FreeBSD.org>2016-07-31 13:42:53 +0000
commitbb63f3f081d73b0a040e48ae90a92ba3edca1d79 (patch)
treed062e01eb675be54a510654ef9c5d0ebb5038af3 /editors/p5-Padre
parent0c723327e40803e47933ac927ce085d7d7b992e4 (diff)
downloadports-bb63f3f081d73b0a040e48ae90a92ba3edca1d79.tar.gz
ports-bb63f3f081d73b0a040e48ae90a92ba3edca1d79.zip
Notes
Diffstat (limited to 'editors/p5-Padre')
-rw-r--r--editors/p5-Padre/Makefile21
-rw-r--r--editors/p5-Padre/files/extra-patch-editor10
-rw-r--r--editors/p5-Padre/files/patch-Makefile.PL4
-rw-r--r--editors/p5-Padre/files/patch-lib_Padre_Wx.pm4
4 files changed, 27 insertions, 12 deletions
diff --git a/editors/p5-Padre/Makefile b/editors/p5-Padre/Makefile
index f70d83cef432..ca971ccdd1ac 100644
--- a/editors/p5-Padre/Makefile
+++ b/editors/p5-Padre/Makefile
@@ -3,7 +3,7 @@
PORTNAME= Padre
PORTVERSION= 1.00
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= editors perl5
MASTER_SITES= CPAN/${PORTNAME}/ CPAN/Wx/:wxsc
PKGNAMEPREFIX= p5-
@@ -66,12 +66,13 @@ BUILD_DEPENDS= p5-JSON-XS>=2.29:converters/p5-JSON-XS \
RUN_DEPENDS:= ${BUILD_DEPENDS}
BUILD_DEPENDS+= p5-Module-Build>=0.36:devel/p5-Module-Build
-USES= compiler:c++11-lib gettext perl5
+USES= compiler:c++11-lib dos2unix gettext perl5
USE_PERL5= configure
USE_WX= 3.0
WX_COMPS= wx
-WX_UNICODE= yes
MAKE_JOBS_UNSAFE= yes
+DOS2UNIX_WRKSRC=${WRKDIR}/${WXSC_DISTNAME}
+DOS2UNIX_FILES= wx-scintilla/src/scintilla/src/Editor.cxx
BROKEN_FreeBSD_9= Does not build.
@@ -104,12 +105,16 @@ IGNORE= needs a threaded Perl, build with enabling THREADS option and try again
.endif
.endif
+pre-patch:
+ (cd ${WRKDIR}/${WXSC_DISTNAME} && \
+ ${PATCH} < ${FILESDIR}/extra-patch-editor )
+
post-patch:
- @${REINPLACE_CMD} -e \
+ ${REINPLACE_CMD} -e \
'/my /s|wx-config|${WX_CONFIG:T}|g' \
-e '/ret/ s|urn .flags;|urn $$flags . " -std=c++11";|' \
${WRKDIR}/${WXSC_DISTNAME}/inc/Module/Build/Scintilla.pm
- @${REINPLACE_CMD} -e \
+ ${REINPLACE_CMD} -e \
's|_scintilla-|_scintilla| ; \
s|$$major.*$$release \.|| ; \
/$$major.*$$release;/s|^|#| ; \
@@ -121,15 +126,15 @@ post-patch:
${WRKDIR}/${WXSC_DISTNAME}/inc/Module/Build/Scintilla/GTK.pm
pre-configure:
- @(cd ${WRKDIR}/${WXSC_DISTNAME} && ${SETENV} ${CONFIGURE_ENV} \
+ (cd ${WRKDIR}/${WXSC_DISTNAME} && ${SETENV} ${CONFIGURE_ENV} \
${PERL} Build.PL ${CONFIGURE_ARGS} --destdir=${STAGEDIR})
pre-build:
- @(cd ${WRKDIR}/${WXSC_DISTNAME} && ${SETENV} CC="$$(${WHICH} ${CC})" \
+ (cd ${WRKDIR}/${WXSC_DISTNAME} && ${SETENV} CC="$$(${WHICH} ${CC})" \
${PERL} Build)
pre-install:
- @(cd ${WRKDIR}/${WXSC_DISTNAME} && ${SETENV} CC="$$(${WHICH} ${CC})" \
+ (cd ${WRKDIR}/${WXSC_DISTNAME} && ${SETENV} CC="$$(${WHICH} ${CC})" \
${PERL} Build install)
post-install:
diff --git a/editors/p5-Padre/files/extra-patch-editor b/editors/p5-Padre/files/extra-patch-editor
new file mode 100644
index 000000000000..57a3240ac8cf
--- /dev/null
+++ b/editors/p5-Padre/files/extra-patch-editor
@@ -0,0 +1,10 @@
+--- wx-scintilla/src/scintilla/src/Editor.cxx.orig 2016-07-10 12:18:20.419137000 +0200
++++ wx-scintilla/src/scintilla/src/Editor.cxx 2016-07-10 12:18:29.917664000 +0200
+@@ -16,6 +16,7 @@
+ #include <map>
+ #include <algorithm>
+ #include <memory>
++#include <cmath>
+
+ #include "Platform.h"
+
diff --git a/editors/p5-Padre/files/patch-Makefile.PL b/editors/p5-Padre/files/patch-Makefile.PL
index b682a5643f47..daffffaaafa8 100644
--- a/editors/p5-Padre/files/patch-Makefile.PL
+++ b/editors/p5-Padre/files/patch-Makefile.PL
@@ -1,6 +1,6 @@
---- Makefile.PL.orig
+--- Makefile.PL.orig 2013-11-09 03:10:25 UTC
+++ Makefile.PL
-@@ -46,20 +46,6 @@
+@@ -46,20 +46,6 @@ configure_requires 'ExtUtils::Embed' =>
# exit 0;
#}
diff --git a/editors/p5-Padre/files/patch-lib_Padre_Wx.pm b/editors/p5-Padre/files/patch-lib_Padre_Wx.pm
index 0b67f45eda4b..a231537ed17a 100644
--- a/editors/p5-Padre/files/patch-lib_Padre_Wx.pm
+++ b/editors/p5-Padre/files/patch-lib_Padre_Wx.pm
@@ -1,6 +1,6 @@
---- lib/Padre/Wx.pm.orig
+--- lib/Padre/Wx.pm.orig 2013-11-09 03:43:41 UTC
+++ lib/Padre/Wx.pm
-@@ -67,6 +67,7 @@
+@@ -158,6 +158,7 @@ sub aui_pane_info {
sub launch_browser {
require Padre::Task::LaunchDefaultBrowser;