aboutsummaryrefslogtreecommitdiff
path: root/editors/parinfer-rust
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-01-26 22:14:07 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-01-26 22:14:07 +0000
commit0b8eee9d5758ff0ba74eec79957781d600f435f7 (patch)
tree4a0e8a9e175960c2e7e65d7bae2bb1de7428a60d /editors/parinfer-rust
parente6fb77ce128128795895dd1317249728427e2cb4 (diff)
downloadports-0b8eee9d5758ff0ba74eec79957781d600f435f7.tar.gz
ports-0b8eee9d5758ff0ba74eec79957781d600f435f7.zip
editors/parinfer-rust: Fix Kakoune plugin for Lisp and Scheme files
Add patch to not immediately remove all key hooks after adding them
Notes
Notes: svn path=/head/; revision=491315
Diffstat (limited to 'editors/parinfer-rust')
-rw-r--r--editors/parinfer-rust/Makefile1
-rw-r--r--editors/parinfer-rust/files/patch-rc_parinfer.kak11
2 files changed, 12 insertions, 0 deletions
diff --git a/editors/parinfer-rust/Makefile b/editors/parinfer-rust/Makefile
index fd5c9693fc60..e4371490c1c7 100644
--- a/editors/parinfer-rust/Makefile
+++ b/editors/parinfer-rust/Makefile
@@ -4,6 +4,7 @@ PORTNAME= parinfer-rust
DISTVERSIONPREFIX= v
DISTVERSION= 0.2.0-198
DISTVERSIONSUFFIX= -g506ae2b
+PORTREVISION= 1
CATEGORIES= editors
MAINTAINER= tobik@FreeBSD.org
diff --git a/editors/parinfer-rust/files/patch-rc_parinfer.kak b/editors/parinfer-rust/files/patch-rc_parinfer.kak
new file mode 100644
index 000000000000..f087c994a62a
--- /dev/null
+++ b/editors/parinfer-rust/files/patch-rc_parinfer.kak
@@ -0,0 +1,11 @@
+--- rc/parinfer.kak.orig 2019-01-26 21:44:33 UTC
++++ rc/parinfer.kak
+@@ -72,7 +72,5 @@ hook -group parinfer global WinSetOption filetype=(clo
+ hook -group parinfer window NormalKey .* %{ parinfer -if-enabled -smart }
+ hook -group parinfer window InsertChar (?!\n).* %{ parinfer -if-enabled -smart }
+ hook -group parinfer window InsertDelete .* %{ parinfer -if-enabled -smart }
+-}
+-hook -group parinfer global WinSetOption filetype=(!clojure|lisp|scheme).* %{
+- remove-hooks window parinfer
++ hook -once -always window WinSetOption filetype=.* %{ remove-hooks window parinfer }
+ }