aboutsummaryrefslogtreecommitdiff
path: root/editors/picpas/Makefile
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2018-08-07 07:06:04 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2018-08-07 07:06:04 +0000
commitf3c3dafa569b7d2fdd7913eba157438ec166e972 (patch)
tree8c3269689f7bb52a93d8a2e3375a7d38eeb60949 /editors/picpas/Makefile
parent5d6279f143c2a56a0e3ed2cc4af70ccd9f9fff47 (diff)
downloadports-f3c3dafa569b7d2fdd7913eba157438ec166e972.tar.gz
ports-f3c3dafa569b7d2fdd7913eba157438ec166e972.zip
Notes
Diffstat (limited to 'editors/picpas/Makefile')
-rw-r--r--editors/picpas/Makefile51
1 files changed, 51 insertions, 0 deletions
diff --git a/editors/picpas/Makefile b/editors/picpas/Makefile
new file mode 100644
index 000000000000..8760294e69aa
--- /dev/null
+++ b/editors/picpas/Makefile
@@ -0,0 +1,51 @@
+# $FreeBSD$
+
+PORTNAME= picpas
+PORTVERSION= 0.8.6
+DISTVERSIONPREFIX= v
+CATEGORIES= editors
+PKGNAMESUFFIX= ${LAZARUS_PKGNAMESUFFIX}
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= Multi-platform Pascal for Microchip PIC16F microcontrollers
+
+LICENSE= GPLv2
+
+USES= dos2unix fpc lazarus:flavors
+USE_FPC= chm fcl-base fcl-image fcl-json fcl-registry fcl-xml pasjpeg regexpr \
+ rtl-objpas x11
+USE_XORG= x11
+DOS2UNIX_REGEX= .*\.([txt]|pas|lpi|txt|lfm)
+USE_GITHUB= yes
+GH_ACCOUNT= t-edson
+GH_PROJECT= PicPas
+GH_TAGNAME= e095d58
+GH_TUPLE= t-edson:MiConfig:a4a988a:miconfig/miconfig \
+ t-edson:MisUtils:742eff3:misutils/misutils \
+ t-edson:PicUtils:b38865a:picutils/picutils \
+ t-edson:SynFacilUtils:2909899:syncfacilutils/syncfacilutils \
+ t-edson:UtilsGrilla:07744b9:utilsgrilla/utilsgrilla \
+ t-edson:ogEditGraf:4552327:ogeditgraf/ogeeditgraf \
+ t-edson:t-Xpres:6665922:txpres/txpres
+
+USE_FPC_gtk2= cairo
+USE_GNOME_gtk2= cairo
+USE_FPC+= ${USE_FPC_${FLAVOR}}
+USE_GNOME+= ${USE_GNOME_${FLAVOR}}
+
+gtk2_CONFLICTS_INSTALL= ${PORTNAME}-qt4 ${PORTNAME}-qt5
+qt4_CONFLICTS_INSTALL= ${PORTNAME}-gtk2 ${PORTNAME}-qt5
+qt5_CONFLICTS_INSTALL= ${PORTNAME}-gtk2 ${PORTNAME}-qt4
+
+LAZARUS_PROJECT_FILES= Source/PicPas.lpi
+LAZBUILD_ARGS= -d
+
+post-patch:
+ ${REINPLACE_CMD} 's|%%DATADIR%%|${DATADIR}|g' ${WRKSRC}/Source/Globales.pas
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/PicPas-freebsd ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ cd ${WRKSRC} && ${COPYTREE_SHARE} "devices syntax samples temp themes units" ${STAGEDIR}${DATADIR}
+
+.include <bsd.port.mk>