aboutsummaryrefslogtreecommitdiff
path: root/editors/psgml
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2005-07-30 10:17:06 +0000
committerHiroki Sato <hrs@FreeBSD.org>2005-07-30 10:17:06 +0000
commitf0289e0cafa9128a455d4a9bddbf221f8c83d320 (patch)
treefa41bc28f2e4537a8e7ba3173ec34729625b4943 /editors/psgml
parent64a293a25350d1ae3c0c1050c30b431230de0d73 (diff)
downloadports-f0289e0cafa9128a455d4a9bddbf221f8c83d320.tar.gz
ports-f0289e0cafa9128a455d4a9bddbf221f8c83d320.zip
Fix a runtime problem on emacs20. Bump PORTREVISION.
Submitted by: yoichi
Notes
Notes: svn path=/head/; revision=140461
Diffstat (limited to 'editors/psgml')
-rw-r--r--editors/psgml/Makefile2
-rw-r--r--editors/psgml/files/patch-psgml-parse.el25
2 files changed, 26 insertions, 1 deletions
diff --git a/editors/psgml/Makefile b/editors/psgml/Makefile
index 27389c6d38ac..279bc72acaec 100644
--- a/editors/psgml/Makefile
+++ b/editors/psgml/Makefile
@@ -7,7 +7,7 @@
PORTNAME= psgml
PORTVERSION= 1.3.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= editors elisp
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= psgml
diff --git a/editors/psgml/files/patch-psgml-parse.el b/editors/psgml/files/patch-psgml-parse.el
new file mode 100644
index 000000000000..0c67d70a8d9e
--- /dev/null
+++ b/editors/psgml/files/patch-psgml-parse.el
@@ -0,0 +1,25 @@
+*** psgml-parse.el.orig Sun Mar 6 01:23:40 2005
+--- psgml-parse.el Wed Jun 8 12:47:33 2005
+***************
+*** 568,574 ****
+ (setq s1 (car l)
+ allfinal (and allfinal (sgml-state-final-p s1))
+ s2 (sgml-get-move s1 token)
+! res (and s2 (sgml-make-and-state s2 (remq s1 dfas) next))
+ l (cdr l)))
+ (cond (res)
+ (allfinal (sgml-get-move next token)))))
+--- 568,580 ----
+ (setq s1 (car l)
+ allfinal (and allfinal (sgml-state-final-p s1))
+ s2 (sgml-get-move s1 token)
+! res (and s2
+! (sgml-make-and-state
+! s2
+! (if (memq s1 dfas)
+! (delq s1 (copy-sequence dfas))
+! dfas)
+! next))
+ l (cdr l)))
+ (cond (res)
+ (allfinal (sgml-get-move next token)))))