aboutsummaryrefslogtreecommitdiff
path: root/editors/scite/Makefile
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2012-10-24 21:42:46 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2012-10-24 21:42:46 +0000
commit09352b6619bdf96427835539518fe4491eaaedf7 (patch)
treedce327fb61ec7cf4358d46df8c506b93dde3cdd1 /editors/scite/Makefile
parent911bd5ffb34186a991a55a5bf05c9cfda467fc33 (diff)
downloadports-09352b6619bdf96427835539518fe4491eaaedf7.tar.gz
ports-09352b6619bdf96427835539518fe4491eaaedf7.zip
- Update to 3.2.2.
- Trim Makefile header. PR: ports/172443 Submitted by: Naram Qashat <cyberbotx@cyberbotx.com> (maintainer) Feature safe: yes
Notes
Notes: svn path=/head/; revision=306357
Diffstat (limited to 'editors/scite/Makefile')
-rw-r--r--editors/scite/Makefile25
1 files changed, 16 insertions, 9 deletions
diff --git a/editors/scite/Makefile b/editors/scite/Makefile
index d5746bfb7229..8e5451a700e7 100644
--- a/editors/scite/Makefile
+++ b/editors/scite/Makefile
@@ -1,12 +1,8 @@
-# New ports collection makefile for: scite
-# Date created: 27 November 2000
-# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
-#
+# Created by: Maxim Sobolev <sobomax@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= scite
-PORTVERSION= 3.2.1
+PORTVERSION= 3.2.2
CATEGORIES= editors gnome
MASTER_SITES= SF/scintilla/SciTE/${PORTVERSION}
DISTNAME= ${PORTNAME}${PORTVERSION:S/.//g}
@@ -15,9 +11,12 @@ EXTRACT_SUFX= .tgz
MAINTAINER= cyberbotx@cyberbotx.com
COMMENT= Full-featured SCIntilla based text editor for GTK/GNOME
-LIB_DEPENDS= scintilla.2:${PORTSDIR}/x11-toolkits/scintilla
+LIB_DEPENDS= scintilla:${PORTSDIR}/x11-toolkits/scintilla
RUN_DEPENDS= xdg-open:${PORTSDIR}/devel/xdg-utils
+OPTIONS_DEFINE= DOCS FULL_BUFFER_MENU
+FULL_BUFFER_MENU_DESC= Show all files in buffer menu
+
WRKSRC= ${WRKDIR}/${PORTNAME}/gtk
USE_GMAKE= yes
@@ -27,10 +26,18 @@ MAKE_JOBS_SAFE= yes
MAN1= scite.1
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
+PORTDOCS= *
+.else
+PORTDOCS=
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|[(]CC[)]|(CXX)|g ; s|[(]CCOMP[)]|(CC)|g ; \
s| -Os||g' ${WRKSRC}/makefile
-.if defined(WITH_FULL_BUFFER_MENU)
+.if ${PORT_OPTIONS:MFULL_BUFFER_MENU}
@${REINPLACE_CMD} -e 's|30, "/Buffers|props.GetInt("buffers") > 30 ? props.GetInt("buffers") - 10 : 30, "/Buffers|g' ${WRKSRC}/SciTEGTK.cxx
.endif
@${REINPLACE_CMD} -e 's|netscape "file://$$(SciteDefaultHome)|xdg-open "file://${DOCSDIR}|' \
@@ -45,7 +52,7 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/Sci48M.png ${PREFIX}/share/pixmaps
@${MKDIR} ${DATADIR}
${INSTALL_DATA} ${WRKSRC}/../src/*.properties ${DATADIR}
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/../doc/*.html ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/../doc/*.jpg ${DOCSDIR}