aboutsummaryrefslogtreecommitdiff
path: root/editors/scite
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-11-23 19:35:50 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-11-23 19:35:50 +0000
commit7d50169d0d4bd2ab7fb96f2ffd04ef6e739f3cc9 (patch)
treebe656ca087424ed7400b465df23df82e90921ca1 /editors/scite
parentadb599850a1f845261c23aa563bb97ee9e5709d2 (diff)
downloadports-7d50169d0d4bd2ab7fb96f2ffd04ef6e739f3cc9.tar.gz
ports-7d50169d0d4bd2ab7fb96f2ffd04ef6e739f3cc9.zip
- Update to 3.6.2
PR: 204561 Submitted by: cyberbotx@cyberbotx.com (maintainer)
Notes
Notes: svn path=/head/; revision=402318
Diffstat (limited to 'editors/scite')
-rw-r--r--editors/scite/Makefile4
-rw-r--r--editors/scite/distinfo4
-rw-r--r--editors/scite/files/patch-makefile12
3 files changed, 10 insertions, 10 deletions
diff --git a/editors/scite/Makefile b/editors/scite/Makefile
index 3f327a2bb42d..b3dcf3773990 100644
--- a/editors/scite/Makefile
+++ b/editors/scite/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= scite
-PORTVERSION= 3.6.1
+PORTVERSION= 3.6.2
CATEGORIES= editors gnome
MASTER_SITES= SF/scintilla/SciTE/${PORTVERSION}
DISTNAME= ${PORTNAME}${PORTVERSION:S/.//g}
@@ -22,7 +22,7 @@ OPTIONS_DEFINE= DOCS
WRKSRC= ${WRKDIR}/${PORTNAME}/gtk
-USES= desktop-file-utils gmake pkgconfig tar:tgz
+USES= compiler:c++11-lib desktop-file-utils gmake pkgconfig tar:tgz
USE_GNOME= gtk20
MAKEFILE= makefile
diff --git a/editors/scite/distinfo b/editors/scite/distinfo
index 7184f229960d..ed19075027e4 100644
--- a/editors/scite/distinfo
+++ b/editors/scite/distinfo
@@ -1,2 +1,2 @@
-SHA256 (scite361.tgz) = bdffdc28c501dbb5e3dc6cbfe3808da2d574df983790c6ddfc2643040023a010
-SIZE (scite361.tgz) = 2347061
+SHA256 (scite362.tgz) = 6530d0d86c72485b815663e3b2c2987d59779340a71632ed8bb97a43530737a3
+SIZE (scite362.tgz) = 2368491
diff --git a/editors/scite/files/patch-makefile b/editors/scite/files/patch-makefile
index 4ca96963fef6..11340a082927 100644
--- a/editors/scite/files/patch-makefile
+++ b/editors/scite/files/patch-makefile
@@ -1,4 +1,4 @@
---- makefile.orig 2014-08-09 23:52:11 UTC
+--- makefile.orig 2015-09-22 01:37:15 UTC
+++ makefile
@@ -5,14 +5,6 @@
# GNU make does not like \r\n line endings so should be saved to CVS in binary form.
@@ -9,13 +9,13 @@
-# thread also need to create Position Independent Executable -> search online documentation
-SANITIZE = address
-#SANITIZE = undefined
--CXX = clang++ -fsanitize=$(SANITIZE) --std=c++0x -Wno-deprecated-register
+-CXX = clang++ -fsanitize=$(SANITIZE) -Wno-deprecated-register
-CC = clang -fsanitize=$(SANITIZE) -Wno-empty-body
-endif
ifdef GTK3
GTKVERSION=gtk+-3.0
-@@ -24,7 +16,7 @@
+@@ -24,7 +16,7 @@ endif
CONFIGFLAGS:=$(shell pkg-config --cflags $(GTKVERSION))
CONFIGLIB:=$(shell pkg-config --libs $(GTKVERSION) gthread-2.0 gmodule-no-export-2.0)
CONFIGTHREADS:=
@@ -24,9 +24,9 @@
ifndef prefix
ifdef gnomeprefix
prefix=$(gnomeprefix)
-@@ -113,8 +105,9 @@
- FilePath.o SciTEBase.o FileWorker.o Cookie.o Credits.o SciTEBuffers.o SciTEIO.o StringList.o \
- Exporters.o MatchMarker.o StringHelpers.o \
+@@ -114,8 +106,9 @@ FilePath.o SciTEBase.o FileWorker.o Cook
+ ExportHTML.o ExportPDF.o ExportRTF.o ExportTEX.o ExportXML.o \
+ MatchMarker.o StringHelpers.o \
PropSetFile.o MultiplexExtension.o DirectorExtension.o SciTEProps.o StyleDefinition.o StyleWriter.o Utf8_16.o \
- JobQueue.o GTKMutex.o IFaceTable.o $(COMPLIB) $(LUA_OBJS)
- $(CXX) `$(CONFIGTHREADS)` -rdynamic -Wl,--as-needed -Wl,--version-script lua.vers -DGTK $^ -o $@ $(CONFIGLIB) $(LIBDL) -lm -lstdc++