aboutsummaryrefslogtreecommitdiff
path: root/editors/scite
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-02-27 11:47:50 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2013-02-27 11:47:50 +0000
commitbbce14dcec28f0f2a7e7be6560896499cae3a618 (patch)
tree7f25a7e2d097b52461006a81233c98840f621851 /editors/scite
parentebc7255077a43fdc4ff8b62a534be20998119eba (diff)
downloadports-bbce14dcec28f0f2a7e7be6560896499cae3a618.tar.gz
ports-bbce14dcec28f0f2a7e7be6560896499cae3a618.zip
Update to 3.2.5
PR: ports/176458 Submitted by: Naram Qashat (maintainer)
Notes
Notes: svn path=/head/; revision=313047
Diffstat (limited to 'editors/scite')
-rw-r--r--editors/scite/Makefile2
-rw-r--r--editors/scite/distinfo4
-rw-r--r--editors/scite/files/patch-aa19
3 files changed, 11 insertions, 14 deletions
diff --git a/editors/scite/Makefile b/editors/scite/Makefile
index c2be292ded12..cc8dc510718a 100644
--- a/editors/scite/Makefile
+++ b/editors/scite/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= scite
-PORTVERSION= 3.2.4
+PORTVERSION= 3.2.5
CATEGORIES= editors gnome
MASTER_SITES= SF/scintilla/SciTE/${PORTVERSION}
DISTNAME= ${PORTNAME}${PORTVERSION:S/.//g}
diff --git a/editors/scite/distinfo b/editors/scite/distinfo
index 3dae01ea1743..6f9553a4d752 100644
--- a/editors/scite/distinfo
+++ b/editors/scite/distinfo
@@ -1,2 +1,2 @@
-SHA256 (scite324.tgz) = bd20b97513aee8e4584253d6ca31ec658bd4f098ceefb354889eb8a498cb5c08
-SIZE (scite324.tgz) = 1956084
+SHA256 (scite325.tgz) = ac3ca9588bb23ef21da2e22f6ef21416bbd7bf6957130a8e4057b3e5f3c58bef
+SIZE (scite325.tgz) = 1974782
diff --git a/editors/scite/files/patch-aa b/editors/scite/files/patch-aa
index d303c2304740..02cfc206dec9 100644
--- a/editors/scite/files/patch-aa
+++ b/editors/scite/files/patch-aa
@@ -1,15 +1,12 @@
---- makefile.orig 2012-06-01 10:26:56.000000000 +0200
-+++ makefile 2012-08-13 15:57:01.532542909 +0200
-@@ -5,16 +5,6 @@
+--- makefile.orig 2013-02-18 02:21:10.000000000 -0500
++++ makefile 2013-02-26 18:30:59.000000000 -0500
+@@ -5,13 +5,6 @@
# GNU make does not like \r\n line endings so should be saved to CVS in binary form.
.SUFFIXES: .cxx .o .h .a .c
-ifdef CLANG
--ifdef CLANG_ANALYZE
--ANALYZE=--analyze
--endif
--CC = clang $(ANALYZE)
--CCOMP = clang $(ANALYZE)
+-CC = clang --std=c++0x
+-CCOMP = clang -Wno-empty-body
-else
-CC = g++
-CCOMP = gcc
@@ -17,7 +14,7 @@
AR = ar
ifdef GTK3
-@@ -27,7 +17,7 @@
+@@ -24,7 +17,7 @@
CONFIGFLAGS:=$(shell pkg-config --cflags $(GTKVERSION))
CONFIGLIB:=$(shell pkg-config --libs $(GTKVERSION) gthread-2.0 gmodule-no-export-2.0)
CONFIGTHREADS:=
@@ -26,12 +23,12 @@
ifndef prefix
ifdef gnomeprefix
prefix=$(gnomeprefix)
-@@ -107,8 +97,9 @@
+@@ -109,8 +102,9 @@
$(PROG): SciTEGTK.o GUIGTK.o Widget.o \
FilePath.o SciTEBase.o FileWorker.o Cookie.o Credits.o SciTEBuffers.o SciTEIO.o StringList.o Exporters.o StringHelpers.o \
PropSetFile.o MultiplexExtension.o DirectorExtension.o SciTEProps.o StyleWriter.o Utf8_16.o \
- JobQueue.o GTKMutex.o IFaceTable.o $(COMPLIB) $(LUA_OBJS)
-- $(CC) `$(CONFIGTHREADS)` -rdynamic -Wl,--as-needed -Wl,--version-script lua.vers -DGTK $^ -o $@ $(CONFIGLIB) $(LIBDL) -lstdc++
+- $(CC) `$(CONFIGTHREADS)` -rdynamic -Wl,--as-needed -Wl,--version-script lua.vers -DGTK $^ -o $@ $(CONFIGLIB) $(LIBDL) -lm -lstdc++
+ JobQueue.o GTKMutex.o IFaceTable.o $(LUA_OBJS)
+ $(CC) -DGTK $(CXXFLAGS) -rdynamic -Wl,--version-script lua.vers $(LDFLAGS) \
+ -o $@ $^ -lscintilla -lscintilla_lexers -Wl,--as-needed $(CONFIGLIB)