aboutsummaryrefslogtreecommitdiff
path: root/editors/tamago
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2014-08-31 18:00:17 +0000
committerHiroki Sato <hrs@FreeBSD.org>2014-08-31 18:00:17 +0000
commit8845e6d921d53c36713e19cb47f8aa824e712e1a (patch)
tree6db4063da3d5deea9e3b75ad7d82e11b6911c019 /editors/tamago
parent4daf3a99d2df6351fa195a77fba6903226262c3b (diff)
downloadports-8845e6d921d53c36713e19cb47f8aa824e712e1a.tar.gz
ports-8845e6d921d53c36713e19cb47f8aa824e712e1a.zip
Add a patch forgotten in the previous commit.
Notes
Notes: svn path=/head/; revision=366804
Diffstat (limited to 'editors/tamago')
-rw-r--r--editors/tamago/Makefile8
-rw-r--r--editors/tamago/files/patch-Makefile.in45
2 files changed, 47 insertions, 6 deletions
diff --git a/editors/tamago/Makefile b/editors/tamago/Makefile
index ab3ded92a0d2..d570cffada33 100644
--- a/editors/tamago/Makefile
+++ b/editors/tamago/Makefile
@@ -41,11 +41,6 @@ PLIST_SUB+= HAS_JISX0213=""
PLIST_SUB+= HAS_JISX0213="@comment "
.endif
-post-patch:
- @${REINPLACE_CMD} -e '/^lispdir/s|@lispdir@|${STAGEDIR}&|' \
- -e 's|mkdir|${MKDIR}|' \
- ${WRKSRC}/Makefile.in
-
pre-configure:
@${REINPLACE_CMD} -e 's|emacs/site-lisp|${EMACS_NAME}/${EMACS_VER}/site-lisp|g' \
${WRKSRC}/configure
@@ -60,8 +55,9 @@ post-build:
post-install:
${INSTALL_PROGRAM} ${WRKSRC}/helper/egg-helper \
${STAGEDIR}${PREFIX}/bin/egg-helper
-
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${STAGEDIR}${DOCSDIR}
(cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR})
+.endif
.include <bsd.port.post.mk>
diff --git a/editors/tamago/files/patch-Makefile.in b/editors/tamago/files/patch-Makefile.in
new file mode 100644
index 000000000000..26e113eaec6a
--- /dev/null
+++ b/editors/tamago/files/patch-Makefile.in
@@ -0,0 +1,45 @@
+--- Makefile.in.orig 2004-11-22 03:53:05.000000000 +0900
++++ Makefile.in 2014-06-10 13:51:03.000000000 +0900
+@@ -113,32 +115,32 @@
+
+ install-site: all
+ echo "Egg system will be installed in ${lispdir}/egg...."; \
+- if [ -d ${lispdir}/egg ]; then \
++ if [ -d -p ${DESTDIR}${lispdir}/egg ]; then \
+ echo "Clean up the previsous installation...."; \
+- rm -rf ${lispdir}/egg/*; \
++ rm -rf ${DESTDIR}${lispdir}/egg/*; \
+ else \
+ echo "Make the directory ${lispdir}/egg..."; \
+- mkdir ${lispdir}/egg; \
++ mkdir -p ${DESTDIR}${lispdir}/egg; \
+ fi; \
+ #
+ for FILE in ${TOPSRCS} ${TOPELCS} ${INITELS}; \
+ do \
+- ${INSTALL_DATA} $${FILE} ${lispdir}/egg/; \
++ ${INSTALL_DATA} $${FILE} ${DESTDIR}${lispdir}/egg/; \
+ done; \
+ #
+- mkdir ${lispdir}/egg/egg ; \
++ mkdir -p ${DESTDIR}${lispdir}/egg/egg ; \
+ for FILE in ${EGGSRCS} ${EGGELCS} ; \
+ do \
+- ${INSTALL_DATA} $${FILE} ${lispdir}/egg/egg; \
++ ${INSTALL_DATA} $${FILE} ${DESTDIR}${lispdir}/egg/egg; \
+ done; \
+- touch ${lispdir}/egg/egg/.nosearch; \
++ touch ${DESTDIR}${lispdir}/egg/egg/.nosearch; \
+ #
+- mkdir ${lispdir}/egg/its ; \
++ mkdir -p ${DESTDIR}${lispdir}/egg/its ; \
+ for FILE in ${ITSSRCS} ${ITSELCS} ; \
+ do \
+- ${INSTALL_DATA} $${FILE} ${lispdir}/egg/its ; \
++ ${INSTALL_DATA} $${FILE} ${DESTDIR}${lispdir}/egg/its ; \
+ done; \
+- touch ${lispdir}/egg/its/.nosearch; \
++ touch ${DESTDIR}${lispdir}/egg/its/.nosearch; \
+
+
+ uninstall-site: