aboutsummaryrefslogtreecommitdiff
path: root/editors/teco
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-20 08:14:16 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-20 08:14:16 +0000
commit9fe7d907dc4a12597fc5f18e05ddca716d0c0916 (patch)
tree18437132f1edb0825eb44037c5f9511c40a7b738 /editors/teco
parenta3af4f48e1fabf3e62afcda13f5b71edf8f2e3ea (diff)
downloadports-9fe7d907dc4a12597fc5f18e05ddca716d0c0916.tar.gz
ports-9fe7d907dc4a12597fc5f18e05ddca716d0c0916.zip
Support staging
Notes
Notes: svn path=/head/; revision=345181
Diffstat (limited to 'editors/teco')
-rw-r--r--editors/teco/Makefile16
1 files changed, 7 insertions, 9 deletions
diff --git a/editors/teco/Makefile b/editors/teco/Makefile
index d380130aafb8..13f8cfd94d88 100644
--- a/editors/teco/Makefile
+++ b/editors/teco/Makefile
@@ -18,19 +18,17 @@ ALL_TARGET= #
DOCSFILES= src/readme.1st src/readme.lnx src/changes.txt src/aaout.txt \
src/problems.txt src/video.txt doc/teco.doc doc/wchart.txt
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS
+
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/src/tecoc ${PREFIX}/bin
- ${MKDIR} ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/lib/* ${DATADIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/tecoc ${STAGEDIR}${PREFIX}/bin
+ ${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/lib/* ${STAGEDIR}${DATADIR}
post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
.for FILE in ${DOCSFILES}
- ${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${FILE} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
- @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>