aboutsummaryrefslogtreecommitdiff
path: root/editors/ted
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
commit2b74a89bc8342f0b9b737c37d87737caf7b0ea1e (patch)
treec04604583d8be53b3ed7f10975be828c731f87cb /editors/ted
parent24315159daa0089f08acea4ba1b130fb6721ad5c (diff)
downloadports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.tar.gz
ports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.zip
- update png to 1.5.10
Notes
Notes: svn path=/head/; revision=297915
Diffstat (limited to 'editors/ted')
-rw-r--r--editors/ted/Makefile4
-rw-r--r--editors/ted/files/patch-bitmap-bmpng.c10
2 files changed, 13 insertions, 1 deletions
diff --git a/editors/ted/Makefile b/editors/ted/Makefile
index bdef16142df0..2b98000d60cf 100644
--- a/editors/ted/Makefile
+++ b/editors/ted/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ted
PORTVERSION= 2.22
+PORTREVISION= 1
CATEGORIES= editors
MASTER_SITES= ftp://ftp.nluug.nl/pub/editors/ted/
EXTRACT_SUFX= .src.tar.gz
@@ -17,7 +18,7 @@ COMMENT= X11 based RTF editor
LICENSE= GPLv2
LIB_DEPENDS= pcre.1:${PORTSDIR}/devel/pcre \
- png.6:${PORTSDIR}/graphics/png \
+ png15:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff \
paper.2:${PORTSDIR}/print/libpaper
RUN_DEPENDS= ${LOCALBASE}/share/ghostscript/fonts/a010013l.pfb:${PORTSDIR}/print/gsfonts
@@ -30,6 +31,7 @@ USE_XORG= xext xft
USE_ICONV= yes
USE_GHOSTSCRIPT_RUN= yes
GNU_CONFIGURE= yes
+CFLAGS+= -I${LOCALBASE}/include/libpng15
MAKE_ENV= DEF_AFMDIR="-DAFMDIR=\"\\\"${AFMDIR}/\\\"\"" \
DEF_INDDIR="-DINDDIR=\"\\\"${INDDIR}/\\\"\"" \
DEF_DOCUMENT_DIR="-DDOCUMENT_DIR=\"\\\"${DOCSDIR}/\\\"\"" \
diff --git a/editors/ted/files/patch-bitmap-bmpng.c b/editors/ted/files/patch-bitmap-bmpng.c
new file mode 100644
index 000000000000..7f9a5b18f25f
--- /dev/null
+++ b/editors/ted/files/patch-bitmap-bmpng.c
@@ -0,0 +1,10 @@
+--- bitmap/bmpng.c.orig 2012-04-01 11:57:27.000000000 +0200
++++ bitmap/bmpng.c 2012-05-04 12:44:03.000000000 +0200
+@@ -4,6 +4,7 @@
+ # include "bmintern.h"
+ # include "bmio.h"
+ # include <png.h>
++# include <pngpriv.h>
+ # include <appDebugon.h>
+ # include <sioFileio.h>
+ # include <utilEndian.h>