aboutsummaryrefslogtreecommitdiff
path: root/editors/texmacs
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-08-28 18:20:28 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-08-28 18:20:28 +0000
commit7d97cf724a3069bfa21ba0cc24cd103b96b997a9 (patch)
treeb2f1ea996d153e254a510c0e5eda8c30438a0518 /editors/texmacs
parent932f3c64d083d5592e126900e842db102170b5f6 (diff)
downloadports-7d97cf724a3069bfa21ba0cc24cd103b96b997a9.tar.gz
ports-7d97cf724a3069bfa21ba0cc24cd103b96b997a9.zip
- Fix build on -current
- Use OPTIONS helpers - shebangfix some perl scripts - Add missing file to plist - Don't try to remove directories installed by dependencies
Notes
Notes: svn path=/head/; revision=366444
Diffstat (limited to 'editors/texmacs')
-rw-r--r--editors/texmacs/Makefile73
-rw-r--r--editors/texmacs/files/patch-src__Kernel__Types__tree.cpp11
-rw-r--r--editors/texmacs/files/patch-src__Kernel__Types__tree.hpp11
-rw-r--r--editors/texmacs/files/patch-src__Typeset__Boxes__Basic__boxes.cpp11
-rw-r--r--editors/texmacs/files/patch-src__Typeset__boxes.hpp11
-rw-r--r--editors/texmacs/pkg-plist4
6 files changed, 71 insertions, 50 deletions
diff --git a/editors/texmacs/Makefile b/editors/texmacs/Makefile
index 401d95dd3749..0320fab42a7f 100644
--- a/editors/texmacs/Makefile
+++ b/editors/texmacs/Makefile
@@ -3,7 +3,7 @@
PORTNAME= texmacs
PORTVERSION= 1.0.7.21
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= editors print
MASTER_SITES= ftp://ftp.texmacs.org/TeXmacs/tmftp/source/ \
http://www.predatorlabs.net/dl/
@@ -16,8 +16,7 @@ LICENSE= GPLv3
LIB_DEPENDS= libguile.so:${PORTSDIR}/lang/guile
-USES= gmake shared-mime-info desktop-file-utils
-USE_PYTHON= yes
+USES= gmake shared-mime-info desktop-file-utils python shebangfix
USE_TEX= tex
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
@@ -27,54 +26,34 @@ MAKE_ARGS= CP="${CP} -R -f"
ALL_TARGET= ${PORTNAME:tu}
INSTALL_ICONS= yes
+SHEBANG_FILES= plugins/asymptote/bin/tm_asy2 \
+ plugins/feynmf/bin/bbox_add.pl \
+ plugins/asymptote/bin/perl-tm_asy
+
DATADIR= ${PREFIX}/share/TeXmacs
OPTIONS_DEFINE= FREETYPE GHOSTSCRIPT ICONV IMLIB2 PDF QT4
-OPTIONS_DEFAULT= FREETYPE GHOSTSCRIPT ICONV IMLIB2 QT4
+OPTIONS_DEFAULT=FREETYPE GHOSTSCRIPT ICONV IMLIB2 QT4
PDF_DESC= Experimental PDF renderer
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MFREETYPE}
-LIB_DEPENDS+= libfreetype.so:${PORTSDIR}/print/freetype2
-CONFIGURE_ARGS+= --with-freetype=linked
-.else
-CONFIGURE_ARGS+= --without-freetype
-.endif
-
-.if ${PORT_OPTIONS:MGHOSTSCRIPT}
-USE_GHOSTSCRIPT= yes
-CONFIGURE_ARGS+= --with-gs=yes
-.else
-CONFIGURE_ARGS+= --without-gs
-.endif
-
-.if ${PORT_OPTIONS:MICONV}
-USES+= iconv
-CONFIGURE_ARGS+= --with-iconv
-.else
-CONFIGURE_ARGS+= --without-iconv
-.endif
-
-.if ${PORT_OPTIONS:MIMLIB2}
-USE_EFL= imlib2
-CONFIGURE_ARGS+= --with-imlib2
-.else
-CONFIGURE_ARGS+= --without-imlib
-.endif
-
-.if ${PORT_OPTIONS:MPDF}
-CONFIGURE_ARGS+= --enable-pdf-renderer
-.endif
-
-.if ${PORT_OPTIONS:MQT4}
-USE_QT4= gui moc_build qmake_build rcc uic_build
-CONFIGURE_ARGS+= --with-qt --enable-qtpipes
-.else
-CONFIGURE_ARGS+= --disable-qt
-.endif
-
-.include <bsd.port.pre.mk>
+FREETYPE_LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2
+FREETYPE_CONFIGURE_WITH=freetype=linked
+
+GHOSTSCRIPT_USE= GHOSTSCRIPT=yes
+GHOSTSCRIPT_CONFIGURE_WITH= gs=yes
+
+ICONV_USES= iconv
+ICONV_CONFIGURE_WITH= iconv
+
+IMLIB2_USE= EFL=imlib2
+IMLIB2_CONFIGURE_ON= --with-imlib2
+IMLIB2_CONFIGURE_OFF= --without-imlib
+
+PDF_CONFIGURE_ON= --enable-pdf-renderer
+
+QT4_USE= QT4=gui,moc_build,qmake_build,rcc,uic_build
+QT4_CONFIGURE_ON= --with-qt --enable-qtpipes
+QT4_CONFIGURE_OFF= --disable-qt
post-patch:
@${GREP} -lR "#!/bin/bash" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
@@ -87,4 +66,4 @@ post-patch:
@${REINPLACE_CMD} -e 's|qdrawutil.h|qt4/Qt/qdrawutil.h|' \
${WRKSRC}/src/Plugins/Qt/QTMStyle.cpp
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/editors/texmacs/files/patch-src__Kernel__Types__tree.cpp b/editors/texmacs/files/patch-src__Kernel__Types__tree.cpp
new file mode 100644
index 000000000000..bd4f728664b3
--- /dev/null
+++ b/editors/texmacs/files/patch-src__Kernel__Types__tree.cpp
@@ -0,0 +1,11 @@
+--- ./src/Kernel/Types/tree.cpp.orig 2014-08-28 13:09:45.011154991 -0400
++++ ./src/Kernel/Types/tree.cpp 2014-08-28 13:10:18.050663990 -0400
+@@ -195,7 +195,7 @@
+ }
+
+ void
+-print_tree (tree t, int tab) {
++print_tree (tree t, int tab=0) {
+ int i;
+ for (i=0; i<tab; i++) cout << " ";
+ if (is_atomic (t)) cout << t->label << "\n";
diff --git a/editors/texmacs/files/patch-src__Kernel__Types__tree.hpp b/editors/texmacs/files/patch-src__Kernel__Types__tree.hpp
new file mode 100644
index 000000000000..87c4085325ec
--- /dev/null
+++ b/editors/texmacs/files/patch-src__Kernel__Types__tree.hpp
@@ -0,0 +1,11 @@
+--- ./src/Kernel/Types/tree.hpp.orig 2014-08-28 13:09:50.435479991 -0400
++++ ./src/Kernel/Types/tree.hpp 2014-08-28 13:10:38.328730991 -0400
+@@ -84,7 +84,7 @@
+ friend tree& operator << (tree& t, array<tree> a);
+ friend tm_ostream& operator << (tm_ostream& out, tree t);
+ friend tree operator * (tree t1, tree t2);
+- friend void print_tree (tree t, int tab=0);
++ friend void print_tree (tree t, int tab);
+ friend list<tree> as_trees (list<pointer> l);
+ friend class tree_pointer_rep;
+ friend class tree_position_rep;
diff --git a/editors/texmacs/files/patch-src__Typeset__Boxes__Basic__boxes.cpp b/editors/texmacs/files/patch-src__Typeset__Boxes__Basic__boxes.cpp
new file mode 100644
index 000000000000..a94809fa52d4
--- /dev/null
+++ b/editors/texmacs/files/patch-src__Typeset__Boxes__Basic__boxes.cpp
@@ -0,0 +1,11 @@
+--- ./src/Typeset/Boxes/Basic/boxes.cpp.orig 2014-08-28 13:13:07.420709990 -0400
++++ ./src/Typeset/Boxes/Basic/boxes.cpp 2014-08-28 13:13:15.171566990 -0400
+@@ -850,7 +850,7 @@
+ ******************************************************************************/
+
+ void
+-make_eps (url name, box b, int dpi) {
++make_eps (url name, box b, int dpi=600) {
+ double inch= ((double) dpi * PIXEL);
+ double cm = inch / 2.54;
+ SI w= b->x4 - b->x3;
diff --git a/editors/texmacs/files/patch-src__Typeset__boxes.hpp b/editors/texmacs/files/patch-src__Typeset__boxes.hpp
new file mode 100644
index 000000000000..c8adbc39e074
--- /dev/null
+++ b/editors/texmacs/files/patch-src__Typeset__boxes.hpp
@@ -0,0 +1,11 @@
+--- ./src/Typeset/boxes.hpp.orig 2014-08-28 13:13:20.617755990 -0400
++++ ./src/Typeset/boxes.hpp 2014-08-28 13:13:35.051223990 -0400
+@@ -255,7 +255,7 @@
+ friend class phrase_box_rep;
+ friend class remember_box_rep;
+ friend class effect_box_rep;
+- friend void make_eps (url dest, box b, int dpi= 600);
++ friend void make_eps (url dest, box b, int dpi);
+ };
+ ABSTRACT_NULL_CODE(box);
+
diff --git a/editors/texmacs/pkg-plist b/editors/texmacs/pkg-plist
index b4d95440fe81..527789b56062 100644
--- a/editors/texmacs/pkg-plist
+++ b/editors/texmacs/pkg-plist
@@ -4150,16 +4150,14 @@ share/icons/gnome/scalable/mimetypes/text-texmacs.svg
share/mime-info/texmacs.keys
share/mime-info/texmacs.mime
share/mime/packages/texmacs.xml
+share/mime/text/x-texmacs.xml
share/pixmaps/TeXmacs.xpm
@dirrmtry share/mime/text
-@dirrmtry share/mime/packages
@dirrmtry share/mime-info
-@dirrmtry share/mime
@dirrmtry share/icons/gnome/scalable/mimetypes
@dirrmtry share/icons/gnome/scalable/apps
@dirrmtry share/icons/gnome/scalable
@dirrmtry share/icons/gnome
-@dirrmtry share/icons
@dirrmtry share/application-registry
@dirrm %%DATADIR%%/texts/test
@dirrm %%DATADIR%%/texts