aboutsummaryrefslogtreecommitdiff
path: root/editors/texmaker
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-10-08 16:03:48 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2013-10-08 16:03:48 +0000
commit95580066a99e4a2a33be0c234f96249c988dde73 (patch)
tree611bfaf5552370ded4d493db5e8c995fe46dc287 /editors/texmaker
parent998596a21baea03a21c29d4f24f88a846b02e09b (diff)
downloadports-95580066a99e4a2a33be0c234f96249c988dde73.tar.gz
ports-95580066a99e4a2a33be0c234f96249c988dde73.zip
- Convert to USES=qmake
- Allow staging - Use options helpers - Use new LIB_DEPENDS syntax
Notes
Notes: svn path=/head/; revision=329804
Diffstat (limited to 'editors/texmaker')
-rw-r--r--editors/texmaker/Makefile29
1 files changed, 9 insertions, 20 deletions
diff --git a/editors/texmaker/Makefile b/editors/texmaker/Makefile
index 24d2d44ec137..8d4f85089140 100644
--- a/editors/texmaker/Makefile
+++ b/editors/texmaker/Makefile
@@ -10,46 +10,35 @@ MASTER_SITES= http://www.xm1math.net/texmaker/
MAINTAINER= makc@FreeBSD.org
COMMENT= LaTeX Development Environment
-LIB_DEPENDS= poppler:${PORTSDIR}/graphics/poppler \
- poppler-qt4:${PORTSDIR}/graphics/poppler-qt4
+LIB_DEPENDS= libpoppler.so:${PORTSDIR}/graphics/poppler \
+ libpoppler-qt4.so:${PORTSDIR}/graphics/poppler-qt4
RUN_DEPENDS= ${LOCALBASE}/share/icons/hicolor/index.theme:${PORTSDIR}/misc/hicolor-icon-theme
+USES= qmake
USE_BZIP2= yes
USE_GHOSTSCRIPT=yes
USE_QT4= gui network xml webkit \
moc_build qmake_build rcc_build uic_build
USE_TEX= latex dvipsk
-HAS_CONFIGURE= yes
-QMAKE_ARGS= PREFIX=${PREFIX} ICONDIR=${PREFIX}/share/pixmaps \
+QMAKE_ARGS= ICONDIR=${PREFIX}/share/pixmaps \
DESKTOPDIR=${DESKTOPDIR}
OPTIONS_DEFINE= GV XDVI
+
GV_DESC= View ps files with gv
+GV_RUN_DEPENDS+= gv:${PORTSDIR}/print/gv
+
XDVI_DESC= View dvi files with xdvi
+XDVI_RUN_DEPENDS+= xdvi:${PORTSDIR}/print/xdvik
STRIP_FILES= bin/texmaker
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MXDVI}
-RUN_DEPENDS+= xdvi:${PORTSDIR}/print/xdvik
-.endif
-
-.if ${PORT_OPTIONS:MGV}
-RUN_DEPENDS+= gv:${PORTSDIR}/print/gv
-.endif
-
pre-configure:
${REINPLACE_CMD} -e 's,/usr/include,${LOCALBASE}/include,g' \
-e 's,/usr/lib,${LOCALBASE}/lib,g' \
${WRKSRC}/texmaker.pro
-do-configure:
- @cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
- ${QMAKE} ${QMAKEFLAGS} ${QMAKE_ARGS} texmaker.pro
-
post-install:
- ${STRIP_CMD} ${STRIP_FILES:S,^,${PREFIX}/,}
+ ${STRIP_CMD} ${STRIP_FILES:S,^,${STAGEDIR}${PREFIX}/,}
.include <bsd.port.mk>