aboutsummaryrefslogtreecommitdiff
path: root/editors/texmakerx
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2013-10-02 07:45:46 +0000
committerJohn Marino <marino@FreeBSD.org>2013-10-02 07:45:46 +0000
commit2a15e8b848260a512b67ccc0d9d07bdf0e88b0df (patch)
treebd4b0fb6c4ee1811debb88b454324e51ceb79e9b /editors/texmakerx
parent6512f0235dc7aa288f6d5c66be25999dd1ff745d (diff)
Notes
Diffstat (limited to 'editors/texmakerx')
-rw-r--r--editors/texmakerx/Makefile1
-rw-r--r--editors/texmakerx/files/patch-qtsingleapplication_qtlocalpeer.cpp10
2 files changed, 11 insertions, 0 deletions
diff --git a/editors/texmakerx/Makefile b/editors/texmakerx/Makefile
index 2f788ef12b52..329f5823bd7d 100644
--- a/editors/texmakerx/Makefile
+++ b/editors/texmakerx/Makefile
@@ -21,6 +21,7 @@ USE_GHOSTSCRIPT=yes
USE_QT4= gui network xml moc_build qmake_build rcc_build \
uic_build qtestlib script
USE_TEX= latex dvipsk
+USE_DOS2UNIX= yes
HAS_CONFIGURE= yes
INSTALLS_ICONS= yes
MAKE_JOBS_UNSAFE= yes
diff --git a/editors/texmakerx/files/patch-qtsingleapplication_qtlocalpeer.cpp b/editors/texmakerx/files/patch-qtsingleapplication_qtlocalpeer.cpp
new file mode 100644
index 000000000000..f2680b978522
--- /dev/null
+++ b/editors/texmakerx/files/patch-qtsingleapplication_qtlocalpeer.cpp
@@ -0,0 +1,10 @@
+--- qtsingleapplication/qtlocalpeer.cpp.orig 2013-10-02 07:36:54.000000000 +0000
++++ qtsingleapplication/qtlocalpeer.cpp
+@@ -56,6 +56,7 @@ typedef BOOL(WINAPI*PProcessIdToSessionI
+ static PProcessIdToSessionId pProcessIdToSessionId = 0;
+ #endif
+ #if defined(Q_OS_UNIX)
++#include <unistd.h>
+ #include <time.h>
+ #endif
+