aboutsummaryrefslogtreecommitdiff
path: root/editors/texmakerx
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-11-22 12:55:18 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2013-11-22 12:55:18 +0000
commit4561e036c7993c4d648480996207fd794414df6b (patch)
treee5d8fb03dadf7c4332a432be715b65ed71eed93f /editors/texmakerx
parent2e206d8fad4d6aa3091a7410aba9abe1a3a41278 (diff)
- Convert to USES=qmake
- Use options helpers - Convert LIB_DEPENDS to new style Approved by: portmgr (blanket approval)
Notes
Notes: svn path=/head/; revision=334588
Diffstat (limited to 'editors/texmakerx')
-rw-r--r--editors/texmakerx/Makefile31
1 files changed, 8 insertions, 23 deletions
diff --git a/editors/texmakerx/Makefile b/editors/texmakerx/Makefile
index 329f5823bd7d..1d9413a2b0a6 100644
--- a/editors/texmakerx/Makefile
+++ b/editors/texmakerx/Makefile
@@ -9,37 +9,26 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/TexMakerX%20${PORTVERSION}
DISTNAME= ${PORTNAME}-${PORTVERSION:S:.0::}
MAINTAINER= lx@FreeBSD.org
-COMMENT= A LaTeX IDE derived from Texmaker
+COMMENT= LaTeX IDE derived from Texmaker
-LIB_DEPENDS= poppler:${PORTSDIR}/graphics/poppler \
- poppler-qt4:${PORTSDIR}/graphics/poppler-qt4
-RUN_DEPENDS= ${LOCALBASE}/share/icons/hicolor/index.theme:${PORTSDIR}/misc/hicolor-icon-theme
+LIB_DEPENDS= libpoppler.so:${PORTSDIR}/graphics/poppler \
+ libpoppler-qt4.so:${PORTSDIR}/graphics/poppler-qt4
WRKSRC= ${WRKDIR}/${PORTNAME}${PORTVERSION}
-USE_GHOSTSCRIPT=yes
-USE_QT4= gui network xml moc_build qmake_build rcc_build \
+USES= dos2unix qmake
+USE_GHOSTSCRIPT_RUN= yes
+USE_QT4= gui network xml moc_build rcc_build \
uic_build qtestlib script
USE_TEX= latex dvipsk
-USE_DOS2UNIX= yes
-HAS_CONFIGURE= yes
INSTALLS_ICONS= yes
MAKE_JOBS_UNSAFE= yes
OPTIONS_DEFINE= XDVI GV
GV_DESC= View ps files with gv
+GV_RUN_DEPENDS= xdvi:${PORTSDIR}/print/xdvik
XDVI_DESC= View dvi files with xdvi
-
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MXDVI}
-RUN_DEPENDS+= xdvi:${PORTSDIR}/print/xdvik
-.endif
-
-.if ${PORT_OPTIONS:MGV}
-RUN_DEPENDS+= gv:${PORTSDIR}/print/gv
-.endif
+XDVI_RUN_DEPENDS= gv:${PORTSDIR}/print/gv
post-patch:
@${REINPLACE_CMD} -e 's,^\(utilities.path =\).*,\1 ${DATADIR},' \
@@ -47,8 +36,4 @@ post-patch:
-e 's,/usr/lib,${LOCALBASE}/lib,g' \
${WRKSRC}/${PORTNAME}.pro
-do-configure:
- @cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
- ${QMAKE} PREFIX=${PREFIX} ${PORTNAME}.pro
-
.include <bsd.port.mk>