aboutsummaryrefslogtreecommitdiff
path: root/editors/texstudio
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2020-05-18 16:27:24 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2020-05-18 16:27:24 +0000
commit0126cf8ae5d3acfddbacf1961d9933d830478d4e (patch)
tree16dbf2cda6c230a02621e77dbaea903b70ed9d48 /editors/texstudio
parenta3ba8a0170291f0afe7d348be9cf661f0e270ed2 (diff)
downloadports-0126cf8ae5d3acfddbacf1961d9933d830478d4e.tar.gz
ports-0126cf8ae5d3acfddbacf1961d9933d830478d4e.zip
editors/texstudio: prepare for Qt5-5.15
Notes
Notes: svn path=/head/; revision=535748
Diffstat (limited to 'editors/texstudio')
-rw-r--r--editors/texstudio/Makefile5
-rw-r--r--editors/texstudio/files/patch-src_manhattanstyle.cpp10
-rw-r--r--editors/texstudio/files/patch-src_pdfviewer_PDFDocument.h10
-rw-r--r--editors/texstudio/files/patch-src_qcodeedit_lib_widgets_qfoldpanel.cpp10
4 files changed, 34 insertions, 1 deletions
diff --git a/editors/texstudio/Makefile b/editors/texstudio/Makefile
index 015c75ddd483..3b5f687bbcc9 100644
--- a/editors/texstudio/Makefile
+++ b/editors/texstudio/Makefile
@@ -31,7 +31,10 @@ USE_TEX= latex dvipsk
USE_GITHUB= yes
GH_ACCOUNT= ${PORTNAME}-org
-DOS2UNIX_FILES= ${PORTNAME}.pro
+DOS2UNIX_FILES= ${PORTNAME}.pro \
+ src/manhattanstyle.cpp \
+ src/pdfviewer/PDFDocument.h \
+ src/qcodeedit/lib/widgets/qfoldpanel.cpp
QMAKE_ARGS+= USE_SYSTEM_HUNSPELL=true USE_SYSTEM_QUAZIP=true
diff --git a/editors/texstudio/files/patch-src_manhattanstyle.cpp b/editors/texstudio/files/patch-src_manhattanstyle.cpp
new file mode 100644
index 000000000000..1cbdeb084094
--- /dev/null
+++ b/editors/texstudio/files/patch-src_manhattanstyle.cpp
@@ -0,0 +1,10 @@
+--- src/manhattanstyle.cpp.orig 2020-05-18 16:04:09 UTC
++++ src/manhattanstyle.cpp
+@@ -44,6 +44,7 @@
+ #include <QMainWindow>
+ #include <QMenuBar>
+ #include <QPainter>
++#include <QPainterPath>
+ #include <QPixmap>
+ #include <QPixmapCache>
+ #include <QPushButton>
diff --git a/editors/texstudio/files/patch-src_pdfviewer_PDFDocument.h b/editors/texstudio/files/patch-src_pdfviewer_PDFDocument.h
new file mode 100644
index 000000000000..63de26c6ea31
--- /dev/null
+++ b/editors/texstudio/files/patch-src_pdfviewer_PDFDocument.h
@@ -0,0 +1,10 @@
+--- src/pdfviewer/PDFDocument.h.orig 2020-05-18 16:11:58 UTC
++++ src/pdfviewer/PDFDocument.h
+@@ -30,6 +30,7 @@
+ #include <QGestureEvent>
+ #include <QPinchGesture>
+ #include <QTapGesture>
++#include <QPainterPath>
+ #include <QProgressDialog>
+
+ //#include "FindDialog.h"
diff --git a/editors/texstudio/files/patch-src_qcodeedit_lib_widgets_qfoldpanel.cpp b/editors/texstudio/files/patch-src_qcodeedit_lib_widgets_qfoldpanel.cpp
new file mode 100644
index 000000000000..7fb58b92fdb4
--- /dev/null
+++ b/editors/texstudio/files/patch-src_qcodeedit_lib_widgets_qfoldpanel.cpp
@@ -0,0 +1,10 @@
+--- src/qcodeedit/lib/widgets/qfoldpanel.cpp.orig 2020-05-18 16:22:00 UTC
++++ src/qcodeedit/lib/widgets/qfoldpanel.cpp
+@@ -28,6 +28,7 @@
+ #include "qdocumentline.h"
+
+ #include "qlanguagedefinition.h"
++#include <QPainterPath>
+
+ /*!
+ \ingroup widgets