aboutsummaryrefslogtreecommitdiff
path: root/editors/tweak
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2018-02-21 09:02:56 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2018-02-21 09:02:56 +0000
commit6225d12a8176933ecb0485049eebb5ab046b29e7 (patch)
tree304bf28a4ec01bd84134de6b51e5bdb3ea8cdc25 /editors/tweak
parentc86a54ec8a687530b9d6634e38fe8792ad6af752 (diff)
downloadports-6225d12a8176933ecb0485049eebb5ab046b29e7.tar.gz
ports-6225d12a8176933ecb0485049eebb5ab046b29e7.zip
- Add LICENSE
- Update WWW - Switch to upstream makefile
Notes
Notes: svn path=/head/; revision=462479
Diffstat (limited to 'editors/tweak')
-rw-r--r--editors/tweak/Makefile11
-rw-r--r--editors/tweak/files/Makefile.in7
-rw-r--r--editors/tweak/files/patch-Makefile42
-rw-r--r--editors/tweak/pkg-descr2
4 files changed, 49 insertions, 13 deletions
diff --git a/editors/tweak/Makefile b/editors/tweak/Makefile
index 4e1e78145104..d86ccfd519a7 100644
--- a/editors/tweak/Makefile
+++ b/editors/tweak/Makefile
@@ -4,16 +4,17 @@
PORTNAME= tweak
PORTVERSION= 3.02
CATEGORIES= editors
-MASTER_SITES= http://www.chiark.greenend.org.uk/~sgtatham/${PORTNAME}/
+MASTER_SITES= https://www.chiark.greenend.org.uk/~sgtatham/${PORTNAME}/
MAINTAINER= ports@FreeBSD.org
COMMENT= Efficient hex editor
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENCE
+
+USES= gmake ncurses
+
PLIST_FILES= bin/tweak \
man/man1/tweak.1.gz
-USES= ncurses uidfix
-MAKEFILE= ${FILESDIR}/Makefile.in
-MAKE_ENV+= BINDIR="${LOCALBASE}/bin" MANDIR="${PREFIX}/man/man"
-
.include <bsd.port.mk>
diff --git a/editors/tweak/files/Makefile.in b/editors/tweak/files/Makefile.in
deleted file mode 100644
index 1f82158c7aa4..000000000000
--- a/editors/tweak/files/Makefile.in
+++ /dev/null
@@ -1,7 +0,0 @@
-# $FreeBSD$
-
-PROG= tweak
-SRCS= actions.c btree.c buffer.c curses.c keytab.c main.c rcfile.c search.c
-LDADD= -lncurses
-
-.include <bsd.prog.mk>
diff --git a/editors/tweak/files/patch-Makefile b/editors/tweak/files/patch-Makefile
new file mode 100644
index 000000000000..6174b9a7d1cd
--- /dev/null
+++ b/editors/tweak/files/patch-Makefile
@@ -0,0 +1,42 @@
+--- Makefile.orig 2016-03-22 21:12:51 UTC
++++ Makefile
+@@ -16,15 +16,16 @@
+ # number in tweak.h, or else the resulting binary won't match
+ # the version number on the archive.
+
+-CC := gcc
+-CFLAGS := -g -c -Wall $(XFLAGS)
+-LINK := gcc
+-LFLAGS :=
+-LIBS :=
++CC ?= gcc
++CFLAGS ?= -g
++CFLAGS += -c -Wall $(XFLAGS)
++LINK ?= ${CC}
++LFLAGS ?=
++LIBS ?=
+
+-PREFIX=$(DESTDIR)/usr/local
+-BINDIR=$(PREFIX)/bin
+-MANDIR=$(PREFIX)/man/man1
++PREFIX?=/usr/local
++BINDIR?=$(PREFIX)/bin
++MANDIR?=$(PREFIX)/man/man1
+
+ TWEAK := main.o keytab.o actions.o search.o rcfile.o buffer.o btree.o
+
+@@ -63,10 +64,10 @@ release: tweak.1 btree.html
+ rm -rf reltmp
+
+ install: tweak tweak.1
+- mkdir -p $(BINDIR)
+- install tweak $(BINDIR)/tweak
+- mkdir -p $(MANDIR)
+- install -m 0644 tweak.1 $(MANDIR)/tweak.1
++ mkdir -p $(DESTDIR)$(BINDIR)
++ install tweak $(DESTDIR)$(BINDIR)/tweak
++ mkdir -p $(DESTDIR)$(MANDIR)
++ install -m 0644 tweak.1 $(DESTDIR)$(MANDIR)/tweak.1
+
+ clean:
+ rm -f *.o tweak tweak.1 btree.html
diff --git a/editors/tweak/pkg-descr b/editors/tweak/pkg-descr
index 8294beaf01d7..f0e6ab6bfbb4 100644
--- a/editors/tweak/pkg-descr
+++ b/editors/tweak/pkg-descr
@@ -4,4 +4,4 @@ useful for modifying binary files such as executables, editing disk or
CD images, debugging programs that generate binary file formats incorrectly,
and many other things.
-WWW: http://www.chiark.greenend.org.uk/~sgtatham/tweak/
+WWW: https://www.chiark.greenend.org.uk/~sgtatham/tweak/