aboutsummaryrefslogtreecommitdiff
path: root/editors/uzap
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2016-01-31 12:18:31 +0000
committerJohn Marino <marino@FreeBSD.org>2016-01-31 12:18:31 +0000
commit148e920b75009b4de703cb58ea21942e22f13923 (patch)
treecb8413008f703e83092ddefee2a7008e9410f10c /editors/uzap
parent2977b03ee7ab4553c51e9eae573ef7b207d6630a (diff)
downloadports-148e920b75009b4de703cb58ea21942e22f13923.tar.gz
ports-148e920b75009b4de703cb58ea21942e22f13923.zip
editors/uzap: document ncurses reqmt (USES+=ncurses), respect LDFLAGS
while here, regenerate remaining patch and rename both of them. approved by: infrastructure blanket
Notes
Notes: svn path=/head/; revision=407618
Diffstat (limited to 'editors/uzap')
-rw-r--r--editors/uzap/Makefile2
-rw-r--r--editors/uzap/files/patch-Makefile (renamed from editors/uzap/files/patch-a)6
-rw-r--r--editors/uzap/files/patch-b19
-rw-r--r--editors/uzap/files/patch-search.c11
4 files changed, 16 insertions, 22 deletions
diff --git a/editors/uzap/Makefile b/editors/uzap/Makefile
index f7d243808e68..77e4bc58d0d3 100644
--- a/editors/uzap/Makefile
+++ b/editors/uzap/Makefile
@@ -10,6 +10,8 @@ DISTNAME= ${PORTNAME}
MAINTAINER= joerg@FreeBSD.org
COMMENT= Visual binary file editor
+USES= ncurses
+
# Has been posted to alt.sources in 1989
# http://www.megalextoria.com/usenet-archive/news097f1/b120/alt/sources/00000521.html
NO_CDROM= This software may not be used to make a profit in any way.
diff --git a/editors/uzap/files/patch-a b/editors/uzap/files/patch-Makefile
index 67701b52ddf0..260e4fc677d9 100644
--- a/editors/uzap/files/patch-a
+++ b/editors/uzap/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig 1989-03-31 02:04:11.000000000 +0800
-+++ Makefile 2014-05-27 21:34:34.280623089 +0800
+--- Makefile.orig 1989-03-30 18:04:11 UTC
++++ Makefile
@@ -1,26 +1,28 @@
# Makefile for Uzap.
-BINDIR = /usr/local
@@ -13,7 +13,7 @@
uzap: uzap.o edit.o search.o screen.o
- cc -O uzap.o edit.o search.o screen.o -lcurses -ltermcap -o uzap
-+ $(CC) $(CFLAGS) uzap.o edit.o search.o screen.o -lcurses -ltermcap -o uzap
++ $(CC) $(CFLAGS) uzap.o edit.o search.o screen.o $(LDFLAGS) -lncurses -o uzap
uzap.o: uzap.c
- cc -c -O uzap.c
diff --git a/editors/uzap/files/patch-b b/editors/uzap/files/patch-b
deleted file mode 100644
index 39cfa5f07e90..000000000000
--- a/editors/uzap/files/patch-b
+++ /dev/null
@@ -1,19 +0,0 @@
-*** search.c.orig Thu Mar 30 20:04:12 1989
---- search.c Mon Jun 19 22:17:24 1995
-***************
-*** 217,223 ****
- }
- }
- for(x= 0; x < len - 1; x+= 2){
-! strcpy(hdigit, hex + (len - x - 2), 2);
- hdigit[2]= '\0';
-
- if(hdigit[0] < 96) hdigit[0]= hdigit[0] - 48;
---- 217,223 ----
- }
- }
- for(x= 0; x < len - 1; x+= 2){
-! strncpy(hdigit, hex + (len - x - 2), 2);
- hdigit[2]= '\0';
-
- if(hdigit[0] < 96) hdigit[0]= hdigit[0] - 48;
diff --git a/editors/uzap/files/patch-search.c b/editors/uzap/files/patch-search.c
new file mode 100644
index 000000000000..ccaebe7e1fe7
--- /dev/null
+++ b/editors/uzap/files/patch-search.c
@@ -0,0 +1,11 @@
+--- search.c.orig 1989-03-30 18:04:12 UTC
++++ search.c
+@@ -217,7 +217,7 @@ unsigned char hdigit[16], temp[128];
+ }
+ }
+ for(x= 0; x < len - 1; x+= 2){
+- strcpy(hdigit, hex + (len - x - 2), 2);
++ strncpy(hdigit, hex + (len - x - 2), 2);
+ hdigit[2]= '\0';
+
+ if(hdigit[0] < 96) hdigit[0]= hdigit[0] - 48;